Disclaimer

Esta ayuda en línea quiere ser una ayuda operativa para cuantos deseen empezar a trabajar enseguida con WebSite X5 para crear el propio sitio Web, Blog o Tienda de comercio electrónico.
Siguiendo paso a paso el procedimiento de desarrollo propuesto, se da una descripción exacta de la interfaz del programa, ilustrando todos los comandos y las opciones presentes en los menús, en los paneles y en las ventanas previstas.
Las explicaciones y las profundizaciones aquí propuestas, junto a la intuitiva lógica de trabajo y a la disponibilidad de las numerosas vistas previas actualizadas en tiempo real, permitirán a cualquiera trabajar fácilmente con WebSite X5 y obtener sitios atractivos, interesantes y profesionales.

La presente ayuda de WebSite X5 hace referencia a la versión EVOLUTION v. 9 pero, teniendo en cuenta las limitaciones específicas, puede ser útil consultarla también para trabajar con otras versiones del programa.

Concretamente, la guía está dividida en las siguientes secciones:
- | El ambiente de trabajo Aparecen ilustradas todas las funciones puestas a disposición por el software, en las distintas ventanas que se presentan durante la creación y publicación de un sitio.
- | Tutorial Se proponen algunos tutorial que simulan algunos procedimientos para resolver tareas específicas como la creación de un formulario para la recogida de datos o la predisposición de un área reservada mediante contraseña.
- | Aclaraciones Se brindan aclaraciones técnicas o teóricas adicionales.
- | Integración con Google Se proponen aclaraciones relativas al uso de algunas herramientas puestas a disposición por Google, finalizadas principalmente a la optimización de los sitios web.

Última actualización: versión 9.0.0


Sumario

Crear sitios Web, Tiendas Online y Blog en 5 pasos

WebSite X5 es el software ideal para crear los sitios Web que siempre has deseado tener. No requiere ningún conocimiento sobre programación y permite trabajar de modo completamente visual mediante una interfaz intuitiva y rica de numerosas vistas previas, actualizadas en tiempo real.

De este modo, WebSite X5 ayuda hasta la publicación del Sitio, garantizando simplicidad de uso, flexibilidad y amplios espacios de personalización.

En base a las elecciones efectuadas y a las predisposiciones definidas, WebSite X5 genera en automático el código de las Páginas en HTML5 + CSS 2.1 o 3 garantizando, así, plena compatibilidad con todas los Navegadores y los dispositivos móviles, además de una correcta indización por parte de los Motores de búsqueda.

Herramientas Web profesionales

Es preciso subrayar que, aún siendo muy fácil de usar, WebSite X5 pone a disposición una ampla gama de herramientas profesionales para:
- | Tiendas en línea con tarjeta de crédito | - | Zoom e imágenes panorámicas
- | Blog con Podcast y Videocast | - | Galerías de imágenes y vídeos
- | Motor de búsqueda interno | - | Gestión accesos y Áreas reservadas
- | Formularios de correo electrónico con filtros anti-spam | - | Gestión banner publicitarios
- | News y Sindicación web (RSS) | - | Creación de sitios multi-lengua

Una solución "todo en uno"

Además, WebSite X5 permite ahorrar tiempo y cansancio incluyendo ya todo lo que es necesario para la creación de un Sitio:
- | Editor para los template | - | 1.500 plantillas personalizables
- | Editor para las imágenes | - | 6.000 imágenes royalty free
- | Generador de los menús | - | Bibliotecas de botones
- | Motor FTP interno | - | Colección de Widget

Esta mezcla de simplicidad y exhaustividad de prestaciones es el motivo del éxito de WebSite X5: el software justo para quienquiera que desee crear Sitios Web.


Incomedia WebSite X5: ¿Qué es lo que hace?

Incomedia WebSite X5 permite crear de forma simple y rápida Sitios Web, carritos de comercio electrónico, Blog, álbumes fotográficos digitales o presentaciones interactivas. Los proyectos se desarrollan a través del menú estructurado y articulado por niveles: de esta forma usted podrá insertar un número ilimitado de páginas.

El usuario puede establecer en cada una de las páginas la disposición de cada uno de los objetos que el programa ofrece, tales como: Textos, Imágenes, Tablas, Animaciones Flash™, Vídeo, Sonidos, Galerías, Objetos HTML, Formularios de envío de correo electrónico.

WebSite X5 contiene numerosas funciones interesantes para la edición de imágenes, evitándole así la necesidad de recurrir a utilizar otros programas gráficos. Gracias a la función que guarda automáticamente la imágenes en formato comprimido, el usuario ni siquiera debe preocuparse de optimizar las fotografías antes de insertarlas.

El amplio archivo de modelos gráficos, el editor interno para la creción de botones tridimensionales, las amplias posibilidades de personalización gráfica, la introducción de una intro, la predisposición de la elección de los idiomas de consulta, la creación de un área de acceso reservado mediante contraseña, la posibilidad de crear y administrar Blog, Sindicación web (Feed RSS) y tiendas en línea habilitadas para el pago con tarjeta de crédito, permiten enriquecer el sitio haciéndolo completo y profesional.

Al final, WebSite X5 permite publicar directtamente en red el proyecto realizado, sin tener que recurrir a programas de FTP (archivo transfer Protocol) externos.

Trabajando con WebSite X5

WebSite X5 opera con un asistente (wizard), es decir una guía visual que acompaña paso a paso en la creación de un sitio Web completo, funcional y gráficamente atractivo.

Se requieren solamente 5 pasos para crear su sitio Web:
1. | Ajustes Generales Después de haber especificado el Proyecto al que trabajar y de haber insertado algunas informaciones de carácter general, como la Descripción y las Palabras clave para la indización de los motores de búsqueda, WebSite X5 permite definir la gráfica del Sitio. Es posible escoger entre más de 1.500 plantillas predefinidas o liberar la propia creatividad predisponiendo una propia Plantilla desde cero. Gracias al especial editor interno, el Encabezamiento y el Pie de página de las Plantillas pueden ser libremente personalizados.
2. | Creación del mapa Empezando por la Página de inicio, WebSite X5 permite proceder a la definición de la estructura de árbol del Sitio. Se pueden prever todos los niveles de profundización necesarios para organizar un número ilimitado de páginas. En función del mapa se creará dinámicamente el Menú de navegación. El Mapa podrá ser modificado en cualquier momento para poder efectuar fácilmente la actualizacion del Sitio.
3. | Creación de las Páginas La creación y la disposición de cada uno de los objetos, es tan sencilla que solamente requiere seleccionar y arrastrar objetos tales como: Textos, Tablas, Imágenes, Animaciones, Vídeo y Audio, Galerías, Formularios para la recogida de datos y el envío de correo electrónico, Lista de productos, Código HTML y Widget. Los objetos importados pueden ser personalizados y completados con la inserción de Enlaces a recursos tanto internos como externos. Gracias al editor gráfico incorporado es posible girar, corregir o aplicar filtros, máscaras y marcos a todas las imágenes importadas sin la necesidad de recurrir a software externos.
4. | Definición de las predisposiciones avanzadas Para completar la personalización del sitio, es posible proceder a la definición del Estilo de elementos como los Menús de navegación, los Textos, la ventana ShowBox y los correos electrónicos. Gracias a un especial editor interno, es posible proceder a la creación de Botones tridimensionales para los que se puede prever el efecto correspondiente al paso del puntero del ratón (effetto di mouseover). Además, el sitio web puede ser completado con herramientas como: Página de bienvenida con columna sonora y elección del idioma de consulta; Áreas reservadas con gestión de los accesos y de los usuarios; Mensajes publicitarios; Sindicación web (RSS); Blog; Carrito de la compra de comercio electrónico.
5. | Exportar WebSite X5 permite también la publicación en red del Sitio Web creado: se inicia una sesión FTP mediante la cual se transfieren al servidor todos los archivos necesarios para que el sitio sea visible inmediatamente en el Web. WebSite X5 soporta la conexión segura y permite ahorrar tiempo trabajando en multi-conexión y publicando sólo los archivos modificados. Además de la publicación en Internet es posible prever la exportación del Proyecto en un distinto disco del propio ordenador o crear fácilmente una copia de seguridad.


Diferencias entre las versiones

Versiones disponibles

WebSite X5 está disponible en distintas versiones entre las que las principales son: Evolution y Compact.

Para obtener una panorámica de las diferencias entre las versiones disponibles, consultar la página: http://www.websitex5.com/compare


El ambiente de trabajo

Proponiéndose como un comportamiento guiado, WebSite X5 se presenta como una serie de ventanas a través de las cuales el usuario llega a introducir todas las informaciones necesarias para crear y publicar un Sitio Internet completo, funcional y gráficamente atrayente.

Todas las páginas de pantalla presentadas por el Programa tienen en común una interfaz gráfica idéntica que prevé una botonera superior, una lateral y una inferior siempre invariadas, y una ventana central que cambia en función de la fase de trabajo y, por lo tanto, de las informaciones requeridas.

Botonera superior

-

Ayuda: permite abrir la presente Ayuda en línea. Mediante la flecha hacia la izquierda del botón Ayuda es posible acceder también a los comandos:
- | Sumario: para activar la presente Ayuda en línea.
- | Vídeo Tutorial: para acceder a una serie de Vídeos Tutorial especialmente realizados para explicar cómo empezar a trabajar con el Programa.
- | WebSite X5 Gallery: para acceder a una rica y variada Galería de sitios creados con WebSite X5 y señalados directamene por sus autores.
- | WebSite X5 Templates: para visualizar y descargar nuevas plantillas gráficas, eligiendo entre las propuestas por Incomedia o por otros autores, tanto gratuitos como de pago.
- | Servicio técnico: para acceder al Servicio técnico que permite consultar el archivo de las FAQ o abrir un ticket de asistencia.
- | www.websitex5.com: para acceder al Sitio Internet de referencia para el Programa.
- | Informaciones sobre WebSite X5: para visualizar una ventana en la que se presentan algunas informaciones sobre el Programa.

-

Guardar [CTRL + S]: permite guardar el proyecto. El proyecto es automáticamente archivado en la Carpeta de los Proyectos especificada en la ventana Preferencias.

Para crear una copia del Proyecto, en lugar de usar un comando Guardar como..., basta utilizar el comando Duplicar disponible en la ventana Selección de proyecto.

-

Prueba: permite visualizar mediante el Browser interno una Vista previa en local del Sitio realizado.

Si se deja activa la opción Crear las Páginas durante la modificación del Proyecto disponible en la ventana Preferencias, cada vez que se termina una modificación (y, por ejemplo, se hace clic en un botón Aceptar o en un botón Siguiente), el Programa recrea todo lo relacionado con la modificación misma. Esto permite mantener siempre actualizada la Vista previa del sitio en local y poderla visualizar sin tiempos de espera.
Además, es posible activar también la opción Guardar en cada Vista previa, siempre presente ventana Preferencias, de modo que haciendo clic en el botón Prueba se efectúe también la memorización del Proyecto.
Para forzar la creación de la Vista previa del Sitio es posible mantener pulsada la tecla CTRL haciendo clic en el botón Prueba.

Botonera lateral

WebSite X5 permite llegar a la realización de un Sitio Internet en sólo 5 pasos. Así, los botones que quedan siempre a disposición en la columna izquierda de la ventana del Programa, sirven para indicar qué fase del proceso de creación del Sitio se está afrontando o para permitir pasar directamente a una de ellas, independientemente del orden en que son presentadas.

 | Elección del Proyecto
1. | Ajustes generales
2. | Creación del mapa
3. | Creación de páginas
4. | Ajustes avanzados
5. | Exportar

Botonera inferior

- | Atrás: permite volver a la ventana anterior para modificar ajustes ya definidos.
- | Siguiente: avanza a la próxima ventana para proseguir con la creación del Sitio web.


Bienvenidos a Incomedia WebSite X5

Esta ventana de Benvenida es la primera a la que se accede después de haber abierto WebSite X5 y tiene la función de proponer enlaces a recursos y materiales en línea útiles para trabajar lo mejor posible con el software. Concretamente, estos enlaces son presentados mediante una botonera lateral organizada como sigue:

 Vídeo Tutorial
Para visualizar una serie de Vídeos Tutorial útiles para comprender cómo empezar a trabajar con el Programa.

WebSite X5 Gallery
Para visitar la Galería, o sea, el archivo en línea de los Sitios realizados con WebSite X5 que han sido señalados directamente por sus autores.

WebSite X5 Templates
Para acceder a la sección Plantillas X5 del sitio oficial de WebSite X5 y descargar nuevas plantillas que añadir a la lista de las pre-instaladas.

Soporte
Para conectarse al Centro de asistencia, disponible en italiano, inglés y alemán, y consultar las respuestas a las preguntas más frecuentes o solicitar asistencia.

Preferencias
Para abrir la ventana Preferencias mediante la cual es posible predisponer algunos parámetros generales inherentes al funcionamiento del programa.

Buscar actualizaciones
Para verificar la disponibilidad de actualizaciones online para la versión instalada de WebSite X5.

Además de esta botonera, la ventana de Bienvenida presenta contenidos que, si está activada la conexión a Internet, pueden ser actualizados en el tiempo proponiendo argumentos como: informaciones sobre el estado de actualización del Programa instalado, Noticias, Contenidos especiales (Artículos de profundización, WhitePaper, Tips&Tricks), nuevos Vídeos Tutorial, ofertas y promociones en curso.

Si no está disponible la conexión a Internet, como contenido de la ventana de Bienvenida se carga una página estándar. Esta misma página estándar es propuesta incluso si está desactivada la opción Buscar actualizaciones al iniciar el programa disponible en la ventana Preferencias.

Una vez explorados los contenidos de la ventana de Bienvenida, es posible iniciar la creación de un Sitio simplemente haciendo clic en el botón Iniciar.


Ventana Preferencias

Esta ventana, abierta por el botón Preferencias de la Página de Bienvenida, permite predisponer algunos parámetros generales inherentes al funcionamiento del programa.

Las opciones disponibles son:

-

Carpeta de los Proyectos: permite especificar la carpeta dentro de la cual se guardará el archivo de Proyecto (archivo Project.IWP), tanto en el caso de creación de un nuevo Proyecto, como en el caso de importación de un Proyecto ya existente (ver, Elección del Proyecto| Importar Proyecto). Si se especifica aquí, haciendo clic en el botón Guardar durante el trabajo de desarrollo del Sitio, el Proyecto será guardado sin que se pida la carpeta de destino.

-

Buscar actualizaciones al inicar el Programa: activo por defecto, permite verificar automáticamente la disponibilidad de actualizaciones en cada inicio del Programa. Para efectuar esta búsqueda, el Programa se conecta al Servidor Incomedia a través de Internet.

Se aconseja dejar activa esta opción para tener la certeza de trabajar siempre con la versión más actualizada de WebSite X5.

-

Guardar en cada Vista previa: permite guardar automáticamente el Proyecto cada vez que, mediante el comando Prueba, se visualice su vista previa en el Navegador en local.

-

Hacer Copia de seguridad cada vez que se guarda: activa por defecto, hace que se cree automáticamente una Copia de seguridad (archivo Backup.IWP) antes de cada vez que se guarda el Proyecto.

-

Hacer Copia de seguridad en cada publicación: hace que se cree automáticamente una Copia de seguridad (archivo Uploaded_TimesTemp.IWP, donde "TimesTemp" indica la fecha y la hora relativos a la creación de la copia de seguridad) del Proyecto cada vez que se efectúa la publicación en línea del Sitio (ver, Exportación del Sitio a Internet).

Según la opción predispuesta, en cada memorización o publicación, se crea automáticamente una Copia de seguridad de la versión del Proyecto precedente a la memorización o publicación: esta copia recibe el nombre de Backup.IWP o Uploaded_TimesTemp.IWP dentro de la Carpeta de los Proyectos.
Para restablecer una Copia de seguridad es preciso, después de haber eliminado el archivo de Proyecto Project.IWP, nombrar de nuevo el archivo Backup.IWP o el archivo Uploaded_TimesTemp.IWP en Project.IWP.

-

Crear las Páginas durante la modificación del Proyecto: activa por defecto, permite hacer que las Páginas relativas al Sitio sean creadas ya durante la modificación del Proyecto.

Concretamente, cada vez que se termina una modificación (y, por ejemplo, se hace clic en un botón ACEPTAR o en un botón Siguiente), el Programa crea de nuevo todo lo relacionado con la modificación misma. Esto permite mantener siempre actualizada la Vista previa del Sitio en local y poderla visualizar sin tiempos de espera.

-

Número máximo de procesos simultáneos: permite predisponer el número de procesos (o Thread) iniciados por el Programa que deben ser efectuados simultáneamente por el ordenador.

La técnica de subdividir un proceso en varios que después son ejecutados contemporáneamente es indicada como Multithreading y, para funcionar, debe ser soportada por el ordenador. Es decir, el Multithread intenta aprovechar al máximo la unidad de cálculo del ordenador haciéndole efectuar varios thread en paralelo. Así pues, gracias a esta técnica, un programa que, como WebSite X5, ha sido desarrollado subdividiendo la carga de trabajo en varios thread, puede obtener notables mejoras en sus prestaciones.
Para obtener una real ventaja del Multithreading es preciso valorar la configuración hardware del ordenador en el que se trabaja. Se aconseja empezar con 5 procesos simultáneos y probar a modificar dicho parámetro, aumentándolo progresivamente, para identificar el número mejor según las propias exigencias.

-

Script para el envío de los correos electrónicos: permite elegir qué script debe ser utilizado para el envío de los correos electrónicos manejado por el programa en relación, por ejemplo, al uso del Objeto Formulario de envío de correo electrónico o a la creación de un Carrito de la compra de comercio electrónico. Por defecto se utiliza el Script completo: en el caso que dicho script no funcione a causa de las configuraciones del Servidor empleado, se recomienda intentar sustituirlo y predisponer las opciones Servidor de baja calidad o Script de bajo nivel.

-

Método de envío de los datos de los Formularios de correo electrónico: permite elegir qué metodo de invío de los datos se debe utilizar para enviar los datos del Objeto Formulario de envío de correo electrónico. Por defecto se utiliza el método POST pero, puesto que algunos Servidores podrían no estar adecuadamente predispuestos para soportarlo, es posible elegir el método GET.

Como se sabe, el protocolo HTTP (Hypertext transfer Protocol) es el utilizado como sistema principal para la transmisión de informaciones en la Web. Este protocolo funciona en base a un mecanismo de pregunta/respuesta en el que el Client efectúa una pregunta y el Servidor restituye una respuesta. En general, el Client corresponde al Navegador y el Servidor al Sitio Web.
Los mensajes HTTP de pregunta/respuesta tienen, obviamente, una sintaxis propia. En particular, en los mensajes de pregunta es necesario especificar un método y, de entre los disponibles, los más comunes son GET y POST.
El metodo GET se usa para obtener el contenido del recurso indicado como objeto de la pregunta (por ejemplo la página web que se desea tener).
El método POST, en cambio, se usa normalmente para enviar informaciones al Servidor (por ejemplo los datos de un form).
Así pues, para el caso específico de los form de correo electrónico, es más correcto utilizar el método POST pero, puesto que no puede ser soportado por el Servidor, WebSite X5 permite aprovechar en sustitución el método GET.


Elección del Proyecto

Una vez activado WebSite X5, después de la Página de Bienvenida inicial, se accede a la ventana Elección del Proyecto donde hay que especificar a qué Proyecto se desea trabajar.

Es posible elegir si crear un nuevo Proyecto o si modificar uno ya realizado anteriormente.

-

Crear un nuevo Proyecto: al seleccionar esta opción se inicia la realización de un nuevo Sitio web del que es preciso especificar enseguida el nombre, escribiéndolo en el campo especial que está debajo. Se podrá guardar el Proyecto creado mediante el botón Guardar siempre disponible en la botonera superior.

Durante las operaciones de memorización no es necesario especificar la ruta de acceso puesto que los Proyectos son tratados automáticamente por el programa y guardados en la Carpeta de los Proyectos predispuesta mediante la ventana Preferencias.

-

Editar un Proyecto existente: activando esta opción se abre un Proyecto creado anteriormente para poder modificarlo o actualizarlo.

Todos los Proyectos ya existentes son visualizados en una lista especial. Para seleccionar más fácilmente qué Proyecto abrir, es posible escoger entre distintas visualizaciones: Iconos grandes, [image] Títulos, [image] Lista y [image] Detalles. Además, mediante el comando [image] Mostrar grupos es posible hacer que todos los Proyectossean agrupados y mostrados en base a la fecha de la última modificación.

La lista de los proyectos existentes puede ser modificada con los siguientes comandos:
- | Importar: permite importar, mediante la ventana Importar Proyecto abierta, un Proyecto precedentemente creado y exportado (ver, Exportar el Proyecto) con WebSite X5 desde un ordenador diverso.
- | Renombrar: permite modificar el nombre del Proyecto seleccionado.
- | Duplicar: permite crear una copia del Proyecto seleccionado.
- | Eliminar: permite eliminar el Proyecto seleccionado.

Temas relacionados:
- | Importar Proyecto
- | Exportar el Proyecto


Exportar y optimizar el Proyecto

Elección del Proyecto| Importar Proyecto

Esta ventana, abierta por el botón Importar presente en Elección del Proyecto, permite importar un Proyecto precedentemente creado en un ordenador distinto y exportado mediante la función Exportar el Proyecto. En efecto, gracias a esta específica función de exportación, es posible obtener un único archivo comprimido (archivo en formato .IWZIP) que contiene tanto el archivo de Proyecto original (archivo en formato .IWP) como todos los archivos a él vinculados (por ejemplo, relativos a Imágenes, Vídeo o Animaciones importadas).

Concretamente, la ventana Importar proyecto presenta las siguientes opciones:
- | Archivo de Proyecto por importar: permite seleccionar el archivo de Proyecto (archivo en formato .IWZIP) que importar.
- | Carpeta donde copiar los archivos vinculados al Proyecto: permite especificar la carpeta dentro de la cual se deben copiar los archivos vinculados al archivo de Proyecto. De este modo es posible saber qué carpeta abrir para poder tomar los archivos vinculados al Proyecto.

Consejos Práticos

Una vez creado un Proyecto en el ordenador A, si se desea desplazarlo a un ordenador B, es preciso proceder como sigue:

-

En el ordenador A
- | Abrir el Proyecto y, en el Paso 5 - Exportar, elegir la opción Exportar el Proyecto.
- | Especificar la Carpeta de destino para el proyecto y confirmar.

-

Transferir el archivo comprimido obtenido por la exportación (o sea, el archivo MiProyecto.iwzip, donde "MiProyecto" es el nombre del Proyecto inicial) del ordenador A al ordenador B.

-

En el ordenador B
- | Abrir el Programa y en la ventana Elección del Proyecto hacer clic en el botón Importar: utilizar la ventana Importar proyecto abierta para seleccionar el archivo comprimido precedentemente exportato y transferido (o sea, MiProyecto.iwzip).
- | Siempre en la ventana Importar proyecto especificar la carpeta dentro de la cual se deben copiar todos los archivos vinculados al archivo de Proyecto.
- | Una vez terminada la fase de importación, seleccionar el Proyecto y hacer clic en el botón Siguiente para proceder con el desarrollo o la actualización del Sitio.

Como ya se ha dicho, el archivo .IWZIP obtenido con la exportación es un archivo comprimido en el que están incluídos tanto el archivo de Proyecto original como los archivos a él vinculados. Una vez importado, este archivo es automáticamente decomprimido:

-

el archivo de Proyecto .IWP es guardado en la Carpeta de los Proyectos predispuesta mediante la ventana Preferencias y aparece visualizado en la Lista de los Proyectos en la ventana Elección del Proyecto;

-

en cambio, los archivos vinculados son guardados en la carpeta indicada que es organizada en sub-carpetas en base al siguiente criterio:
- | Sub-carpeta General: contiene los archivos definidos en los Ajustes Generales como el icono del Sitio, las imágenes/animaciones utilizadas en la Plantilla personalizada o para la personalización del Encabezamiento del Sitio.
- | Sub-carpetas ObjImage, ObjVideo, ObjFlash, etc.: contienen los archivos usados para la creación de los Objetos individuales utilizados en las diferentes Páginas del Sitio.
- | Sub-carpeta Advanced: contiene los archivos definidos en las Predisposiciones avanzadas como el cursor para los enlaces, las imágenes para los puntos lista de los sub-menús, los iconos del Carrito de la compra de comercio electrónico, las banderas para la elección del idioma de consulta, etc.
- | Sub-carpeta Links: contiene los archivos vinculados a los enlaces contenidos en cualquier parte del Sitio.
- | Sub-carpeta Aspect: contiene los archivos utilizados para definir el aspecto de las Celdas de la Rejilla de paginación.

Temas relacionados:
- | Elección del Proyecto
- | Exportar el Proyecto


Ajustes Generales

Esta ventana inicial, la primera del Paso 1, tiene el objetivo de recoger, mediante oportunos campos, algunas informaciones necesarias para configurar los parámetros de base del Proyecto en el que se está trabajando.

Es importante, por ejemplo, definir un título, especificar la URL, predisponer un idioma y prever códigos y metatag necesarios para la activación de servicios adicionales como el de las estadísticas de acceso.
Todos estos parámetros pueden ser predispuestos enseguida o también en un segundo momento.

Concretamente, las opciones disponibles se presentan en las siguientes secciones:
- | Sección General
- | Sección Avanzado


Ajustes Generales - Sección General

Ajustes Generales| Sección General

En la Sección General de la ventana Ajustes generales es posible especificar los siguientes parámetros:

-

Título del Sitio: en este campo se puede escribir el título que se desea dar al Sitio. Este título aparecerá en la Barra del título del Navegador (Browser) y es, obviamente, un parámetro importante para permitir a los usuarios y Motores de búsqueda que localicen correctamente el Sitio.
Como Título del sitio se toma automáticamente el nombre asignado al Proyecto (ver: Elección del Proyecto): en cualquier caso, el Título del Sitio puede ser modificado y establecido en base al tema tratado y a las exigencias de optimización específicas.

-

Autor del Sitio: en este campo se puede escribir el nombre de la persona o de la sociedad que debe figurar como autor del Sitio. El nombre del autor aparece en el código HTML de las páginas realizadas como valor del metatag <author>: de este modo se pone la firma en el trabajo hecho.

-

Dirección URL del Sitio: en este campo se puede introducir la dirección URL (por ejemplo, http://www.misitio.com) en la que se podrá encontrar el Sitio una vez publicado. Esta información es necesaria para el correcto funcionamiento de eventuales Sindicación web (RSS), del Carrito de la compra de comercio electrónico y del SiteMap que es automáticamente creado y conectado por el Programa.

-

Descripción del sitio: en este campo se puede introducir una breve descripción del Sitio web. El contenido de esta descripción debe ser conciso, eficaz y significativo para el sitio al que se hace referencia. esta descripción, en efecto, será utilizada en el código HTML como contenido del metatag <description> y será analizda por los spider de los Motores de búsqueda.

-

Palabras clave para la búsqueda: en este campo se pueden introducir palabras clave (separadas entre sí por una coma) que sean relevantes para la identificación del Sitio web. Las palabras clave serán introducidas en el código HTML como valor del metatag <keywords> y podrán ser utilizadas por los Motores de búsqueda.

La descripción del Sitio y la lista de Palabras clave introducidas mediante estos campos aparecen automáticamente asociadas a la Página de inicio del Sitio.
Ahora bien, para una mejor optimización del Sitio se recomienda asociar a cada Página, o al menos a las más importantes, una Descripción y una lista de Palabras clave específicas. Para hacer esto basta acceder a la ventana Creación del mapa, seleccionar la Página en la que se desea trabajar y hacer clic en el comando Propiedades de la página.

-

Idioma: en este campo es posible especificar el Idioma del sitio. En base al Idioma elegido, se utiliza la correspondiente versión de los textos insertados automáticamente por el programa: enlaces a anclas internas, etiquetas del Objeto Formulario de envío de correo electrónico, etiquetas y textos del Carrito de la compra de comercio electrónico, textos del Mapa del Sitio.

Para poder modificar los textos insertados automáticamente por el Programa o agregar nuevos idiomas basta hacer clic en el botón [image] y utilizar las opciones disponibles en la ventana abierta Gestión de contenido de Idioma. (ver, Cómo manejar los Idiomas para los textos insertados en automático).

-

Icono para el Sitio: en este campo es posible especificar qué icono (archivo .ico o .png) asociar a las páginas Web del Sitio. Este icono será visualizado a la izquierda de la URL en la barra de las direcciones del Navegador Internet.

Como icono asociado a un Sitio (o favicon, por el inglés de favorites icon) se puede utilizar una imagen con formato .ICO, .PNG, .GIF y .JPG.
Mientras que los archivos .ICO son utilizados tal como son, para los archivos en formato .PNG, .GIF y .JPG, independientemente del tamaño que tengan, WebSite X5 crea automáticamente una copia como archivo .PNG de 16x16 pixel y utiliza dicha copia como favicon.

Temas relacionados:

-

Cómo manejar los Idiomas para los textos insertados en automático


Ajustes Generales - Sección Avanzado

Ajustes Generales| Sección Avanzado

En la Sección Avanzado de la ventana Ajustes generales es posible especificar las siguientes parámetros:

-

Código personalizado para la sección HEAD: en este campo es posible escribir el código HTML que se desea introducir dentro de la sección <head> de todas las Páginas. Esta función es muy útil si se desean incluir las bibliotecas y las Hojas de estilo (CSS) externas o internas.

-

Metatag de control para Google WebMaster Central: en este campo es posible insertar el metatag de verificación necesario para poder utilizar las herramientas puestas a disposición por Google Webmaster Central.

Para más información sobre el servicio Google WebMaster Central y para obtener una cuenta, hacer clic en el botón [image] y acceder al Sitio oficial: http://www.google.com/webmasters/.

-

Código para la activación de las Estadísticas: en este campo es posible insertar el código necesario para activar los servicios de estadísticas sobre el Sitio, como por ejemplo Google Analytics, y tener informaciones útiles sobre la cantidad y la calidad de las visitas recibidas.

Para más información sobre el servicio Google Analytics y para obtener una cuenta, hacer clic en el botón [image] y acceder al Sitio oficial: http://www.google.com/analytics/.

-

Crear el Mapa del sitio automáticamente: activa por defecto, esta opción permite que se cree y se conecte automáticamente el SiteMap del sitio.

Para que el SiteMap sea construido y funcione correctamente, es necesario indicar un dirección URL válida en el campo Dirección URL del sitio presente en la Sección General de la ventana Ajustes generales.

-

Activar protección de acceso al código HTML: activando esta opción, las páginas del Sitio publicado son protegidas deshabilitando el clic de la tecla derecha del ratón para solicitar la visualización del código fuente o la copia de las imágenes presentes.

Temas relacionados:
- | Qué hacer para poder usar Google WebMaster Tools
- | Cómo activar un servicio de estadísticas como, por ejemplo, Google Analytics
- | Cómo crear y conectar el SiteMap del Sitio


Selección de plantillas

Elección de la Plantilla

Uno de los factores que influyen en el éxito de un Sitio Web es seguramente el layout gráfico. En efecto, aún antes de llegar a los contenidos y a la estructura de navegación, el aspecto del Sitio es lo que llama la atención del navegador, influyendo de manera determinante en el juicio que se hará de él. Es fácil comprender que un diseño cuidado y profesional es interpretado como un indicio de un Sitio de calidad, del cual valdrá la pena profundizar los contenidos.

WebSite X5 permite definir el aspecto del Sitio eligiendo la plantilla gráfica que aplicar de una galería de más de 1.500 plantillas, o bien creando una propia plantilla personalizada empezando desde cero.

Todos las plantillas predefinidas han sido estudiadas en los más mínimos detalles para poder garantizar un óptimo resultado y se presentan en 4 distintas variantes de estilo para poderse adaptar más fácilmente a exigencias específicas. Gracias al especial Editor interno, todos las plantillas predefinidas pueden ser también ampliamente personalizadas.

Así pues, en primer lugar, para definir el estilo gráfico del sitio web, es necesario seleccionar una de las siguientes opciones:
- | Plantilla personalizada: para proceder a la definición de una propia plantilla de estilo empezando desde cero.
- | Plantilla predefinida: para aplicar una de las plantillas predeterminadas, eligiendo entre las propuestas.

Si se decide utilizar una plantilla predeterminada, es posible elegir qué plantilla aplicar explorando la Lista de las plantillas disponibles. Dado el elevado número, para hacer más simple la elección, las plantillas disponibles han sido divididas en categorías temáticas. Una vez seleccionada una categoría mediante el especial menú, aparece visualizada una miniatura de todas las plantillas compredidas en ella. Una vez seleccionada una miniatura, aparece visualizada una Vista previa de tamaño mayor.

Después de haber seleccionado una plantilla es posible empezar la definición de las siguientes Opciones:

-

Tipo de Menú: permite definir la estructura del Sitio eligiendo, en prática, como predisponer el menú de navegación fija. Es posible escoger entre las estructuras con Menú Vertical y con Menú horizontal.

En las precedentes versiones de WebSite X5, la elección entre Menú horizontal y Menú Vertical se efectuaba en la ventana Elección del tipo de menú que en la actual versión 9 ya no está presente.

-

Estilos: para cada plantilla están disponibles 4 distintas variantes de estilo, cada una representada por una pequeña imagen de vista previa. Para visualizar la Vista previa ampliada relativa a una variante o para seleccionarla basta hacer clic en ella.

En la precedente versión 8 de WebSite X5, para cada plantilla estaban disponibles 4 Variantes de color: las actuales Variantes de estilo se distinguen porque no presentan sólo paletas de colores distintas, sino también predisposiciones y elementos gráficos diferentes.

-

Ajuste del color: además de las 4 Variantes de estilo predeterminadas, mediante el especial cursor es posible utilizar el Ajuste del color para dar una nueva y original variante de color a la plantilla. Gracias a esta opción, las variantes gráficas son potencialmente infinitas.

Las plantillas están optimizadas para una visualización de 1024 X 768 pixeles. Si se desea realizar un sitio con diferente resolución, se puede utilizar la Plantilla personalizada.

Temas relacionados:
- | Cómo está organizada la carpeta Plantillas relativa a las plantillas preinstaladas
- | Dónde encontrar nuevas plantillas para WebSite X5


Cómo está organizada la carpeta Plantillas relativa a las plantillas preinstaladas

Si se desea modificar una plantilla preinstalada o añadir en la lista de las plantillas disponibles una propia plantilla, puede ser útil comprender cómo y dónde se guardan durante la instalación de WebSite X5.

Los archivos gráficos relativos a las distintas plantillas predeterminadas son guardados en la sub-carpeta /Plantillas de la carpeta de instalación del Programa.

Por ejemplo, los archivos relativos a la plantilla "City" presente en la categoría "2.Travel" son guardados con las siguientes rutas de acceso:
- | /Templates/2.Travel/City/Hor - para las plantillas con el Menú de navegación horizontal;
- | /Templates/2.Travel/City/Ver - para las plantillas con el Menú de navegación vertical.
En las subcarpetas /Hor y /Ver están presentes otras subcarpetas nombradas con un número de 1 a 4. Cada una de estas 4 subcarpetas corresponde a una Variante de estilo de la plantilla. En efecto, en la ventana Selección de plantillas, colocando el ratón sobre los botones que permiten elegir la Variante de estilo que aplicar, aparece, en una ToolTip, la indicación del número correspondiente al nombre de la subcarpeta.

En la subcarpeta de la plantilla (/Templates/2.Travel/City) está presente también el archivo settings.xml. Este archivo de texto contiene algunos parámetros de base como: ContentHorWidth y ContentVerWidth (la anchura de los contenidos por plantilla con menu horizontal o vertical), MenuHorWidth (la anchura del menú horizontal), MenuHorHeight (la altura del menú horizontal). Los valores de estos parámetros están expresados en pixel.

Por último, dentro de las subcarpetas #1, #2, #3 y #4 se encuentran los archivos gráficos (archivos JPG) relativos a las imágenes utilizadas para la composición de la plantilla.

Además de las 4 subcarpetas citadas, en las carpetas /Hor y /Ver están presentes también los siguientes archivos, comunes a las 4 variantes de estilo:
- | index.html: contiene el código relativo a la estructura de base de la plantilla.
- | template.css: es la hoja de estilo en la que están contenidas la instrucciones necesarias para definir algunas predisposiciones de base sobre la presentación de los contenidos.

Temas relacionados:

-

Selección de plantillas


Dónde encontrar nuevas plantillas para WebSite X5

Si se está buscando una nueva plantilla que utilizar en la creación o en la remodelación del propio sitio Web, se pueden encontrar muchas nuevas plantillas en WebSite X5 Templates, la sección del sitio oficial de WebSite X5 alcanzable mediante la dirección www.websitex5.com/templates.

En WebSite X5 Templates se encontrarán numerosas plantillas gráficas nuevas, realizadas por Incomedia o por otros usuarios, tanto gratuitas como de pago, y se podrá descargarlas y utilizarlas para el propio proyecto.

Es posible, además, colaborar personalmente al crecimiento del archivo de las plantillas proponiendo los propios trabajos. En efecto, si se es un apasionado de gráfica Web, es posible convertirse en autor afiliado, proponer las propias plantillas y ganar por esta actividad. Para más información sobre la afiliación www.websitex5.com/templates/affiliates

Así pues, es recomendable visitar periódicamente WebSite x5 templates para ver qué hay de nuevo: si se deseas, es posible subscribir la Sindicación web (RSS) para mantenerse costantemente al día sobre las últimas novedades.

Temas relacionados:

-

Elección de la Plantilla


Plantilla personalizada

WebSite X5 permite crear una propria plantilla de estilo personalizada empezando desde cero: para hacerlo basta seleccionar la opción Plantilla personalizada presente en la ventana Selección de plantillas y hacer clic en el botón Siguiente.

Para facilitar el trabajo, la ventana Plantilla personalizada ofrece una Vista previa en la que aparece visualizada una representación esquemática de la Página. Es posible elegir la sección a modificar de la lista, o bien, también es posible hacer clic directamente en las distintas áreas de la estructura de la Página para poderlas seleccionar, modificar su aspecto con los especiales comandos y ver enseguida el resultado de las acciones efectuadas.

En primer lugar, para crear una plantilla personalizada es necesario especificar el Tipo de menú, o sea, dónde y cómo se debe colocar el Menú de navegación dentro de todas las Páginas del Sitio.
Las alternativas posibles son: Horizontal - Menú sobre el encabezamiento, [image] Horizontal - Menú debajo del encabezamiento, [image] Vertical - Menú a la izquierda.

 En las precedentes versiones de WebSite X5, la elección entre Menú horizontal y Menú Vertical se efectuaba en la ventana Elección del tipo de menú pero en la actual versión 9 ya no está presente este menú.

Una vez elegido el tipo de Menú, es preciso seleccionar la Sección de página en la que se desea trabajar.

Las secciones en que está dividida la Página son:

 Fondo de la Página: es el área externa a la Página y es visualizada cuando la ventana del Navegador es abierta con tamaño superior respecto a la resolución del Sitio.

Encabezamiento: también llamado "header" o "banner" superior y consiste en una sección, principalmente gráfica, ideal para contener elementos como título y subtítulo del Sitio, el logotipo de la empresa, campos de búsqueda, menús de servicio con los enlaces, por ejemplo, para la visualización del mapa o para la elección del idioma de consulta.

Menú: es el área destinada a contener la navegación fija, o sea, las opciones de primer nivel del menú que deben estar presentes, inalteradas, en cada página del Sitio. Obviamente, la posición de esta área cambia en base a la estructura del Sitio elegida.

Contenido de la página: es el área destinada al contenido real de las Páginas y, eventualmente, de los submenús de navegación.

Pie de página: es otra sección principalmente gráfica que tiene la finalidad de cerrar visualmente la Página. En general, en esta área están colocados elementos como notas, disclaimer, copyright, número de identificación fiscal, direcciones de correo electrónico.

Fondo del pie de página: es la parte del fondo del Sitio que empieza exactamente a la altura del Pie de página. Si está predispuesto como Transparente, el Fondo del pie de página es tratado como parte integrante del Fondo de la página y asume su mismo aspecto. En casos particulares (por ejemplo, si se desea una banda para el pie de página que ocupe toda la anchura de la ventana del Navegador), puede ser útil disponer un Fondo del pie de página distinto del Fondo de la página.

Para todas las áreas anteriormente mencionadas es posible utilizar las siguientes opciones:
- | Color: permite especificar, mediante la ventana Color abierta, el color de fondo para el área de la Página seleccionada.
- | Archivo imagen: permite especificar una imagen ( .jpg , .gif o .png ) que introducir como fondo para el área de la Página seleccionada. En el caso del Encabezamiento o del Pie de página es posible prever también una animación Flash (.swf).
- | Repetir: esta opción permite especificar si la imagen utilizada como fondo de la celda debe repetirse o no. La imagen puede repetirse de forma horizontal, vertical o en ambas direcciones, con el propósito de llenar el espacio disponible. Además, sólo para la sección Fondo de la página, es posible hacer que la imagen sea adaptada, o sea, cambiada en sus dimensiones de modo que cubra todo el fondo: en este caso, quizás no se respeten las proporciones originales.
- | Alineación: esta opción permite alinear la imagen insertada en relación al área de la Página seleccionada.

Sólo para el área Fondo de la página está disponible la opción:

-

Imagen de fondo fija: activando esta opción, la imagen introducida como fondo de la página es mantenida fija incluso cuando el contenido de la página se hace deslizar mediante la barra de desplazamiento.

Para las áreas Encabezamiento y Menú está disponible la opción:

-

Anchura: presenta el valor expresado en pixel de la anchura del área de la Página seleccionada. Para el Tipo de menú Vertical, el valor de la Anchura está predeterminado por defecto a 960 pixel para la sección Encabezamiento y a 120 pixel para la sección Menú pero, en cualquier caso, se puede modificar libremente. Para el Tipo de menú Horizontal, en cambio, el valor de la Anchura predeterminado para el Encabezamiento es tomado automáticamente también para el Menú, el Contenido de la página y el Pie de página.

El valor de la anchura predeterminado por defecto está calculado para obtener un Sitio optimizado para una visualización a 1024x768 pixel.

Para las áreas Encabezamiento, Menú (sólo para el Tipo de menú Horizontal) y Pie de página está disponible la opción:

-

Altura: presenta el valor expresado en pixel de la altura del área de la Página seleccionada.

Por último, para las secciones Fondo de la página, Menú y Contenido de la página están disponibles las opciones:

-

Margen Superior / Margen Inferior: permiten especificar, respectivamente, el valor en pixel que predisponer para los márgenes superior e inferior. El margen es el espacio vacío existente entre el borde de la sección y su contenido.

Sólo para las secciones Menú y Contenido de la página están disponibles también las opciones:

-

Margen izquierdo / Margen derecho: permiten especificar, respectivamente, el valor en pixel que predisponer para los márgenes izquierdo y derecho.

La anchura efectiva de las Páginas del Sitio viene dada por la anchura de la sección Contenido de la página (dependiente del área Encabezamiento) menos el margen izquierdo y el margen derecho.

El encabezado de la plantilla realizada puede ser completado con la inserción de textos, imágenes, animaciones Flash, presentaciones, campos de búsqueda y enlaces: las opciones necesarias son presentadas en la ventana Editor de plantilla a la que se accede haciendo clic en el botón Siguiente.

Temas relacionados:
- | Elección de la Plantilla
- | Editor de plantilla


Editor de plantilla

Después de haber elegido una de las plantillas predeterminadas en la ventana Selección de plantillas o después de haber creado una plantilla desde cero mediante la ventana Plantilla personalizada, se accede a la ventana Editor de plantilla. Mediante las secciones Encabezamiento y Pie de página de esta ventana es posible personalizar, respectivamente, el Encabezamiento y/o el Pie de página de la plantilla misma añadiendo Textos, Imágenes, Animaciones Flash, Presentaciones, Código HTML, Campos de búsqueda y Enlaces.

 Tanto trabajando en la imagen del Encabezamiento como en la del Pie de página, los comandos y las opciones disponibles son idénticos.

Si en las secciones Encabezamiento o Pie de página está introducida como fondo una Animación Flash, la ventana Editor de plantilla no permite su personalización.

Como se ve, la ventana presenta un editor gráfico al interno del cual, inmediatamente debajo de la Barra herramientas, aparece automáticamente la imagen utilizada como fondo del Encabezamiento o del Pie de página de la plantilla elegida (tanto predeterminada como personalizada): la imagen es visualizada en escala 1:1 y, si es necesario, se puede deslizar mediante la especial barra de desplazamiento horizontal. Sobre esta imagen se muestra, en tiempo real, todas las modificaciones aportadas con los comandos disponibles.

Inmediatamente debajo de la imagen cargada está presente una Barra de Estado en la que aparece:
- | Posición: muestra las coordenadas X e Y que identifican la posición del ángulo superior derecho del Objeto seleccionado.
- | Tamaño: muestra el valor expresado en pixel de la anchura y de la altura del objeto seleccionado.

Una vez introducido un Objeto mediante el especial comando de la Barra herramientas, es posible seleccionarlo y modificarlo con las opciones presentes en el recuadro que toma el nombre del objeto mismo.

Así pues, se puede tener un Recuadro Encabezamiento / Pie de página, un Recuadro Texto, un Recuadro Imagen, un Recuadro Animación Flash, un Recuadro Presentación, un Recuadro Código HTML y un Recuadro Campo de búsqueda.

Además, en común con los Objetos Texto, Imagen y Presentación, está disponible el Recuadro Efectos.

Temas relacionados:
- | Selección de plantillas
- | Plantilla personalizada


Editor de plantilla| Barra de herramientas

En la ventana Editor de plantilla, la barra de herramientas del editor gráfico contiene los siguientes comandos:

 Cortar [CTRL+X] - Copiar [CTRL + C] - Pegar [CTRL + V]
Permiten, respectivamente, cortar, copiar y pegar el objeto seleccionado.

Deshacer [CTRL+Z]
Permite anular la ultima acción realizada.

Traer al primer plano - Llevar al segundo plano
Permiten, respectivamente, llevar el objeto seleccionado al primer plano o al segundo, o sea, delante o detrás de todos los demás Objetos eventualmente superpuestos.

Asociar un enlace
Permite predisponer un enlace en el texto, en la imagen o en las imágenes de la Presentación seleccionadas. Es posible definir los ajustes del enlace mediante la ventana abierta Enlace.

Posición y Tamaño
Permite definir, mediante la ventana abierta, las coordenadas que determinan la posición y el tamaño del Objeto seleccionado. La opción Mantener relación, activa por defecto, hace que en las operaciones de modificación del tamaño se mantentan las proporciones originales del objeto.

Insertar texto -Insertar imagen -Insertar una animación Flash -Insertar Presentación -Insertar código HTML - Insertar campo de búsqueda
Permiten, respectivamente, insertar un Texto, una Imagen, una Animación Flash, una Presentación, el código HTML o un Campo de búsqueda.
La Presentación está formada por una secuencia de imágenes que pasan automáticamente una tras otra: puede ser útil para crear banner, también con finalidad publicitaria.
Mediante la inserción de Código HTML es posible añadir cualquier tipo de contenido: de este modo se puede superar ampliamente las posibilidades ofrecidas por los comandos.
Por último, el Campo de búsqueda aprovecha un motor interno para permitir al usuario efectuar búsquedas en los contenidos de todo el Sitio.

Las Animaciones Flash y los Objetos Código HTML introducidos son visualizados sólo cuando el sitio es abierto en el Navegador.

Temas relacionados:

-

Editor de plantilla


Editor de plantilla| Recuadro Encabezamiento / Pie de página

En la ventana Editor de plantilla, haciendo clic directamente en la imagen de fondo de las secciones Encabezamiento y Pie de página se selecciona y es posible utilizar las siguientes opciones presentes el recuadro Encabezamiento / Pie de página:
- | Archivo imagen: permite visualizar la ruta de acceso del archivo gráfico utilizado. La imagen presente puede ser sustituida con una nueva imagen: pueden ser utilizados archivos con formato JPG, GIF, PNG, BMP, PSD, TIF, DIB, PCX, RLE, TGA, WMF.
- | Guardar como imagen JPG: en fase de creación del Sitio, los Objetos texto y los Objetos imagen añadidos en el Encabezamiento/Pie de Página se fundirán con la imagen de fondo utilizada que será guardada automáticamente como un nuevo archivo en formato PNG. La elección del formato PNG permite mantener eventuales transparencias predispuestas. Si no es preciso gestionar transparencias particulares, es posible activar la opción Guardar como imagen JPG para obtener una imagen de fondo de tamaño inferior.

 Conocer la ruta de acceso del archivo gráfico utilizado como fondo del Encabezamiento/Pie de Página puede ser útil para poder identificar más fácilmente dicho archivo, abrirlo, modificarlo con un editor externo y guardar una copia que sustituya al original.

Temas relacionados:

-

Editor de plantilla


Editor de plantilla| Recuadro Texto

En la ventana Editor de plantilla, seleccionando un Objeto de texto introducido en las secciones Encabezamiento y Pie de página es posible utilizar las siguientes opciones presentes en el recuadro Texto:
- | Contenido: esta opción permite introducir el texto deseado.
- | Fuente: permite especificar, mediante la ventana abierta, el tipo de fuente, el estilo y las dimensiones en puntos del texto.
- | Color Texto / Color Fondo: permiten definir, mediante la ventana Color abierta, el color para del rótulo y para el fondo del texto introducido.

Temas relacionados:

-

Editor de plantilla


Editor de plantilla| Recuadro Imagen

En la ventana Editor de plantilla, seleccionando un Objeto Imagen introducido en las secciones Encabezamiento y Pie de página es posible utilizar las siguientes opciones presentes en el recuadro Imagen:
- | Archivo imagen: permite seleccionar el archivo gráfico relativo a la imagen a introducir. Pueden ser utilizados archivos con formato JPG, GIF, PNG, BMP, PSD, TIF, DIB, PCX, RLE, TGA, WMF.
- | Archivo Imagen al pasar el ratón: permite seleccionar un segundo y distinto archivo gráfico que será visualizado cuando se pase el ratón sobre la imagen misma. Esta opción es especialmente útil para la creación de botones con efecto pulsado/soltado.
- | Habilitar Transparencia: al activar esta opción el efecto de transparencia es aplicado en la imagen, haciendo invisible el color seleccionado.
- | Transparencia: permite especificar, mediante la ventana Color abierta, el color de la imagen introducida que debe ser invisible si se activa la opción Habilitar transparencia. En estos casos la herramienta "Cuentagotas" que está en la ventada de la paleta de color, resulta muy útil ya que permite "succionar" el color exacto directamente de la imagen.
- | Tolerancia: esta opción permite especificar el factor de tolerancia para ser aplicado en la transparencia. Cuanto mayor sea el valor de la tolerancia, mayor será el área de transparencia de la imagen.

Temas relacionados:

-

Editor de plantilla


Editor de plantilla| Recuadro Animación Flash

En la ventana Editor de plantilla, seleccionando un Objeto de Animación Flash introducido en las secciones Encabezamiento y Pie de página es posible utilizar las siguientes opciones presentes en el recuadro Animación Flash:
- | Archivo Animación: esta opción permite seleccionar el archivo SWF relativo a la Animación Flash que introducir.
- | Fondo transparente: al activar esta opción, el fondo de la animación se hace invisible.

Temas relacionados:

-

Editor de plantilla


Editor de plantilla| Recuadro SlideShow

En la ventana Editor de plantilla, seleccionando un Objeto Presentación introducido en las secciones Encabezamiento y Pie de página es posible utilizar las siguientes opciones presentes en el recuadro Presentación:
- | Lista de imágenes a visualizar: muestra la lista de las imágenes que componen la Presentación. Para cada imagen introducida, se presenta la ruta de acceso del archivo además de, si están presentes, la indicación del efecto y del enlace asociados. Seleccionando un archivo de la lista se obtiene su visualización en la vista previa. También es posible efectuar una selección múltiple de los archivos utilizando los comandos CTRL + clic y SHIFT + clic.
- | Agregar / Eliminar: permiten, respectivamente, agregar nuevas imágenes o eliminar las imágenes seleccionadas de la lista de aquellas que componen la Presentación. La ventana Seleccionar archivo abierta permite seleccionar incluso varios archivos contemporáneamente.
- | Subir / Bajar: permiten, respectivamente, desplazar la imagen seleccionada a antes o después de la precedente/sucesiva en la Lista de imágenes por visualizar en la Presentación.
- | Efecto: Permite activar la ventana Propiedades de los efectos mediante la cual es posible predisponer efectos de entrada, movimiento y zoom además que los enlaces para las imágenes de la Presentación seleccionadas de entre las presentes en la Lista de imágenes por visualizar.
- | Reproducción automática: activada por defecto, esta opción hace que la Presentación inicie automáticamente.
- | Visualizar en orden casual: activando esta opción, las imágenes introducidas en la Presentación son reproducidas en orden casual y no en base al orden de inserción en la Lista de imágenes por visualizar.

Temas relacionados:
- | Editor de plantilla
- | Ventana Propiedades de los efectos


Editor de plantilla| Recuadro Código HTML

En la ventana Editor de plantilla, seleccionando un objeto HTML introducido en las secciones Encabezamiento y Pie de página es posible utilizar las siguientes opciones presentes en el recuadro Código HTML:
- | Código HTML: permite introducir el código HTML relativo al objeto que se desea crear.
- | Visualizar barras de desplazamiento: activando esta opción aparecen visualizadas las barras de desplazamiento.

Además es posible hacer clic en el botón [image] Insertar Snippet y, mediante el menú activado, elegir si introducir:

-

La Fecha de publicación [FECHAS]: permite introducir automáticamente la fecha de publicación de la Página. Por ejemplo, se puede escribir: "Página actualizada el [DATE]".

-

La Hora actual [HOUR]: permite introducir automáticamente la indicación de la hora en curso. Por ejemplo, se puede escribir: "Son las [HOUR]".

-

La Fecha actual [NOW]: permite introducir automáticamente la indicación del día en curso. Por ejemplo, se puede escribir: "Hoy es [NOW]".

-

Cerrar session en área reservada [LOGOUT]: permite introducir automáticamente la palabra Logout con el enlace necesario para permitir al usuario salir del Área reservada (compuesta por las Páginas protegidas a las cuales puede acceder mediante las propias credenciales) y regresar a la Página de inicio del Sitio. Este enlace para el Logout es visualizado sólo si el usuario ha efectuado anteriormente el Login.

La palabra "Logout" puede ser modificada mediante la ventana Gestión de contenido de idioma.

Temas relacionados:

-

Editor de plantilla


Editor de plantilla| Recuadro Campo de Búsqueda

En la ventana Editor de plantilla, seleccionando el Campo de búsqueda introducido en las secciones Encabezamiento y Pie de página es posible utilizar las siguientes opciones presentes en el recuadro Campo de búsqueda:
- | Etiqueta Botón: permite especificar el texto que se debe ver en el interior del botón que lanza la búsqueda.
- | Fuente: permite especificar, mediante la ventana abierta, el tipo de fuente, el estilo y las dimensiones en puntos del texto.
- | Colores Campo: permite definir, mediante la ventana Color abierta, el color para el texto y para el fondo del campo.
- | Colores Botón: permite definir, mediante la ventana Color abierta, el color para el texto y el fondo del botón.

 Los resultados de las búsquedas efectuadas en el interior del sitio aparecen en páginas automáticamente creadas por el Programa: el aspecto gráfico de dichas Páginas es establecido en base a las predisposiciones de estilo de los textos (ver Estilos y Plantillas en el Paso 4 - Ajustes avanzados).

Temas relacionados:
- | Editor de plantilla
- | Cómo funciona el Motor de búsqueda interno de WebSite X5


Editor de plantilla| Recuadro Efectos

En la ventana Editor de plantilla, seleccionando un Objeto de texto, un Objeto Imagen o un objeto Presentación introducido es posible utilizar las siguientes opciones presentes en el recuadro Efectos:

-

Tipo de Efecto: permite seleccionar y activar uno o más efectps que aplicar en el Objeto seleccionado.

En cada Objeto Texto, Imagen y Presentación se pueden aplicar incluso varios efectos contemporáneamente; para cada efecto es posible utilizar varios ajustes:

Efecto | Ajustes
Sombra | - | Difusión: esta opción permite definir el tamaño de la sombra.
 | - | Color: permite definir, mediante la ventana Color abierta, el color de la sombra que aplicar.
 | - | Distancia X / Distancia Y: permiten definir de cuánto se debe desplazar horizontalmente la sombra respecto al objeto a que se aplica. Introduciendo un valor positivo se obtiene un desplazamiento de la sombra, respectivamente, hacia la derecha o hacia abajo; al contrario, introduciendo un valor negativo se obtiene un desplazamiento de la sombra hacia la izquierda o hacia arriba.
Espejo | - | Difusión: permite definir cuánto debe ser difundido, es decir cuánto debe ser grande, el reflejo a aplicar.
 | - | Distancia: permite definir a qué distancia debe estar el reflejo respecto al objeto al que se aplica.
Borde a color | - | Grosor: esta opción permite definir el valor en píxeles del grosor del borde que aplicar.
 | - | Color: permite definir, mediante la ventana Color abierta, el color del borde que aplicar.
Brillo exterior | - | Difusión: esta opción le permite definir cómo debe de ser la propagación de luz.
 | - | Color: permite definir, mediante la ventana Color abierta, el color de la propagación de la luz que aplicar.
Convexo | - | Profundidad: esta opción permite definir cúanto debe ser acentuado el efecto convexo.
 | - | Difusión: esta opción permite definir cuándo debe ser extendido el efecto convexo.
 | - | Ángulo: esta opción permite definir el ángulo del efecto convexo que aplicar.
Rotación | - | Ángulo: esta opción permite definir el valor del ángulo de rotación (en dirección de las agujas del reloj) que aplicar.
Opacidad | - | Opacidad: permite predisponer un valor da 0 a 255 para definir el grado de opacidad de la imagen. Para valores que tienden a 0 diminuye la opacidad de la imagen que, de este modo, es cada vez más transparente.
Desenfocado | - | Difusión: permite definir cuánto debe ser extendido el desenfocado que aplicar.
Onda | - | Difusión: permite definir la amplitud de la onda.
 | - | Frecuencia: permite definir cuánto deben estar cerca las ondas entre sí.
Perspectiva | - | Horizontal: permite predisponer el ángulo de fuga para obtener un efecto de perspectiva hacia la derecha (con valores positivos) o hacia la izquierda (con valores negativos).
 | - | Vertical: permite predisponer el ángulo de fuga para obtener un efecto de perspectiva hacia abajo (con valores positivos) o hacia arriba (con valores negativos).
Distorsión | - | Horizontal: permite colocar el punto hacia el cual predisponer la distorsión a lo largo de un plano horizontal, hacia la derecha (con valores positivos) o hacia la izquierda (con valores negativos).
 | - | Vertical: permite colocar el punto hacia el cual predisponer la distorsión a lo largo de un plano vertical, arriba (con valores positivos) o abajo (con valores negativos).

Temas relacionados:

-

Editor de plantilla


Creación del Mapa

Un Sitio Web puede ser definido como un conjunto estructurado de Páginas. Definir correctamente la estructura es muy importante puesto que ésta determina como están conectadas entre sí las Páginas y, de consecuencia, define los trayectos de navegación disponibles para llegar a cada información individual.
Una buena estructura hará que el usuario no se pierda durante la navegación, sepa simpre dónde se encuentra y consiga alcanzar en pocos pasos las informaciones que busca. Al contrario, una mala estructura generará desorientación y frustración y, en el peor de los casos, llavará al usuario a abandonar el Sitio.

Así pues, la ventana Creación del mapa permite definir la estructura del Sitio, introduciendo todas las Páginas necesarias y organizándolas en Niveles y sub-niveles. Una vez diseñado el Mapa como una estructura aún vacía de contenidos, es posible proceder a la efectiva creación de cada Página individual.

La ventana presenta las siguientes secciones mediante las que trabajar:
- | Una representación esquemática del Mapa;
- | Una Barra de herramientas situada sobre la representación del Mapa;
- | Una serie de comandos para diseñar el Mapa.


El esquema del Mapa del sitio

En la ventana Creación del mapa la mayor parte del espacio está ocupado por la representación esquemática del Mapa que se va a construir.

Como base se propone una estructura compuesta por una Página de inicio y por una carpeta Menú que contiene 3 Páginas. Añadiendo los Niveles y las Páginas mediante los especiales comandos, éstos serán introducidos en la carpeta Menú del Mapa que, de este modo, irá tomando poco a poco forma y completándose.
Si, mediante las secciones del Paso 4 - Ajustes avanzados, el Sitio es completado con la inserción de una Página de bienvenida, un Blog, una Área reservada (basta incluso que sólo una Página haya sido predispuesta como Página protegida) o un Carrito de la compra de comercio electrónico, a la estructura del Mapa se añade también la carpeta Páginas especiales con los elementos correspondientes: Página de inicio, Blog, Página de bienvenida de sesión y Carrito de la compra de comercio electrónico.

Además de ver la estructura de árbol del Mapa, para las Páginas insertadas se muestran algunas informaciones adicionales útiles como el Título completo de la página y la Descripción. Obviamente, para que estas informaciones sean visualizadas, es necesario que hayan sido definidas anteriormente mediante la ventana Propiedades de la página.

Trabajando directamente en el Mapa es posible efectuar algunas operaciones:
- | Haciendo clic de nuevo en un Nivel o en una Página, incluída la Página de inicio, ya seleccionada, es posible nombrarla de nuevo (en alternativa al botón Renombrar). También los Alias de las Páginas especiales introducidos en la carpeta Menú pueden ser renombrados, mientras la Páginas especiales no.
- | Después de haber seleccionado una Página, haciendo clic directamente en el Título completo de la página o en la Descripción presentes, se pueden modificar los textos introducidos (como alternativa se debe abrir de nuevo la ventana Propiedades de la página).
- | Faciendo doble clic en un Nivel es posible expandirlo, y ver todas las Páginas en él contenidas, o reducirlo (como alternativa a los botones Expandir y Reducir). Análogamente, también se puede expandir y reducir un Nivel haciendo clic en la flecha que hay antes del nombre.
- | Haciendo doble clic en una Página se pasa a la ventana Creación de la página para proceder a su construcción.
- | Haciendo doble clic en una Página especial se accede a la ventana del Paso 4 - Ajustes avanzados que permite su creación/actualización.
- | Seleccionando un Nivel y arrastrándolo a una nueva posición, se desplaza con todas las páginas en él contenidas (como alternativa a los botones Subir y Bajar).
- | Seleccionando una o más páginas es posible arrastrarlas y desplazarlas a una nueva posición (como alternativa a los botones Subir y Bajar). Para efectuar una selección multiple es posible recurrir a las combinaciones CTRL + clic o SHIFT + clic.
- | Seleccionando una página especial y arrastrándola al interior de la carpeta Menú, o sea entre las Páginas y los Niveles que irán a componer el menú de navegación, se crea un Nivel que se comporta como Alias de la Página especial misma. Así pues, dicho Nivel tiene el mismo nombre que la Página especial y ha predispuesto el enlace a la Página especial misma. Así pues, de este modo es posible introducir en el Menú de navegación una opción activa que da el acceso a la Página de bienvenida, al Blog, a la Página de inicio de sesión o al Carrito de la compra de comercio electrónico.
- | Seleccionando una o más páginas es posible copiarlas o pegarlas dentro del mismo Proyecto o en un distinto Proyecto abierto en otra ventana del Programa. Las operaciones de Copiar y Pegar pueden ser efectuadas mediante los especiales comandos de la Barra herramientas, del menú contextual activado con el clic de la tecla derecha del ratón, o mediante las combinaciones de teclas CTRL + C y CTRL + V. Obviamente no es posible utilizar los comandos Copiar y Pegar con las Páginas especiales.

Temas relacionados:
- | Creación del mapa
- | Los comandos para diseñar el Mapa
- | La Barra de herramientas del Mapa


La Barra de la herramientas del Mapa del Sitio

En la ventana Creación del mapa, inmediatamente por encima de la representación esquemática del Mapa, está disponible una Barra herramientas con los siguientes comandos:

 Cortar [CTRL + X] - Copiar [CTRL + C] - Pegar [CTRL + V]
Permiten, respectivamente, cortar, copiar y pegar las Páginas seleccionadas, dentro del mismo Proyecto o entre los distintos Proyectos. Estos comandos están presentes también en el menú contextual activado con el clic de la tecla derecha del ratón en el Mapa.

Página no visible en el Menú
Activando esta opción, la Página o el Nivel seleccionado no aparece en el Menú de navegación. Haciendo invisible un Nivel, automáticamente todas las páginas contenidas en él son invisibles también. Las páginas invisibles en el Menú pueden ser utilizadas de modo útil como páginas de profundización y ser activadas mediante enlaces internos. Se recuerda que hay que crear al menos un enlace que lleve a las Páginas invisibles.

También la Página de inico puede seleccionarse como invisible en el menú. se aconseja poner la Página de inicio invisibile sólo cuando se prevé poner el enlace que lleva a quella a ella en otros puntos del Sitio, por ejemplo en el Encabezamiento.

Página protegida
Permite abrir la ventana Página protegida, mediante la cual es posible predisponer la Página como Protegida marcando simplemente la opción Configurar esta página como protegida. Una vez hecho esto, es necesario especificar qué grupos y/o usuarios individuales podrán ver dicha Página protegida, haciendo clic en ellos en la lista propuesta. Activar un Grupo o activar todos los Usuarios pertenecientes a un Grupo no es la misma cosa: En efecto, sólo en el primer caso, si en un segundo momento se agregasen nuevos Usuarios al Grupo, para éstos se habilitará automáticamente la visualización de la Página protegida.
Para crear nuevos Grupos/Usuarios basta acceder a la ventana Gestión accesos del Paso 4 - Ajustes avanzados.

Propiedades de página
Se activa cuando se selecciona una Página del Mapa y permite abrir la ventana Propiedades de la página mediante la cual es posible definir una serie de propiedades necesarias para la optimización, para la personalización gráfica y para agregar eventuales porciones de código.

Las opciones disponibles están recogidas en 3 secciones:
- | Sección General
- | Sección Gráfica
- | Sección Avanzado

Propiedades del Nivel
Se activa cuando se selecciona un Nivel del Mapa y permite abrir la ventana Propiedades del nivel mediante la cual es posible definir las siguientes propiedades:

-

No mostrar el Menú desplegable de este Nivel: activando esta opción, no aparece el Menú desplegable relativo a la opción de Nivel a pasar por encima el ratón.

-

Enlace con clic en la opción de Nivel: permite asociar, mediante la ventana Enlace abierta, un enlace directo a la opción de Nivel.

Elegir "no visualizar el Menú desplegable para un Nivel" activando un "enlace con clic en la opción del mismo Nivel" es útil, por ejemplo, si se desea introducir un enlace a un Sitio externo directamente como opción de Menú, o bien, si se desea sustituir un sub-menú con un número elevado de opciones con la apertura de una Página creada a posta para dar el acceso a las distintas secciones internas.

-

Icono para el elemrnto de Menú: permite seleccionar una imagen (archivo .JPG, .GIF, .PNG) que será visualizada en el menú de navegación, junto a la opción.

Si, mediante las secciones del Paso 4 - Ajustes avanzados, el Sitio es completado con la inserción de una Página de bienvenida, un Blog, una Área reservada (basta incluso que sólo una Página haya sido predispuesta como Página protegida) o un Carrito de la compra de comercio electrónico, a la estructura del Mapa se añade también la carpeta Páginas especiales con los elementos correspondientes. En las páginas especiales todos los comandos de la barra herramientas no tienen efecto.

Temas relacionados:
- | Creación del mapa
- | La representación esquemática del Mapa
- | Los comandos para diseñar el Mapa


Creación del mapa| Propiedades Página| Sección general

Las opciones presentes en la sección General de la ventana Propiedades de la página permiten predisponer una serie de parámetros necesarios para la correcta optimización de la Página misma:
- | Título completo de la página: esta opción permite especificar un título distinto del introducido en el Mapa. El nombre dado a la Pagina en fase de construcción del Mapa es mantenido como opción en el Menú de navegación; en cambio, el eventual Título completo especificado en las Propiedades de la página es visualizado como Título efectivo de la Página. En el caso de la Página de inicio, el título no aparece dentro de la Página pero es igualmente posible especificar el Título completo: el título especificado es igualmente utilizado en el menú, mientras que el título o, si está presente, el Título completo de la página es utilizado para componer el metatag <title> en el código HTML de la Página.
- | Descripción de la página: permite insertar una descripción específica para la Página. La descripción de la Página debe de ser corta y precisa. se introduce como valor del metatag <description> en el código HTML de la página y es utilizada por los Motores de búsqueda para la indización.
- | Palabras clave para la búsqueda: permite insertar una serie de palabras clave específicas para la Página. Las palabras clave son introducidas como valor del metatag <keywords> en el código HTML de la Página y utilizadas por los Motores de búsqueda para la indización.
- | Nombre del archivo: esta opción permite especificar el nombre del archivo HTML relativo a la página. Si no se especifica de otra manera, como nombre del archivo HTML se toma automáticamente el nombre dado a la Página durante la costrucción del Mapa. Dar nombres breves y significativos a los archivos permite obtener direcciones simples y fáciles de memorizar y tiene resultados positivos también en la indización por parte de los Motores de búsqueda. Esta opción no está disponible para la Página de inicio.

Temas relacionados:

-

Ventana Propiedades de la página


Creación del mapa| Propiedades Página| Sección Gráfica

Las opciones presentes en la sección Gráfica de la ventana Propiedades de la página permiten modificar algunos importantes aspectos gráficos de la Página en la que se está trabajando:
- | Icono para el elemrnto de Menú: permite seleccionar una imagen (archivo .JPG, .GIF, .PNG) que será visualizada en el menú de navegación, junto a la opción.
- | Imagen de fondo del Sitio para la Página: permite seleccionar una imagen (.JPG, .GIF, .PNG) que será visualizada como fondo de la página en lugar de la imagen o del color previsto en base a la plantilla predispuesta (ver, Selección de plantillas).
- | Imagen de fondo del Contenido de la Página: permite seleccionar una imagen (archivo .JPG, .GIF, .PNG) que será visualizada como fondo del Contenido de la página. Esta imagen es superpuesta al color o a la imagen prevista en base a la plantilla predispuesta (ver, Selección de plantillas).
- | Repetir: permite especificar si la imagen introducida como fondo del Contenido de la página debe ser repetida o no. La imagen puede repetirse de forma horizontal, vertical o en ambas direcciones, con el propósito de llenar el espacio disponible.
- | Repetir: permite especificar cómo se debe alinear la imagen introducida como fondo de la Contenido de la página.
- | Crear la Página sin aplicar la Plantilla: permite hacer que a la Página no se le aplique la Plantilla de estilo elegida o creada como Plantilla personalizada (ver, Selección de plantillas). Así pues, activando esta opción se crea la Página manteniendo sólo los contenidos introducidos en ella, pero no se aplica ni la Plantilla de estilo ni el menú de navegación.
- | Anchura Página / Color de Fondo: disponibles sólo si se ha activado la opción Crear la Página sin la Plantilla, permiten, respectivamente, especificar el valor en pixel de la anchura de la Página y el color de Fondo que aplicar.

Temas relacionados:
- | Ventana Propiedades de la página
- | Elección de la Plantilla


Creación del mapa| Propiedades Página| Sección Avanzado

Las opciones presentes en la sección Avanzado de la ventana Propiedades de la página permiten trabajar en el SiteMap del Sitio y cambiar manualmente el código HTML generado para la Página en la que se está trabajando:

-

Extensión del archivo generado: esta opción permite especificar la extensión que será utilizada por el archivo de la Página. La extensión predeterminada es .html pero es posible escoger entre .php, .asp, .cfm, y .jsp. También el archivo index.html relativo a la Página de inicio puede ser guardado con una extensión distinta: la misma extensión será tomada eventualmente también para la Página de bienvenida. Sólo para las Páginas protegidas (ver el comando [image] Página protegida en la Barra de herramientas del Mapa) no es posible modificar la estensió del archivo generado que queda necesariamente .php.

-

Agregar esta página al SiteMap: esta opción, activa por defecto, hace que la Página sea incluída en la creación del SiteMap.

-

Frequencia de actualizacion: permite especificar con qué frecuencia es actualizada la página. Este parámetro aparece dentro del SiteMap generado.

-

Prioridad del contenidos: permite asignar una puntuación a la página, para indicar su importancia en relación con otras páginas del sitio. Este parámetro aparece dentro del SiteMap generado.

-

Código personalizado: permite insertar porciones de código dentro del código HTML de la Página. Mediante el menú correspondiente es posible definir la posición dentro del código de la Página en la que se debe introducir el código personalizado: Antes del tag <HTML>,Antes del tag </HEAD>,Dentro del tag <BODY> (o sea dentro de la instrucción <BODY>, por ejemplo: <BODY onload="alert('Hello!')">), Antes del tag </BODY>, Después del tag </BODY>. Una vez seleccionada la posición, está disponible un campo en el que escribir o pegar la porción de código a insertar.

La opción Código personalizado es útil cuando, por ejemplo, se desea vincular especiales hojas de estilo (CSS), o bien cuando se deben lanzar sucesos en la onload de la Página. En particular, para el correcto funcionamiento de algunos JavaScript, que pueden ser insertados mediante el especial objeto HTML y widgets, se solicita la inserción de oportunas líneas de código tanto en la sección <HEAD> como en la sección <BODY> del archivo HTML de la Página.

Temas relacionados:
- | Ventana Propiedades de la página
- | Cómo crear y conectar el SiteMap del Sitio


Crear el Mapa del Sitio

En WebSite X5, el Mapa asume la típica estructura de árbol: se parte de una Página de inicio y se desciende a los distintos Niveles, encontrando las distintas Páginas introducidas. Así pues, la creación del Mapa prevé que, además de la Página de inicio, siempre presente, exista una serie de Páginas vinculadas a través del Menú: por este motivo, es necesario introducir todas las Páginas organizando, contemporáneamente, los distintos Niveles del Menú.

Los comandos disponibles para definir el Mapa de Sitio son:

-

Nuevo nivel [CTRL+L]: esta opción permite insertar un nuevo Nivel de menú. No hay límites al número de Niveles y de sub-niveles que se pueden introducir.

-

Nueva página [CTRL+P]: permite crear una nueva Página que será automáticamente introducida en el Nivel seleccionado.

-

Separador: permite insertar un separador para poder organizar también visualmente las opciones de los Menús. Un separador puede ser un espacio o un título y es muy útil para crear menús en varias columnas (ver, Estilo de menú desplegable| Sección Elementos de menú a la Paso 4 - Ajustes avanzados).

-

Eliminar [CANC]: esta opción permite eliminar la Página o el Nivel seleccionado.

-

Renombrar [F2]: esta opción permite modificar el nombre de la Página de inicio, de la Página o del Nivel seleccionado. Es oportuno nombrar correctamente los Niveles y las Páginas introducidas ya que los elementos del Mapa serán tomados automáticamente del Menú de navegación, como títulos de cada Página y como nombres de los archivos HTML correspondientes a las Páginas mismas, a no ser que se especifique lo contrario mediante la ventana Propiedades de la página.

-

Subir [CTRL+U] / Bajar [CTRL+D]: permiten modificar el orden de las Páginas o de los Niveles. Desplazan, hacia arriba o hacia abajo, la Página o el Nivel seleccionado, a la posición precedente o siguiente, respectivamente

También es posible modificar directamente sobre el Mapa el orden de los Niveles y de las Páginas: basta seleccionar el elemento deseado, arrastrarlo y soltarlo en la posición que debe asumir (Drag&Drop). Es posible seleccionar varios niveles y/o Páginas utilizando las teclas CTRL y SHIFT.

-

Expandir / Reducir: permiten, respectivamente, expandir o reducir el Nivel seleccionado para ver o no las Páginas en él contenidas.

Si, mediante las secciones del Paso 4 - Ajustes avanzados, el Sitio es completado con la inserción de una Página de bienvenida, un Blog, una Área reservada (basta incluso que sólo una Página haya sido predispuesta como Página protegida) o un Carrito de la compra de comercio electrónico, a la estructura del Mapa se añade también la carpeta Páginas especiales con los elementos correspondientes. En las Páginas especiales los comandos Eliminar, Renombrar, Subir, Bajar, Expandir y Reducir no tienen efecto. En cambio, para los Alias de las Páginas especiales (obtenidos arrastrando las Páginas especiales entre las Páginas y los Niveles del Menú), los comandos Eliminar, Renombrar, Subir, Bajar quedan activos puesto que no actúan directamente en la Página de inicio, el Blog, la Página de inicio de sesión o el Carrito de la compra de comercio electrónico, sino sólo en los elementos que hacen referencia a ellas, presentes en el menú de navegación.

Como consecuencia de la articulación del Mapa, WebSite X5 propone proceder a la efectiva composición de cada Página del Sitio, presentándolas una detrás de otra. Es posible utilizar el Mapa para pasar directamente a la ventana del Programa que permite trabajar en una determinata página: para esto, basta hacer doble clic en la opción correspondiente o bien seleccionarla y hacer clic en el botón Siguiente.

Temas relacionados:
- | Creación del mapa
- | La Barra de herramientas del Mapa
- | Los comandos para diseñar el Mapa


Mapa del sitio y SiteMap

En base al Mapa definido con el Paso 2, se crea automáticamente una Página que propone el Mapa del sitio. Los elementos del mapa de sitio están vinculados con cada una de las páginas respectivas: por lo tanto, el mapa representa una herramienta útil para la orientación y la navegación puesta a disposición del usuario. La visualización de las opciones del Mapa puede ser modificada mediante los comandos Expandir todo y Reducir todo.
El Mapa del sitio se puede poner a disposición introduciendo especiales enlaces en textos e imágenes de las Páginas (ver, en la ventana Estilo de enlaces la acción Mapa del sitio) o mediante el Menú del pie de página en el que el enlace con el Mapa es introducido automáticamente (activando la opción Visualizar para el elemento Menú del pie de página en Estilos y Plantillas| Sección Textos).

Aunque se decida no poner a disposición el Mapa del sitio, el Programa puede proceder igualmente a su creación bajo forma de SiteMap XML vinculada en el código HTML de las Páginas mediante el metatag <sitemap>. Resumiento, un SiteMap no es otra cosa que un archivo XML que contiene una lista de las Páginas de un sitio y sirve para asegurarse de que los Motores de búsqueda las controlen todas. Además, mediante el SiteMap es posible dar a los motores algunas informaciones útiles sobre las páginas:
- | la frecuencia con la que es actualizada cada página;
- | la fecha de la última modificación de las Páginas;
- | la importancia de cada Página en la economía del Sitio (dicha prioridad no influye en el colocamiento de las Páginas en los resultados de las búsquedas).

Para que se cree el SiteMap del Sitio es preciso activar la opción Crear un SiteMap automáticamente presente en Ajustes generales| Sección Avanzado. Para que en el SiteMap se incluyan también informaciones referidas a la frecuencia de actualización y la importancia relativa de las Páginas de un Sitio, es preciso aprovechar las opciones disponibles en la ventana Propiedades de Página| Avanzado que se puede abrir durante la Creación del Mapa.

Temas relacionados:
- | Creación del mapa
- | Cómo crear y conectar el SiteMap del sitio


Creación de Página

Después de haber articulado el Mapa del Proyecto, es posible iniciar la creación de cada Página insertada en el Sitio. Así pues, la ventana Creación de la página permite definir la estructura de paginación y proceder a la inserción de los contenidos.

La ruta de acceso y el Título de la Página en la que se está trabajando aparece como Página en curso:

La ventana presenta las siguientes secciones mediante las que trabajar:
- | una representación esquemática (o Rejilla) de la Página, cuya función es permitir la definición de la paginación que aplicar;
- | la lista de los tipos de Objetos disponibles para la composición de las Páginas;
- | la Vista previa para la visualización del Objeto contenido en la celda seleccionada de la Rejilla de paginación.


La Rejilla de paginación en la Creación de la página

Para hacer más intuitiva la paginación de los contenidos, WebSite X5 propone una Rejilla que, por defecto, está compuesta por 2 filas y 2 columnas: basta arrastrar los Objetos disponibles al interior de las Celdas de dicha rejilla (un objeto por celda), para componer la Página.

Obviamente, es posible añadir filas y columnas para disponer de un número superior de Celdas y, además, es posible definir manualmente la anchura de cada columna. Como veremos, gracias a estas posibilidades de diseño de la Rejilla y al hecho de poder disponer un Objeto también en varias Celdas adyacentes, es posible incluso obtener paginaciones muy refinadas.

Una precisación importante: el empleo de la Rejilla sirve únicamente para simplificar y guiar la paginación de los contenidos. Con excepción de pocos y específicos casos particulares, representados por combinaciones de paginación muy complejas, la Rejilla de paginación no es "traducida" como tabla en el código HTML de las Páginas. En todos los casos, la Rejilla de paginación no se verá nunca durante la navegación con el Navegador (Browser).

Como ya anticipado, cada Celda de la Rejilla puede contener un único Objeto pero cada Objeto puede ser dispuesto también en varias celdas ayacentes horizontal o verticalmente, de modo que ocupen un espacio de la Página.

El aspecto de las Celdas de la Rejilla de paginación cambia en función de los distintos estados que puede asumir:
- | si contiene un Objeto que aún no ha sido construido, presenta el icono correspondiente al tipo de Objeto sobre un fondo de filas grises oblícuas;
- | si contiene un Objeto que ya ha sido construido, presenta el icono correspondiente al tipo de Objeto sobre un fondo azul uniforme;
- | se contiene el Objeto seleccionado, aparecen visualizados el perímetro y las manillas de selección.

Utilizando los controles ubicados en la Barra de herramientas es posible definir la estructura y ajustar el aspecto gráfico de la Rejilla de paginación.

Concretamente, los comandos disponibles para modificar la Rejilla de paginación son:

 Introducir el contenido del objecto selezionado: está activo cuando se ha seleccionado un Objeto ya introducido en una Celda y permite el acceso a la ventana donde se crea el Objeto mismo. La ventana abierta cambia en función del tipo de objeto.

Estilo de la celda: está activo cuando se ha seleccionado un Objeto ya introducido en una Celda y permite abrir la ventana Estilo de la celda mediante la cual es posible definir el aspecto gráfico de la Celda en curso.

Márgenes de la Celda: está activo cuando se ha seleccionado un objeto ya introducido en una Celda y permite abrir la ventana Margen de celda mediante la cual es posible predisponer el valor en pixel para el margen Externo e interno de la Celda en curso. También es posible activar la opción Márgenes personalizados para tener la posibilidad de definir valores distintos para el margen de cada lado de la Celda: Superior, Derecho, Inferior e Izquierdo. (ver, El Box Model en WebSite X5)

Alineación del contenido de la Celda: está activo cuando se ha seleccionado un Objeto ya introducido en una Celda y permite alinear el Objeto Arriba/en el Centro/Abajo y a la Izquierda/Centro/Derecha respecto a la Celda misma en que está contenido.

Agregar fila / Eliminar fila: permiten, respectivamente, añadir una fila nueva antes de la fila que contiene la Celda seleccionada y eliminar la línea que contiene la Celda seleccionada. Se puede crear rejillas con un máximo de 64 filas.

Agregar columna / Eliminar columna: permiten, respectivamente, añadir una nueva columna antes de la columna que contiene la Celda seleccionada y eliminar la columna que contiene la Celda seleccionada. Se pueden crear rejillas con un máximo de 12columnas.

Si se selecciona una Celda vacía, las nuevas filas/columnas son insertadas inmediatamente antes de dicha Celda. Si, en cambio, se selecciona un Objeto, las nuevas filas/columnas son insertadas de modo que precedan a la primera Celda ocupada por el objeto mismo. Por último, en el caso en que no se seleccione ninguna Celda/Objeto, las nuevas filas/columnas son insertadas al fondo de la Rejilla.

En automático, todas las filas y las columnas de la Rejilla de paginación tienen la misma anchura y altura. Es posible predisponer manualmente el valor absoluto (en pixel) o relativo (en porcentaje) de las columnas mediante los cursores presentes en el fondo de la Rejilla de paginación:
- | Haciendo clic y arrastrando un cursor, se desplaza la fila que delimita la columna. De este modo la columna asume la anchura especificada en la nota visualizada mediante el arrastre del cursor. Manteniendo pulsada la tecla CTRL durante el arrastre del cursor, éste se desplaza un pixel cada vez: en caso contrario, el desplazamiento se produce con paso igual a un décimo del espacio disponible.
- | Haciendo clic con la tecla derecha del ratón en un cursor y eligiendo Establecer ancho de columna del menú contextual, se puede escribir directamente el valor en pixel de la anchura de la columna.
- | Haciendo clic con la tecla derecha del ratón en un cursor y eligiendo Restablecer mismo ancho de columna del menú contextual, se presentan todas las columnas con la misma anchura.

Temas relacionados:
- | Creación de la página
- | La lista de los Objetos en la Creación de la página
- | El Box Model en WebSite X5


La lista de los Objetos en la Creación de la página

Para insertar un Objeto en una Página basta seleccionar el icono que lo representa de la lista de los Objetos disponibles, arrastrarlo y soltarlo en la Rejilla de paginación, en correspondencia de la celda que debe ocupar.

Cada celda de la Rejilla de paginación puede contener un único objeto, pero un objeto puede ocupar varias Celdas adyacentes, tanto en sentido horizontal como vertical.
El icono del objeto seleccionado puede arrastrarse y hacer que calce con los bordes de la celda: en este caso el objeto ocupará el espacio de las celdas seleccionadas. Además, este elemento permite utilizar las anclas de selección del objeto insertado para extenderlo a varias celdas.

Una vez definido el número de Celdas que debe ocupar un Objeto, éste es mantenido, compatiblemente con la presencia de otros Objetos, incluso si el Objeto es desplazado a otros puntos de la Rejilla. Para mayor comodidad, es posible trabajar en la Rejilla utilizando las teclas flecha:
- | teclas flecha: desplazan la selección de una Celda a otra de la Rejilla de paginación.
- | CTRL + teclas flecha: desplazan el Objeto seleccionado (manteniendo su tamaño) entre las Celdas de la Rejilla de paginación.
- | SHIFT + teclas flecha: modifican el tamaño del objeto seleccionado extendiéndolo (compatiblemente con otros objetos presentes) o comprimiéndolo en un número distinto de Celdas de la Rejilla de paginación.

Haciendo clic con el botón derecho del ratón sobre el icono del Objeto insertado en una Celda, o en una Celda vacía de la Rejilla de paginación, se activa un menú contextual con los comandos Cortar, Copiar, Pegar, Eliminar, Aspecto de la celda, Insertar fila, Insertar columna, Eliminar fila y Eliminar columna.
A través de estos comandos es posible, por ejemplo, crear una copia de un objeto pegándolo en otra celda, en otra página, o eliminarlo. Un objeto insertado puede ser eliminado de la Página también arrastrándolo al externo de la Rejilla de paginación o mediante la tecla CANC. En cualquier caso, insertando un nuevo Objeto en una Celda ya ocupada, se obtiene automáticamente la cancelación del primer Objeto y su sustitución con el segundo. Ahora bien, si se arrastra un Objeto ya existene a una Celda ya ocupada, los dos Objetos son intercambiados de posición.

En cambio, los comandos Copiar estilo y Pegar estilo, presentes en el sub-menú abierto por el comando Estilo de la celda, permiten hacer que las predisposiciones definidas en la ventana Estilo de la celda para una Celda sean automáticamente aplicadas también a una segunda Celda.

Después de haber insertado un Objeto se puede abrir la ventana mediante la cual proceder a la efectiva definición de su contenido (Objeto Texto, Objeto Tabla, Objeto Imagen, Objeto Animación Flash, Objeto Vídeo/Sonido, Objeto Galería, Objeto Formulario de envío e-mail, Objeto Lista Productos, Objeto HTML y Widgets), haciendo doble clic en la Celda de la Rejilla de paginación que lo contiene o seleccionando el Objeto y haciendo clic en el botón [image] Contenido objeto.

No es obligatorio llenar todas las celdas de la Rejilla de paginación: en todo caso, se debe considerar que una celda vacía corresponderá a un espacio vacío en la página.

Para comprender mejor cómo aprovechar al máximo las posibilidades de paginación, es preciso recordar que el funcionamiento del software respeta las siguientes reglas:
- | La anchura de la página es determinada por la plantilla.
- | La anchura de las columnas de la Rejilla de paginación se obtiene dividiendo la anchura de la Página por el número de columnas insertado. Por defecto, todas las columnas tienen igual anchura pero es posible modificar manualmente dicho parámetro.
- | Todas las Celdas dispuestas en una misma fila de la Rejilla de paginación tienen igual altura: por defecto, este valor es determinado por el Objeto más alto entre los contenidos en dichas Celdas.
- | Los objetos introducidos toman automáticamente la nueva dimensión en base a los tamaños asumidos por las Celdas de la Rejilla de paginación.

Temas relacionados:
- | Creación de la Página
- | La Rejilla de paginación en la Creación de la Página


Inserción Objeto Texto

Objeto Texto

Más allá de las Imágenes, de los Vídeos y de las Animaciones que se pueden utilizar, en la mayor parte de los casos, los contenidos principales de un Sitio son vehiculados a través de Textos.

Escribir para la Red no es la misma cosa que escribir pensando en la posterior impresión: cada medio tiene sus peculiaridades e Internet se distingue principalmente por el soporte (el monitor de un ordenador o la pantalla de un dispositivo móvil), la modalidad de lectura que inspira (más parecida a una rápida escansión que a una lectura secuencial) y la disponibilidad de un número potencialmente ilimitado de alternativas (consideremos cuántos Sitios se ocupan del mismo argumento).

Por lo tanto, para capturar la atención de un lector, inducirlo a leer y, en la mejor de las hipótesis, persuadirlo de la bondad de lo que estamos proponiendo, es necesario que los contenidos textuales sean escritos en modo adecuado para la publicación en red: en primer lugar deben presentar contenidos de interés y después deben conseguir hacerlo en modo conciso, pero no críptico, y eficaz. Es mejor que el discurso esté dividido en frases breves, ya sea porque es más fácil de comprender, que porque visualmente resultará menos compacto y oprimente. Por último, para aumentar la facilidad de lectura de los textos es importante prestar atención a la tipografía, es decir, el ajuste que se da a los caracteres para títulos, evidenciados, cuerpo principal, didascalías, etc.

Reflexionar sobre estos aspectos y cuidar la redacción de los textos, es seguramente muy importante para conseguir crear un Sitio Web que pueda ser juzgado positivamente por cuantos lo visitarán. Nada como un contenido poco interesante, expresado en modo aproximado y con frases llenas de errores gramaticales o de ortografía, lleva a etiquetar un Sitio como desaliñado e inmerecedor de una segunda visita.

Una vez hechas estas, breves pero obligadas, consideraciones sobre el tema de la Web Writing, WebSite X5 permite componer los Textos necesarios mediante un especial editor interno y proceder a su formatación. Obviamente, también es posible tomar textos ya creados con otros programas e introducirlos mediante una simple operación de Copiar y Pegar.

Consejos Práticos

Haciendo doble clic en el Objeto Texto introducido en la Rejilla de paginación se accede a la ventana Objeto Texto. A través de esta ventana, que propone un editor, es posible efectuar directamente la escritura y formatación de los textos.

El editor de texto se presenta como en la imagen siguiente:

Como se observa, se dispone de los siguientes comandos:

 Cortar [CTRL+X] - Copiar [CTRL + C] - Pegar [CTRL + V]
Permiten, respectivamente, cortar, copiar y pegar el texto seleccionado. En este caso, antes de ser pegado, al texto se le quitan todas las formataciones eventualmente asociadas en origen y asume las definidas en el editor.

Pegar especial
Permite pegar el texto previamente colocado en el portapapeles de Windows mediante los comandos Cortar y Copiar. El texto pegado mantiene todas las formataciones originales.

Gracias a los comandos Cortar, Copiar y Pegar es posible recoger trozos de archivos de texto ya creados incluso con otros editores.

Deshacer [CTRL+Z] - Repetir [ALT+MAYUSC+BACKSPACE]
Permiten, respectivamente, anular y restablecer la última operación efectuada/anulada.

Insertar Enlace [CTRL+L]
Permite predisponer un enlace hipertextual en la/s palabra/s seleccionada/s. Es posible definir los ajustes del enlace mediante la ventana abierta Enlace.

Insertar imagen
Esta opción permite insertar una imagen (en formato .JPG, .GIF, .PNG, .BMP) dentro del texto. Las imágenes insertadas en el objeto Texto son automáticamente cambiadas de tamaño, si tienen dimensiones superiores a las de la Celda de la Rejilla de paginación. Además, el tamaño de las imágenes insertadas en el objeto texto pueden ser libremente manipuladas seleccionando la imagen y utilizando los puntos en los extremos de la misma. para paginaciones y efectos especiales es mejor utilizar el Objeto Imagen.

Activar Código HTML
Permite introducir directamente el código HTML dentro de la página de texto. Es decir, en modalidad HTML, los caracteres <y> no son interpretados como "menor" y "mayor" y lo que es introducido en su interior es interpretado como un tag HTML.

Ajustes para el rollover
Permite hacer que en el texto se predisponga el RollOver: de este modo el texto ya no es estático sino deslizante. Es posible definir los ajustes del Roll Over a través de la ventana Ajustes para el rollover.

Adapta al ancho de la celda
Permite simular el aspecto que el texto asumirá en relación al tamaño de la Celda de paginación que la contiene.

Fondo claro/oscuro
Permite predisponer un color claro u oscuro para el fondo de la ventana del editor de texto: de este modo es más simple, por ejemplo, componer textos que, para tener un adecuado contraste respecto al fondo previsto por la Plantilla gráfica aplicada, deben ser de color blanco.

Elección de la fuente - Tamaño de la fuente
Permiten, respectivamente, elegir el tipo de carácter (font) qué utilizar y definir su tamaño.

El menú desplegable propone todas las fuentes instaladas en el ordenador en que se está trabajando. Es necesario considerar que si la fuente utilizada no está instalada también en el ordenador del visitante del Sitio web, ésta será sustituida automáticamente por una fuente similar.

Negrita [CTRL+B] - Cursiva [CTRL+I] - Subrayado [CTRL+U]
Permiten, respectivamente, poner en negrita, cursiva y subrayado el texto seleccionado.

Color texto - Color fondo del texto
Permiten predisponer, mediante la ventana Color abierta, el color que aplicar al texto seleccionado o al fondo del texto seleccionado.

Listado de viñetas
Permite crear el listado de viñetas.

Aumentar sangría / Reducir sangría
Permiten, respectivamente, aumentar o reducir la sangría del párrafo seleccionado.

Alinear texto a la izquierda - Alineamiento centrado - Alinear texto a la derecha - Alineamiento justificado
Permiten, respectivamente, alinear a la izquierda, al centro, a la derecha o justificar el texto seleccionado.

Texto hacia la derecha - Disposición normal - Texto hacia la izquierda
Si se activan cuando se selecciona una imagen introducida en el texto, permiten hacer que el texto se deslice a lo largo del lado derecho de la imagen, que la imagen quede insertada en el flujo del texto como una palabra cualquiera, que el texto se deslice a lo largo del lado izquierdo de la imagen.

Mediante el clic de la tecla derecha del ratón, también es posible abrir un menú contextual que propone los siguientes comandos: Anular, Cortar, Copiar, Pegar, Pegar especial, Eliminar y Seleccionar todo.

Temas relacionados:
- | La Rejilla de paginación en la Creación de la Página
- | La lista de los Objetos en la Creación de la Página
- | Insertar Enlace
- | Ajustes RollOver


Ajustes RollOver

Esta ventana, abierta mediante el botón [image] del Editor del Objeto Texto o del Objeto Tabla, permite definir las predisposiciones para el RollOver de los textos.

En primer lugar, es preciso activar el efecto seleccionando la opción Habilitar RollOver.

Una vez habilitado el efecto, es posible definir cómo debe presentarse mediante las opciones del recuadro Modalidad:

-

Movimiento: define el tipo de movimiento del texto. Es posible elegir entre las siguientes opciones:

 Ninguno - Mostrar barra de desplazamiento: el texto no se desliza pero, puesto que está fijada la altura de la Celda (ver después la opción Altura), si ésta no basta para permitir la visualización del texto entero, será introducida automáticamente la barra de desplazamiento.

Movimiento simple: el texto se desliza en la dirección especificada y, al llegar al final, se para.

Movimiento continuo: el texto se desliza en la dirección especificada y, al llegar al final, vuelve a empezar, sin discontinuidades.

Desplazamiento alternado: el texto se desliza en la dirección especificada y, al llegar al final, vuelve a empezar en la dirección opuesta.

Desplazamiento por secciones: el texto es descompuesto virtualmente en secciones, o sea en bloques de altura igual a cuanto se ha predispuesto para la opción Altura. El deslizamiento del texto lleva a la visualización de la primera sección, después sigue una pausa antes de proceder con el deslizamiento para la visualización de la segunda sección. Prosigue de este modo, empezando desde el principio tras la visualización de la última sección. Para que el efecto tenga un rendimiento óptimo es necesario que el texto esté escrito y formateado de modo tal que después sea posible dividirlo en secciones predisponiendo adecuadamente la Altura.

-

Dirección: permite definir la dirección de desplazamiento del texto. El deslizamiento se puede producir hacia Arriba, hacia Abajo, hacia la Izquierda o hacia la Derecha.

Además, en el recuadro Opciones están disponibles las siguientes opciones:
- | Efecto: permite elegir entre los efectos Lineal, Efecto rebote y Desaceleración para todos los tipos de movimiento, excepto para el Movimiento continuo.
- | Altura: permite predisponer el valor para la altura de la celda en la que está contenido el texto.
- | Duración (seg.): permite predisponer cuántos segundos debe durar el efecto. Si se ha activado el Movimiento simple, continuo o alternado, la duración define el intervallo de tiempo en el que se desarrolla el movimiento, antes que empiece de nuevo. En cambio, si se ha activado el Desplazamiento por secciones, la duración define el tiempo de visualización de una sección, antes de que se pase a la siguiente.
- | Detiene el movimiento al pasar el raton: permite hacer que el deslizamiento se interrumpa cuando se pasa por encima el ratón.

 La opción Altura está disponible solo si el RollOver está configurado con movimiento vertical (dirección: hacia arriba o hacia abajo). Si, en cambio, el RollOver predispuesto es horizontal (dirección: hacia la izquierda o hacia la derecha), el efecto es mejor si el Objeto de texto ocupa una fila entera de la Rejilla de paginación.

Temas relacionados:
- | Objeto Texto
- | Objeto Tabla


Objeto Imagen

Las imágenes son uno de los elementos más utilizados en la creación de una Página Web. Entre otras cosas, pueden servir para ilustrar un concepto, para mostrar un producto, para vehicular un mensaje o, simplemente, para decorar. En cualquier caso, las imágenes son importantes porque ayudan a definir el aspecto complesivo del Sitio y a hacer que sea percibido como algo bonito, cuidado y profesional.

WebSite X5 permite importar todas los principales formatos gráficos y pone a disposición un funcional Editor gráfico interno para efectuar todas las operaciones más comunes de retoque fotográfico: corte, rotación, corrección, adición de máscaras, filtros y marcos. Además, permite trabajar sobre las Imágenes para obtener espectaculares visiones panorámicas y zoom.

Hay que subrayar que WebSite X5 afronta también el problema de la copia no autorizada de las Imágenes de Internet, poniendo a disposición un sistema de protección que impide acceder al archivo original y que puede prever la aplicación de marca de agua e indicación de copyright.

 Si se necesita imágenes de alta calidad que utilizar en los propios sitios, acceder al panel de control en my.websitex5.com: hay a disposición 6.000 imágenes exclusivas y royalty free entre las que elegir.

Consejos Práticos

Haciendo doble clic en el Objeto Imagen introducido en la Rejilla de paginación se accede a la ventana Objeto Imagen. Mediante esta ventana es posible especificar qué archivo importar, definir sus propiedades, predisponer efectos de zoom y panorámica, decidir si incluírlo en el SiteMap y, en caso positivo, insertar las informaciones necesarias.

Los comandos necesarios para proceder a la creación de un Objeto Imagen están articulados en tres secciones:
- | Sección General
- | Sección Visualización
- | Sección SiteMap

Temas relacionados:
- | La Rejilla de paginación en la Creación de la Página
- | La lista de los Objetos en la Creación de la Página
- | Editor gráfico


Objeto Imagen| Sección General

Mediante los comandos de la Sección General de la ventana Objeto Imagen es posible definir y modificar el Objeto Imagen.

WebSite X5 permite importar todos los formatos gráficos más difundidos (.JPG, .GIF, .PNG, .PSD, .BMP, .TIF, .DIB, .PCX, .RLE, .TGA, .WMF) seleccionando simplemente el recurso que utilizar entre los presentes en local en el ordenador o, en alternativa, en línea directamente en Internet.

La vista previa de la Imagen importada se puede ver en el recuadro Vista Previa. Haciendo clic en el botón Modificar presente bajo la vista previa es posible activar el Editor gráfico interno para modificar la Imagen importada.

Para la Imagen insertada se puede definir una serie de Propiedades:

-

Título: es el título de la Imagen; en el código HTML de las Páginas, el texto introducido será asignado al atributo title del tag <img>.

-

Texto alternativo: es el texto presentato en alternativa a la Imagen cuando ésta no puede ser visualizada. En el código HTML de las Páginas, el texto introducido será asignado al atributo alt del tag <img>.

El Título y el Texto Alternativo son dos parámetros que deben ser valorados y compuestos con atención puesto que resultan importantes tanto para la accesibilidad como para la optimización de los Sitios Web.

-

Enlace: permite predisponer un enlace en la Imagen. Haciendo clic en el botón [image] se abre la ventana Enlace mediante la cual es posible elegir el tipo de acción además de las relativas opciones.

-

Calidad: permite especificar el nivel de calidad que mantener al guardar la Imagen en .JPG.
Todas las imágenes importadas son automáticamente convertidas en formato .JPG o, en el caso que se predisponga la transparencia, en formato .PNG. En el caso que sean guardadas en .JPG, cuanto más alto sea el factor de compresión predispuesto, menor será la calidad mantenida.

Se recomienda insertar archivos gráficos en formato .GIF o .JPG. Todas las imágenes insertadas, con formato distinto de .JPG, .GIF y .PNG, aparecen automáticamente convertidas en formato JPG, en base al nivel de compresión especificado. La conversión en .JPG o, en el caso de imágenes en que se ha predispuesto la transparencia, en .PNG se efectúa aunque la Imagen tenga un tamaño mayor respecto al de la Celda de la Rejilla de paginación que la contiene y se modifica mediante el Editor gráfico.
En todos las demás casos, la Imagen es copiada tal como es. Esto es necesario para mantener el efecto de transparencia aplicado a los .GIF.

Por último, es posible aprovechar las opciones de Protección para intentar evitar la copia no autorizada de Imágenes:
- | Proteger Imagen contra copias: activando esta opción, es posible proteger la iIagen impidiendo que pueda ser fácilmente copiada mediante comandos como Guardar imagen con nombre puestos a disposición por los menús contextuales de los distintos Navegadores. Es decir, la imagen es incorporada al interior de un Objeto Flash: de este modo, no sólo no puede ser copiada fácilmente, sino que además no es posible tampoco conocer el nombre del archivo visualizando el código HTML de la Página.
- | Agregar marca de agua y copyright: como ulterior protección, activando también esta opción, la imagen es "ocultada" mediante la visualización de la imagen de marca de agua sobrepuesta. Además de la marca de agua se añade un rótulo con la indicación del Copyright: este rótulo es compuesto automáticamente tomando el Autor especificado en la ventana Ajustes Generales| Sección General, al Paso 1.

 Algunas notas sobre el funcionamiento del sistema de protección de las Imágenes:
- | Activando el sistema de protección, las Imágenes son introducidas en un objeto Flash: de este modo, Título y Texto alternativo no pueden ser mantenidos dentro del código HTML y, por lo tanto, no será posible aprovecharlos para la optimización de las páginas.
- | Las imágenes protegidas no pueden ser insertadas en el SiteMap. En efecto, para que el sistema de protección sea plenamente eficaz, es necesario que las imágenes protegidas no sean después introducidas en el SiteMap: en efecto, en caso contrario mediante el archivo XML del SiteMap sería posible conocer el nombre del archivo imagen original y, por lo tanto, conseguir descargarlo.
- | Si no se desea activar el sistema de protección propuesto, se puede igualmente trabajar directamente sobre las Imágenes con el Editor gráfico predisponiendo, mediante la especial sección, una imagen de marca de agua.

Temas relacionados:
- | Objeto Imagen
- | Editor gráfico


Objeto Imagen| Sección visualización

Mediante los comandos de la Sección Visualización de la ventana Objeto Imagen es posible definir algunos Modos de visualización para obtener una imagen panorámica con efectos de zoom y desplazamiento.

Los Modos de visualización disponibles son:

 Redimensionado automático de la Imagen: activa por defecto, esta opción hace que la Imagen sea introducida automáticamente redimensionada para adaptarse al tamaño asumido por la celda de la Rejilla de paginación que la contiene.

Zoom y movimiento manual de la Imagen: esta opción permite ampliar la imagen, con un clic del ratón, hasta alcanzar el tamaño previsto por el factor de zoom predispuesto. Una vez ampliada, la Imagen también podrá se desplazada de modo que pase al primer plano el detalle deseado. En este caso específico, el desplazamiento se debe efectuar manualmente, haciendo clic en la Imagen y arrastrándola hasta la posición deseada.
Para obtener este efecto, el tamaño de la Imagen debe ser antes reducido al de la Celda de la Rejilla de paginación y, de consecuencia, recalculado en base al factor predispuesto para el Zoom inicial (si se elige como Tipo del movimiento el Movimiento libre), o bien, en proporción a la Altura establecida (si se predispone como Tipo del movimiento la opción Vista panorámica horizontal o la opción Vista panorámica vertical). De este modo, la imagen resultará ser más grande respecto al área de visualización y será posible moverse en su interior.

Zoom y movimiento automático de la Imagen: análoga a la opción precedente, se distingue por el hecho de que el desplazamiento se produce acercando simplemente el ratón a los bordes de la imagen.

Después de haber seleccionado la opción Zoom y movimiento manual de la Imagen o la opción Zoom y movimiento automático de la Imagen, es posible utilizar los siguientes Ajustes Zoom:

-

Tipo del movimiento: permite especificar en qué dirección se puede desplazar la Imagen manual o automáticamente.

-

Desplazamiento libre: la imagen puede ser arrastrada tanto en sentido horizontal como vertical. En este caso es necesario especificar el valor del Zoom máximo: por ejemplo, un factor de ampliación predispuesto al 200% lleva a obtener un tamaño doble del original de la Imagen.

Imagen introducida | Imagen con efecto

-

Vista panorámica horizontal: la imagen puede ser arrastrada sólo en sentido horizontal. Para aprovechar al máximo este efecto es preciso insertar Imágenes con la base mucho mayor que la altura. En este caso es necesario especificar el valor en pixel de la altura de la Imagen en el campo especial Altura.
Imagen introducida | Imagen con efecto

-

Vista panorámica vertical: la imagen puede ser arrastrada sólo en sentido vertical. Esta vez es preciso utilizar Imágenes con altura mucho mayor de la base y predisponer en el campo Altura el valor en pixel de la altura que se desea mantener para la Celda de la Rejilla de paginación interesada.
Imagen introducida | Imagen con efecto

-

Zoom máximo: disponible sólo para la modalidad de desplazamiento Movimiento libre, permite predisponer el factor de ampliación que debe ser aplicado a la Imagen para que pueda resultar más grande respecto al área en que será visualizada. En efecto, si la imagen no fuese ampliada no podría ser arrastrada.

-

Altura: disponible sólo para las modalidades de desplazamiento Vista panorámica horizontal y Vista panorámica vertical, permite predisponer, en el primer caso, el valor en pixel de la altura de la Imagen, o, en el segundo caso, de la altura de la Celda de la Rejilla de paginación en que es visualizada la imagen.

-

Amplía la imagen: activa por defecto, esta opción hace que la imagen pueda ser amliada y reducida por el usuario mediante el clic del ratón. Al abrir la Página, la Imagen es visualizada con el tamaño original y el icono presente en el ángulo inferior derecho indica la posibilidad de hacer el zoom. Así pues, con el clic del ratón se amplía la Imagen en base al factor de zoom predispuesto.

-

Mostrar la Barra de Zoom: Está disponible sólo si se activa la opción Permitir la ampliación de la Imagen, y permite ver en la ventana Imagen una barra mediante la cual el usuario podrá regular y predisponer el zoom.

-

Mostrar el navegador: activando esta opción, se pone a disposición del usuario un navegador. El navegador es una pequeña ventana situada sobre la Imagen que contiene una miniatura de la imagen misma. La función del navegador es mostrar la Imagen completa y resaltar, mediante un recuadro, la porción actualmente visible. Las acciones posibles son:
- | hacer clic en el recuadro que resalta la porción visible de la Imagen y arrastrarlo a la posición deseada: equivale a desplazar manualmente la Imagen.
- | Hacer clic dentro del navegador, fuera del recuadro que muestra la porción visible de la Imagen, y arrastrarlo: permite desplazar el navegador dentro de la ventana Imagen.
- | Hacer clic en el ángulo inferior derecho del navegador y arrastrar en diagonal: permite cambiar la dimensión del navegador.
Desplazando el ratón al exterior de la ventana Imagen, el navegador desaparece con un efecto de movimiento en salida hacia el lado más cercano.

-

Activar movimiento continuo automático: hace que la imagen siga desplazándose automáticamente durante todo el tiempo en el que es visualizada. Puede ser útil para hacer entender al usuario que la imagen puede ser ampliada. EL usuario puede asumir el control del movimiento acercando simplemente el ratón a los bordes de la imagen, mientras puede hacer zoom con un simple clic para ampliar y con dos para disminuir.

Temas relacionados:
- | Objeto Imagen
- | Editor gráfico


Objeto Imagen| Sección SiteMap

Mediante los comandos de la Sección SiteMap de la ventana Objeto Imagen es posible hacer que en el SiteMap se introduzcan informaciones adicionales sobre la Imagen en la que se está trabajando.

En primer lugar es preciso activar la opción Agregar Imagen al SiteMap: de este modo el SiteMap que es creado automáticamente por WebSite X5 ( ver, Crear SiteMap automáticamente en Ajustes Generales| Sección Avanzado) se completa con las informaciones relativas a la imagen. Una vez hecho esto, es necesario definir los siguientes ajustes:
- | Título: es un parámetro opcional que permite especificar un título para la imagen.
- | Descripción breve: es un parámetro opcional que permite especificar una descripción o didascalia para la Imagen.
- | Posición geográfica: es un parámetro opcional que permite especificar informaciones, como dirección, ciudad o país, que sirven para localizar geográficamente la Imagen.
- | URL de la licencia: es un parámetro opcional que permite de especificar la URL del archivo que contiene la licencia de uso de la imagen.

 No es posible introducir en el SiteMap, Imágenes en las que se haya activado la protección contra descargas y uso no autorizados (ver, Protección en Objeto Imagen| Sección general).

Temas relacionados:
- | Objeto Imagen
- | Editor gráfico
- | Cómo crear y conectar el SiteMap del Sitio


Objeto Tabla

Las tablas son una óptima herramienta para organizar y presentar datos.

En muchos casos mediante una tabla es posible resumir y presentar de manera eficaz una cantidad de datos que, de otro modo, requerirían el desarrollo de un largo y prolijo texto descriptivo. Para simplificar, una tabla con las tarifas de un hotel, distintas por tipo de habitación y periodo del año, es mucho más simple de leer e interpretar que un texto que describe por extenso las mismas informaciones.

Además, las tablas ofrecen también la ventaja de ser un elemento gráfico capaz de embellecer la página y de romper la monotonía de un largo texto.

Obviamente, para que estas consideraciones mantengan su validez es necesario que las tablas estén bien estructuradas, no resulten demasiado complejas y tengan un aspecto agradable.

Consejos Práticos

Haciendo doble clic en el Objeto Tabla introducido en la Rejilla de paginación se accede a la ventana Objeto Tabla. Mediante esta ventana, que propone un editor, es posible efectuar directamente a la efectiva creación de la Tabla.

Por defecto, se propone una Tabla compuesta por dos filas y tres columnas, con un tamaño que ocupa completamente en anchura la Celda de la Rejilla de paginación que la contiene. Naturalmente, es posible añadir o eliminar filas y columnas, definir su tamaño, unir y dividir las celdas para crear Tablas más o menos complejas.

Como se observa, se dispone de los siguientes comandos:

 Cortar [CTRL+X] - Copiar [CTRL + C] - Pegar [CTRL + V]
Permiten, respectivamente, cortar, copiar y pegar el texto seleccionado. En este caso, antes de ser pegado, el texto pierde todas las formataciones eventualmente asociadas en origen y asume las definidas en el editor.

Pegar especial
Permite pegar el texto previamente colocado en el portapapeles de Windows mediante los comandos Cortar y Copiar. El texto pegado mantiene todas las formataciones originales.

Deshacer [CTRL+Z] - Rehacer [ALT+MAYUSC+BACKSPACE]
Permiten, respectivamente, anular y restablecer la última operación efectuada/anulada.

Insertar Enlace [CTRL+L]
Permite predisponer un enlace hipertextual en las palabras y/o en las imágenes seleccionadas. Es posible definir los ajustes del Enlace mediante la ventana abierta Enlace.

Insertar imagen
Esta opción permite insertar una imagen (en formato .JPG, .GIF, .PNG, .BMP) dentro de la celda de la Tabla. El tamaño de las imágenes introducidas puede ser libremente cambiado con las especiales manillas de selección.

Habilitar Código HTML
Permite introducir directamente el código HTML dentro de la tabla. Es decir, en modalidad HTML, los caracteres <y> no son interpretados como "menor" y "mayor", y lo que es introducido entre ellos es interpretado como un tag HTML.

Ajustes RollOver
Permite hacer que en el texto se predisponga el RollOver: de este modo, el texto ya no es estático sino deslizante. Es posible definir los ajustes del Roll Over a través de la ventana Ajustes del Roll Over.

Fondo claro/oscuro
Permite predisponer un color claro u oscuro para el fondo de la ventana del editor de la Tabla: de este modo es más simple, por ejemplo, componer los textos que, para tener un adecuado contraste respecto al fondo previsto por la Plantilla gráfica aplicada, deben ser de color blanco.

Agregar fila / Eliminar fila / Agregar columna / Eliminar columna
Permiten, respectivamente, añadir una línea o una columna después de aquella en la que está situado el cursor del ratón, o eliminar la línea o la colonna en la que está situado el cursor.

Unir celdas - Dividir celdas
Permiten, respectivamente, unir varias celdas adyacentes seleccionadas de modo que formen una única celda, o dividir la celda en la que se está, creando dos celdas una junto a otra horizontalmente.

Elección de la fuente - Tamaño de la fuente
Permiten, respectivamente, elegir el tipo de carácter (font) que utilizar y definir su tamaño.

El menú desplegable propone todas las fuentes instaladas en el ordenador en que se está trabajando. Es necesario considerar que si la fuente utilizada no está instalada también en el ordenador del visitante del Sitio web, ésta será sustituida automáticamente por una fuente similar.

Negrita [CTRL+B] - Cursiva [CTRL+I] - Subrayado [CTRL+U]
Permiten, respectivamente, poner en negrita, cursiva y subrayado el texto seleccionado.

Color texto - Color del fondo del texto
Permiten predisponer, mediante la ventana Color abierta, el color que aplicar al texto seleccionado o al fondo de la celda en que está situado el cursor del ratón.

Color del borde de la Celda
Permite predisponer, mediante la especial ventana abierta, el estilo de los bordes de la celda en curso. Es posible definir tanto el color como el grosor de los bordes que delimitan las líneas y/o las columnas de la Tabla.

Listado de viñetas
Permite crear el listado de viñetas.

Aumentar sangría / Reducir sangría
Permiten, respectivamente, aumentar o reducir la sangría del párrafo seleccionado.

Alinear texto a la izquierda - Alineamiento centrado - Alinear texto a la derecha - Alineamiento justificado
Permiten, respectivamente, alinear a la izquierda, al centro, a la derecha o justificar el texto seleccionado.

Texto hacia la derecha - Disposición normal - Texto hacia la izquierda
Si se activan cuando se selecciona una imagen introducida en una Celda junto a texto, permiten hacer que el texto se deslice a lo largo del lado derecho de la imagen , que la imagen quede dentro del flujo del texto como una palabra cualquiera, o que el texto se deslice a lo largo del lado izquierdo de la imagen.

Allinear en la parte superior - Alinear en el medio - Allinear en la parte inferior
Permiten, respectivamente, alinear verticalmente arriba, en el centro o abajo, el texto seleccionado.

Haciendo clic con la tecla derecha del ratón también es posible activar un menú contextual que, además de proponer de nuevo los comandos Anular, Cortar, Copiar, Pegar, Pegar especial, Eliminar, presenta también los comandos:

-

Altura filas
Permite predisponer, mediante la ventana abierta, el valor en pixel para definir la altura de las filas seleccionadas. Predisponiendo como valor 0, las filas asumen automáticamente la altura mínima necesaria para visualizar el contenido insertado.

-

Anchura columnas
Permite predisponer, mediante la ventana abierta, el valor en pixel para definir la anchura de las columnas seleccionadas.

Los tamaños de las filas, de las columnas o de cada una de las celdas pueden ser modificados también colocando el ratón sobre los bordes y arrastrándolos hasta la posición deseada manteniendo pulsada la tecla izquierda del ratón. Seleccionando una celda y desplazando su borde izquierdo y/o derecho se modifica sólo el tamaño de la celda en cuestión.

Si una tabla no contiene algún texto, se considerará como vacía y no podrá ser visualizada.

Temas relacionados:
- | La Rejilla de paginación en la Creación de la Página
- | La lista de los Objetos en la Creación de la Página
- | Insertar Enlace
- | Ajustes RollOver


Objeto Animación Flash

WebSite X5 permite introducir en las páginas varios tipos de Animaciones y efectos para hacerlas más atrayentes y espectaculares.

Se puede importar cualquier animación Flash (formato SWF): desde simples banner con textos e imágenes, hasta vídeos más complejos e interactivos, tanto guardados en el ordenador local como ya publicados en Internet.
En efecto, gracias a las funciones avanzadas disponibles, es posible también adjuntar eventuales archivos necesarios para la correcta reproducción de la Animación misma.

Consejos Práticos

Haciendo doble clic en el objeto Animación Flash introducido dentro de la Rejilla de paginación se accede a la ventana Objeto Animación Flash. A través de esta ventana es posible especificar qué archivo importar, definir sus propiedades y adjuntar eventuales archivos asociados.

Los comandos disponibles están divididos en dos secciones:
- | Sección General
- | Sección Avanzado

Temas relacionados:
- | La Rejilla de paginación en la Creación de la Página
- | La lista de los Objetos en la Creación de la Página


Objeto Animación Flash| Sección General

Mediante los comandos de la Sección General de la ventana Objeto Animación Flash es posible elegir qué archivo utilizar para la composición del Objeto Animación Flash.

La Animación Flash puede ser introducida importando un archivo presente en local o un archivo ya publicado en Internet. En el primer caso, es preciso activar la opción Archivo local, hacer clic en el botón [image] para ojear los recursos disponibles y localicar un archivo en formato SWF. En el segundo caso, en cambio, es necesario activar la opción Archivo de Internet y escribir en el campo especial la dirección en la que el recurso está ya disponible en línea.

La vista previa de la Animación importada puede ser visualizada en el interior de la ventana relativa, activando la opción Vista previa.

 Para poder visualizar la vista previa de la animación, es necesario instalar el Player de Macromedia Flash.

Para la Animazione introducida están disponibles las siguientes Propiedades:
- | Texto alternativo: permite insertar el texto que se presenta en lugar de la Animación Flash, cuando ésta no pueda ser visualizada.
- | Anchura: permite especificar el tamaño en pixel de la anchura de la Animación Flash. En la escrita entre paréntesis aparece el valor máximo que el Objeto puede asumir en anchura: este valor es determinado por la Rejilla de paginación predispuesta.
- | Altura: permite especificar el tamaño en pixel de la altura de la Animación Flash.
- | Versión Flash: permite especificar qué versión del Player Flash solicitar para la visualización de la Animación introducida. Si el usuario no dispone de la versión del Player Flash especificada, aparecerá automáticamente una ventana con la solicitud de actualización.
- | Fondo transparente: permite hacer transparente el fondo de la Animación insertada.

Temas relacionados:

-

Objeto Animación Flash


Objeto Animación Flash| Sección Avanzado

Mediante los comandos de la Sección Avanzado de la ventana Objeto Animación Flash es posible especificar, si es necesario, qué archivos asociados a la Animación Flash es preciso importar para que pueda funcionar correctamente.

Todos los archivos vinculados a la Animación Flash especificados, son visualizados mediante una tabla resumen en la que, además del nombre del archivo, aparece también la Ruta de acceso relativa en el Servidor.

Para componer la lista de los archivos vinculados a la Animación Flash es posible utilizar los siguientes comandos:
- | Agregar: permite, mediante la ventana Publicar archivo vinculado abierta, insertar un nuevo archivo vinculado.
- | Modificar: permite abrir la ventana Publicar archivo vinculado para modificar los ajustes definidos para el archivo seleccionado en la tabla resumen de los Archivos vinculados.
- | Eliminar: permite eliminar el archivo seleccionado de entre los presentes en la tabla resumen de los Archivos vinculados.

Por último, está disponible la opción:

-

Nombre de ruta para cargar el archivo Flash: permite especificar la ruta de acceso relativa de la carpeta en la que se debe publicar el archivo SWF de la Animación Flash.

Temas relacionados:

-

Objeto Animación Flash


Objeto Vídeo/Sonido

Con WebSite X5 es posible crear sitios capaces también de entretener agradablemente a los usuarios proponiendo, por ejemplo, vídeos y piezas musicales.

Actualmente los vídeos están conociendo un grado de difusión impensable hasta hace poco tiempo: hacer un vídeo, cargarlo en un ordenador, editarlo y, después, ponerlo en línea, se convertido en un proceso que todos pueden hacer.

Con WebSite X5 es posible importar de manera muy simple, cualquier tipo de vídeo, introducirlo en el propio Sitio y, de este modo, compartirlo. WebSite X5 acepta todos los principales formatos y utiliza un Player interno para la reproducción de los archivos FLV y MP4. Permite importar tanto archivos locales como archivos ya publicados en línea, incluídos aquellos de portales como YouTube y Vimeo.

Consejos Práticos

Haciendo doble clic en el Objeto Vídeo/Audio insertado en la Rejilla de paginación se accede a la ventana Objeto Vídeo/Audio. Mediante esta ventana es posible especificar el archivo que importar, definir sus propiedades, decidir si incluírlo en el SiteMap y, en caso afirmativo, insertar las informaciones necesarias.

Los comandos necesarios para proceder a la creación de un Objeto Vídeo/Audio están articulados en dos secciones:
- | Sección General
- | Sección SiteMap

Temas relacionados:
- | La Rejilla de paginación en la Creación de la Página
- | La lista de los Objetos en la Creación de la Página


Objeto Vídeo/Sonido| Sección General

Mediante los comandos de la Sección General de la ventana Objeto Vídeo/Sonido es posible elegir qué archivo utilizar para la creación del objeto Vídeo/Sonido además de definir algunos de sus ajustes inherentes a la modalidad de reproducción.

El objeto Vídeo/Sonido pueder ser insertado de diferente manera según donde esté el recurso a importar:

-

Archivo local su ordenador: una vez activada esta opción, basta hacer clic en el botón [image] para ojear los recursos disponibles y localizar el archivo en formato .MP4, .FLV, .AVI, .WMV, .MPG, .MOV, .MP3, .WMA, .WAV, .MID, .AIF, .M4A que se desea importar.

-

Archivo de Internet: una vez activada esta opción, es necesario escribir en el campo especial, la dirección URL en la que el archivo del Vídeo o del Audio está ya disponible en línea.

-

URL del Vídeo YouTube/Vimeo: una vez activada esta opción, es preciso escribir en el campo especial, la dirección URL de la página de portales como YouTube o Vimeo que contiene el Vídeo/Audio que se desea importar.

Intoduciendo de este modo un Vídeo publicado en YouTube, el tamaño original es modificado en base a los ajustes de WebSite X5. Si se desea mantener mayor control, se aconseja importar el vídeo YouTube mediante el Objeto HTML y Widgets en lugar de a través del Objeto Vídeo/Sonido.

La vista previa del Objeto Vídeo/Sonido importado puede ser visualizada en la especial ventana, activando la opción Vista previa.

En función del formato del archivo Vídeo/Audio importado, se utiliza un Player distinto para la visualización/reproducción:
Player | Archivo Vídeo | Archivo Audio
WebSite X5 Media Player | .MP4 y .FLV | .MP3
Microsoft Windows Media Player | .AVI, .WMV y .MPG | .WAV y .WMA
QuickTime Player | .MOV y .AIF | .M4A

Independientemente del Player utilizado para la visualización/reproducción del archivo importado, es posible definir las siguientes Propiedades:
- | Texto alternativo: permite introducir el texto que se presenta en lugar del Vídeo o del Sonido cuando éste no puede ser visualizado.
- | Anchura: permite especificar el tamaño en pixel de la anchura del Vídeo o de la Barra de controles para el Sonido. En la escrita entre paréntesis aparece el valor máximo que el Objeto puede asumir en anchura: este valor es determinado por la Rejilla de paginación predispuesta.
- | Altura: permite especificar el tamaño en pixel de la altura del Vídeo o de la Barra de controles para el Sonido. En lo escrito entre paréntesis se recuerda que el valor máximo para la altura de la Barra Controles del Sonido es de 35 pixel. En cambio, el valor mínimo es de 15 pixel.
- | Mostrar Barra de Controles: permite predisponer la visualizacion de una botonera con todos los comandos necesarios para gestionar la reproducción del Vídeo o del Sonido.
- | Reprodución automática: permite predisponer el inicio automático de la reproducción del Vídeo o del Audio.

Sólo en el caso en que para la visualización/reproducción del archivo importado se utilice el WebSite X5 Media Player, además de las citadas, están disponibles también las siguientes Propiedades:
- | Habilitar pantalla completa: activando esta opción, se pone a disposición en la Barra de Controles el comando para ampliar a toda pantalla la ventana en la que se ve el Vídeo.
- | Ocultar automáticamente la Barra de Controles: activando esta opción, la Barra de controles es visualizada sólo en cuando el ratón pasa por la ventana en que se reproduce el Vídeo/Audio.
- | Color Barra de Controles: permite especificar, mediante la ventana Color abierta, el color de la Barra de Controles.

Temas relacionados:

-

Objeto Vídeo/Sonido


Objeto Vídeo/Sonido| Sección SiteMap

Mediante los comandos de la Sección SiteMap de la ventana Objeto Vídeo/Sonido es posible hacer que en el SiteMap del Sitio aparezcan informaciones adicionales sobre el Vídeo en el que se está trabajando.

En primer lugar es preciso activar la opción Agregar Vídeo al SiteMap: de este modo el SiteMap que es creado automáticamente por WebSite X5 ( ver, Crear SiteMap automáticamente en Ajustes Generales| Sección Avanzado) es completado con las informaciones relativas al Vídeo. Una vez hecho esto, es necesario definir los siguientes ajustes:
- | Título: es un parámetro obligatorio que requiere especificar un título para el Vídeo. El límite impuesto por Google para la longitud de los títulos es de 100 caracteres.
- | Descripción breve: es un parámetro obligatorio que requiere especificar un breve texto descriptivo para el Vídeo. El límite impuesto por Google para la longitud de las descripciones es de 2048 caracteres: descripciones más largas son truncadas.
- | Categoría: es un parámetro opcional que permite especificar una categoría a la que podría pertenecer el Vídeo, por su contenido. Google especifica que cada Vídeo puede pertenecer a una única categoría e impone el límite para la longitud del nombre de la categoría a 256 caracteres.
- | Palabras clave para la búsqueda: es un parámetro opcional que permite especificar una lista de tag, o sea, breves descripciones de los conceptos clave asociados al Vídeo. Google especifica que cada Vídeo puede tener hasta un máximo de 32 tag.
- | Imagen de vista previa del Vídeo: es un parámetro obligatorio que requiere especificar una Imagen de vista previa que asociar al Vídeo. Google aconseja utilizar para estas miniaturas un tamaño mínimo de 120x90 pixel y guardarlas en formato .JPG, .PNG o .GIF.
- | Fecha de publicación: es un parámetro opcional que permite especificar la fecha de publicación del Vídeo.
- | Duración: es un parámetro opcional que permite especificar la duración en segundos del Vídeo. Google recomienda fuertemente insertar esta información y especifica que el valor insertado debe estar comprendido entre 0 y 28800 (equivalente a 8 horas).
- | Contenido adecuado a menores de edad: es un parámetro opcional que permite especificar si el contenido del Vídeo puede ser visto por un público menor de edad. Google advierte que si un Vídeo no es predispuesto como decuado a menores de edad, estará disponible sólo para usuarios con el filtro SafeSearch desactivado. Recordamos que la función SafeSearch de Google filtra los sitios con contenidos sexuales o pornográficos explícitos y los elimina de los resultados de búsqueda.

Temas relacionados:
- | Objeto Vídeo/Sonido
- | Cómo crear y conectar el SiteMap del Sitio


Objeto Galería

La increíble difusión de las cámaras fotográficas digitales y de los servicios en línea hace extraordinariamente simple publicar y conpartir enteras colecciones de fotografías a través de la Web.
De este modo es posible publicar las fotos de familia para que las vean parientes y amigos lejanos, o bien crear álbumes y catálogos para aficiones o trabajo.

Con WebSite X5 es posible insertar increíbles Galerías mediante la cuales mostrar, no sólo las propias fotografías, sino también los propios vídeos. Las Galerías disponibles están hechas en Flash o en JavaScript y adoptan efectos y métodos de navegación y visualización distintos: pueden, por ejemplo, presentar un barra de control, una secuencia o una rejilla de miniaturas.

En general, las Galerías en JavaScript se distinguen de las Galerías en Flash, además de por la tecnología utilizada, por el uso de la ventana ShowBox para la visualización de las Imágenes ampliadas. En estos casos, el usuario hace clic en una de las miniaturas disponibles y la Imagen o el Vídeo correspondiente se abre en la especial ventan sobrepuesta a la Página principal. A continuación, colocando el ratón sobre la Imagen abierta aparecen visualizados los botones que permiten pasar directamente a la imagen precedente/siguiente sin tener que regresar a las miniaturas.

El aspecto de la ventana ShowBox Puede ser completamente personalizado: mediante las opciones presentes en la sección Estilos y Plantillas| Sección ShowBox del Paso 4 - Ajustes Avanzados es posible, por ejemplo, predisponer colores, sombras, opacidades y efectos de apertura.

Consejos Práticos

Haciendo doble clic en el Objeto Galería introducido en la Rejilla de paginación se accede a la ventana Objeto Galería. Mediante esta ventana es posible elegir el tipo de Galería en Flash o en JavaScript que realizar, crear la lista de Imágenes/Vídeo que utilizar, definir los ajustes necesarios para personalizarla y, si es necesario, trabajar en el aspecto gráfico de las miniaturas.

Los comandos necesarios para proceder a la creación de una Galería están articulados en tres secciones:
- | Sección Estilo
- | Sección Lista
- | Sección Miniaturas

 Las Galerías en JavaScript se pueden abrir también mediante un especial enlace introducido en las Páginas: para más información, véase Enlace.

Temas relacionados:
- | La Rejilla de paginación en la Creación de la Página
- | La lista de los Objetos en la Creación de la Página
- | Estilos y Plantillas| Sección ShowBox


Objeto Galería| Sección Estilo

Mediante los comandos de la Sección Estilo de la ventana Objeto Galería es posible elegir el tipo de Galería que se desea realizar y definir sus ajustes generales.

Como ya se ha dicho, WebSite X5 permite elegir entre dos tipos de Galerías: las Galerías en Flash y las Galerías en JavaScript.

Las Galerías en Flash disponibles son:
- | Presentación Clásica Es una Galería en la que las Imágenes y los Vídeos son presentados en secuencia, uno tras otro: si está predispuesta, la modalidad de visualización de las Imágenes depende del tipo de efecto de entrada. El paso de una Imagen a otra puede ser controlado con los comandos de la Barra de controles. Dentro de la Barra de controles es posible prever la visualización de pequeñas Miniaturas para permitir al usuario abrir enseguida las Imágenes o los Vídeos que le interesen.
- | Galería horizontal En esta Galería se propone una serie de Miniaturas, colocadas en horizontal encima o debajo de la Imagen en primer plano. Basta colocar el ratón sobre las Miniaturas para que éstas se desplacen hacia la derecha/izquierda: haciendo clic en una Miniatura, la imagen o el Vídeo correspondiente es visualizado en primer plano. Las imágenes ampliadas son visualizadas en base al efecto de entrada eventualmente predispuesto.
- | Galería Vertical Análoga a la precedente, esta galería se distingue sólo por el hecho de que las Miniaturas son visualizadas en vertical, a la derecha o a la izquierda respecto a la Imagen en primer plano.

Las Galerías en JavaScript disponibles son:
- | Miniaturas También en esta Galería aparece una rejilla con todas las Miniaturas: haciendo clic en una Miniatura, la Imagen o el Vídeo correspondiente se abre en primer plano mediante la ventana ShowBox.
- | Miniaturas su varias fichas Esta galería es análoga a la precedente pero, sobre todo en el caso en que las Imágenes a incluir sean muchas, permite dividirlas en fichas definiendo el número máximo de filas de Miniaturas que visualizar: el usuario podrá pasar de una ficha a otra, quedándose siempre en la misma Página del Sitio, a través de la especial botonera.
- | Miniaturas Horizontal En esta galería aparece una única tira horizontal de Miniaturas. Haciendo clic en una Miniatura, la imagen o el Vídeo es visualizado mediante la ventana ShowBox.
- | Miniaturas Vertical Análoga a la precedente, esta galería se distingue sólo por el hecho de que las Miniaturas son visualizadas en vertical.

En función del tipo de Galería seleccionado, se proponen Ajustes distintos que efectuar.

Para las Galerías en Flash los Ajustes disponibles son:
 |  | SlideShow Clásico | Galería Horizontal | Galería Vertical
- | Anchura Permite definir el tamaño máximo en pixel de la anchura que las Imágenes pueden asumir. | Sí | Sí | Sí
- | Altura Permite definir el tamaño máximo en pixel de la altura que las imágenes pueden asumir. | Sí | Sí | Sí
- | Visualizar Miniatura en la Barra de controles: Activa por defecto, esta opción hace que en la Barra de controles que aparece al pasar el ratón, además de los botones, estén presentes también las Miniaturas de todas las imágenes. De este modo, el usuario no está vinculado a una consulta en secuencia sino que puede visualizar enseguida las Imágenes o los Vídeos que más le interesen. | Sí | No | No
- | Miniaturas visibles Permite predisponer el número de Miniaturas que deben ser visualizadas junto a la Imagen principal. | No | Sí | Sí
- | Posición Miniaturas Permite definir dónde se deben visualizar las Miniaturas respecto a la Imagen principal. | No | Sí | Sí

Para las Galerías en Flash también es posible activar las siguientes Propiedades:
- | Mostrar Barra de Controles: activa por defecto, permite predisponer la visualización, al pasar el ratón, de una Barra de Controles mediante la cual el usuario podrá controlar la navegación entre las Imágenes y los Vídeos de la Galería. De base, la Barra de controles presenta los botones [image] Inicio presentación, [image] Imagen precedente e [image] Imagen sucesiva.
- | Reproducción automática: permite hacer que la reproducción de Imágenes y Vídeos empiece automáticamente apenas es visualizada la Galería.
- | Visualizar en orden casual: permite hacer que las imágenes y los vídeos sean propuestos, no en base al orden de inserción, sino en base a una secuencia determinada casualmente.
- | Color de la barra de Control: permite especificar, mediante la ventana Color abierta, el color para la Barra de Controles.
- | Color Fondo: permite especificar, mediante la ventana Color abierta, el color del fondo de la Galería.
- | Tamaño de la Fuente: permite predisponer el tamaño del texto presentato como título de la Imagen o del Vídeo en primer plano.
- | Banda Sonora: permite predisponer un archivo musical (archivo en formato .MP3) que reproducir como columna sonora durante la visualización de la Galería.

Para las Galerías en JavaScript los Ajustes disponibles son:
- | Diapositivas visibles: permite predisponer cuántas Miniaturas se deben ver efectivamente.
- | Filas por página: disponible sólo para la Galería Miniaturas en varias fichas, permite predisponer el número de filas de la matriz en la que las Miniaturas son organizadas.
- | Mostrar ampliación con clic mediante ShowBox: activa por defecto, esta opción permite predisponer en la Miniatura el enlace que lleva a la visualización de la Imagen o del Vídeo correspondiente dentro de la ventana ShowBox.
- | Anchura / Altura: disponibles sólo en el caso en el que esté activa la opción Mostrar ampliación con clic mediante ShowBox, permiten predisponer el valor máximo de la anchura y de la altura de la ventana ShowBox.

Temas relacionados:
- | Objeto Galería
- | Estilos y Plantillas| Sección ShowBox


Objeto Galería| Sección Lista

Mediante los comandos de la Sección Lista de la ventana Objeto Galería es posible efectuar la composición de la lista de las Imágenes y de los Vídeos que se deben introducir en la Galería.

Todos los archivos ya importados son visualizados en la Lista de archivos: al seleccionar un archivo de la lista, se podrá ver en la ventana su vista previa.
En la Lista de archivos, para cada Imagen y Vídeo introducido, se presenta la ruta de acceso del archivo, el efecto de aparición eventualmente asociado, una marca de selección para indicar la asociación de un enlace y una descripción.

Los comandos disponibles para componer el Objeto Galería son:

-

Agregar / Eliminar: permiten, respectivamente, añadir nuevos archivo o quitar los seleccionados a/de los ya introducidos. Pueden ser importados archivos gráficos en formato: .JPG, .GIF, .PNG, .PSD, .BMP, .TIF, .DIB, .PCX, .RLE, .TGA, .WMF. Además, pueden ser importados archivos vídeo en formato: .FLV y .MP4.
Haciendo clic en el triángulo presente en el botón Agregar es posible visualizar un submenú con las siguientes opciones: Agregar Imagen, Agregar Vídeo y Agregar Vídeo YouTube/Vimeo.

Mediante la ventana abierta por el comando Agregar Vídeo YouTube/Vimeo es posible especificar la dirección URL del vídeo ya publicado en portales como YouTube o Vimeo que se desea introducir.

-

Subir / Bajar: permiten desplazar el archivo seleccionado a antes o después del archivo precedente o sucesivo en la Lista de los archivos.

-

Editar: permite activar el Editor gráfico interno para modificar la Imagen seleccionada en la Lista de los archivos.

En base al tipo de Galería elegida (ver Objeto Galería| Sección Estilo), para cada Imagen/Vídeo introducido se pueden definir algunas Opciones:
- | Efecto: haciendo clic en el botón [image] se abre la ventana Propiedades Efecto mediante la cual es posible predisponer efecto en entrada, movimiento y zoom para las Imágenes y los Vídeos de la Galería seleccionados entre los presentes en la Lista de archivos. Los efectos predispuestos son reproducidos sólo en las Galería en Flash. En las Galerías en JavaScript, en cambio, está previsto el efecto Difuminado en todas las Imágenes y los Vídeos introducidos.
- | Enlace: haciendo clic en el botón [image] se abre la ventana Enlace que permite definir el enlace que asociar a la Imagen seleccionada entre las presentes en la Lista de archivos. En el caso de las Galerías JavaScript, el enlace así predispuesto sustituye a aquel con la Imagen ampliada aunque se active la opción Mostrar ampliación con clic mediante ShowBox. En el caso de las Galerías en Flash, el enlace puede ser predispuesto también en los Vídeos.
- | Descripción: esta opción permite insertar un texto de descripción para la Imagen o el Vídeo seleccionado en la Lista de los archivos. El texto de descripción aparece en la parte inferior de la ventana que muestra la Imagen o el Vídeo ampliado.

Temas relacionados:
- | Objeto Galería
- | Editor gráfico
- | Ventana Propiedad Efecto


Objeto Galería| Sección Miniaturas

Mediante los comandos de la Sección Miniatura de la ventana Objeto Galería es posible definir los ajustes relativos al aspecto gráfico de las Miniaturas de las Galerías que las prevén.

La Miniatura es una versión reducida de la Imagen o del Vídeo introducido en la Galería y es creada automáticamente por el Programa. Para hacerlas más bonitas, las Miniaturas se presentan dentro de marcos que las hacen similares a diapositivas, fotogramas de una película, post-it, etc.

Para definir el aspecto de las Miniaturas es posible elegir si usar:

-

Imagen predeterminada: esta opción permite elegir el diseño del marco que será colocado a las Miniaturas, seleccionándolo directamente de entre los propuestos.

-

Imagen personalizada: permite abrir el archivo gráfico (en formato .JPG, .GIF, .PNG, .BMP, .PSD, .TIF, .DIB, .PCX, .RLE, .TGA, .WPG) correspondiente al marco que se desa utilizar.

Para crear un nuevo marco, basta diseñar la imagen y guardarla en un archivo especial: es preferible que la imagen del marco sea cuadrada y, si es necesario mantener una transparencia externa, guardarla en formato .PNG.

También es posible utilizar las siguientes Opciones para las Miniaturas:

-

Margen externo a la Imagen (%): esta opción permite definir el margen que se deberá guardar entre la Imagen de la Miniatura y los bordes del marco.

-

Activar variación de color: si se activa, esta opción permite especificar, a través de la ventana Color abierta, el color correspondiente al marco de las Miniaturas. Básicamente se aplica un efecto "coloreado" a la Imagen del marco para cambiarlo por el color deseado.

El efecto de la variación de color se puede utilizar con buenos resultados sólo en marcos que no sean en blanco y negro: en efecto, en estos casos, la opción de "coloreado" no cambia el color.

Temas relacionados:

-

Objeto Galería


Objeto Formulario de envío de correo electrónico

Navegando en Internet, ocurre a menudo que se ven páginas con Formularios de los que se pide la compilación para el envío mediante Correo electrónico de los datos recogidos. Dichos Formularios son utilizados como simples módulos de contacto, para solicitar la inscripción a determinados servicios o el acceso a áreas reservadas mediante clave de acceso o, también, para realizar sondeos y búsquedas.

Cualquiera que sea la finalidad, WebSite X5 permite crear de manera muy simple un Formulario de envío de correo electrónico, permitiendo especificar los campos necesarios, modificar la paginación y el aspecto gráfico y, sobre todo, establecer cómo se debe producir el envío y la recogida de los datos.

Consejos Práticos

Haciendo doble clic en el Objeto Formulario de envío de correo electrónico insertado en la Rejilla de paginación se accede a la ventana Objeto Formulario de envío de correo electrónico. A través de esta ventana es posible definir los campos que deben componer el Formulario, la modalidad de envío y recogida de los datos, el aspecto gráfico del Formulario.

Las diferentes opciones se presentan en las siguientes secciones:
- | Sección Lista
- | Sección Enviar
- | Sección Estilo

 Cuando se prueba el funcionamiento del Sitio creado en local, una ventana de aviso advierte de que los correos electrónicos con los datos recogidos mediante el Formulario no serán enviados. El formulario de correo electrónico funciona plenamente sólo con la publicación del Sitio en el Servidor.

Para el funcionamiento correcto del Formulario de envío de correo electrónico es necesario que el Servidor en el que será publicado el Sitio soporte el lenguaje de programación PHP y que esté activo el comando MAIL. Mediante la sección Prueba WebSite del Panel de control en línea es posible tener estas informaciones de diagnóstico en el Servidor.

Si se verifican problemas en el envío de los correos, es probable que el Servidor utilizado no esté configurado de modo estándar. En estos casos, se recomienda intentar modificar las predisposiciones relativas al script y al método utilizados para el envío de los correos electrónicos a través de las especiales opciones presentes en la ventana Preferencias. Para ulteriores informaciones al respecto, ponerse en contanto con el propio Proveedor de espacio Web.

Temas relacionados:
- | La Rejilla de paginación en la Creación de la página
- | La lista de los Objetos en la Creación de la página
- | Panel de control en línea
- | Ventana Preferencias


Objeto Formulario de envío de correo electrónico| Sección Lista

Mediante los comandos de la Sección Lista de la ventana Objeto Formulario de correo electrónico se puede definir la lista de campos que deben componer un Formulario de correo electrónico.

Todos los campos ya creados son visualizados en la tabla resumen que, para cada uno de ellos, contiene: Nombre campo, Tipo de campo, Anchura, si la respuesta ha sido predispuesta como Obligatoria, o no, y Descripción. Todos estos parámetros pueden ser predispuestos en fase de creación del Campo, a través de la especial ventana Recuadro campo.

La Tabla, además de resumir los principales datos en todos los Campos insertados, también es una útil herramienta de trabajo que permite varias operaciones:
- | Haciendo doble clic en un Campo, se abre la ventana Recuadro campo y se puede iniciar su modificación;
- | Haciendo clic una segunda vez en un Campo ya seleccionado se puede modificar su Nombre: equivale a abrir la ventana Recuadro campo y a cambiar el texto insertado como Etiqueta;
- | Después de haber seleccionado un Campo es posible utilizar los comandos de la botonera de al lado para crear una copia suya, eliminarlo, desplazarlo hacia arriba o hacia abajo, o modificar sus predisposiciones.
Además, mediante la Tabla también es posible controlar la disposición de los Campos en el Módulo. En primer lugar, una ligera línea discontinua indica las líneas en las que se desarrollará el Formulario. Además, si se pone un Campo al lado del precedente, junto a la indicación de su anchura, aparece el icono [image]. Por último, si las anchuras de los Campos predispuestos como juntos en la misma línea exceden el 100% del espacio disponible, el icono con un punto exclamativo [image] señala la imprecisión: si no se modifican las anchuras, los Campos quedarán dispuestos en líneas distintas.

Junto a la Tabla están presentes los comandos útiles para proceder a la creación de la lista de los Campos que irán a componer el Formulario:
- | Agregar: permite abrir la ventana Insertar campo para proceder a la inserción de un nuevo Campo dentro del Formulario.
- | Duplicar: permite crear una copia del campo seleccionado entre aquellos ya introducidos en el formulario.
- | Eliminar: permite eliminar el campo seleccionado.
- | Subir / Bajar: permiten, respectivamente, desplazar el Campo seleccionado a antes o después del campo precedente o sucesivo de entre los ya introducidos en el Formulario.
- | Editar: permite abrir la ventana Recuadro campo mediante la cual modificar las predisposiciones del Campo seleccionado de entre los ya introducidos en Formulario.

La ventana Insertar campo abierta por los comandos Agregar y Modificar es aquella mediante la cual es posible proceder efectivamente a la definición de los Campos. Esta ventana presenta dos secciones:
- | Sección Tipo de campo
- | Sección Opciones

 Los botones Envía, para enviar el formulario compilado, y Cancela, para eliminar todos los datos introducidos en el formulario, son creados automáticamente por el Programa y colocados al final del Formulario.

Temas relacionados:

-

Objeto Formulario de envío de correo electrónico


Objeto Formulario de envío de correo electrónico| Sección Lista| Tipo de campo

Las opciones presentes en la sección Tipo de campo de la ventana Insertar campo permiten crear la lista de Campos que compondrán el Formulario de envío del correo electrónico.

Los tipos de Campo entre los que es posible elegir son:

 Campo de texto: campo de texto dispuesto en una fila que es visualizado como un recuadro vacío dentro del cual el usuario puede escribir libremente la respuesta que considere oportuna.

Correo electrónico: campo de texto específico para solicitar al usuario que proporcione una dirección de correo electrónico. En estos casos, se predispone automáticamente un filtro para controlar que cuanto se introduce sea exacto: por ejemplo, para que se considere válida una dirección debe contener el carácter "@" y presentar un punto en el texto que sigue.

Área de texto: campo de texto dispuesto en varias filas específico para permitir que el usuario deje un propio comentario o pregunta.

Fecha: campo de texto específico para pedir al usuario que proporcione una fecha. La fecha solicitada puede ser escrita o introducida mediante un especial calendario.

Lista desplegable: las respuestas disponibles están presentadas en un listado desplegable en donde el usuario puede escoger solamente una.

Lista: las respuestas disponibles están presentadas en una lista y el usuario puede escoger solamente una.

Elección múltiple: las posibles respuestas, entre las que el usuario puede seleccionar incluso más de una, se presentan una tras otra, como una lista de opciones.

Elección única: las respuestas disponibles son presentadas una tras otra en un listado de viñetas, en donde el usuario puede seleccionar sólo una opción.

Contraseña: campo de texto en el que los caracteres introducidos son automáticamente ocultados, o sea, visualizados como "puntos" o asteriscos (según al sistema operativo en uso). Es útil para permitir a los usuarios especificar la contraseña con que desean registrarse para acceder a un servicio.

Archivo adjunto: campo de texto en el que el usuario, mediante el botón [image] para ojear los recursos disponibles, puede especificar el archivo que desea enviar como adjunto.

Para el correcto funcionamiento de los archivos adjuntos es necesario ponerse en contacto con el propio Proveedor del Espacio web para verificar que el servicio esté activo.

Pregunta de control: campo de texto en el que el usuario debe escribir la respuesta a una pregunta formulada con la intención de discriminar entre usuarios reales y programas que aprovechan los formularios de contacto publicados en línea para el envío de correo no deseado.

Condiciones de aceptación: campo de texto en el que se presentan las condiciones que el usuario debe aceptar para proceder al envío de los datos. Este campo puede ser utilizado, por ejemplo, para presentar las condiciones a las cuales se debe atener el usuario para mantener la privacidad en el manejo de los datos obtenidos.

Según el tipo de campo seleccionado, aparecen diferentes opciones. Las opciones comunes a todos las Campos son:
- | Etiqueta: permite introducir la descripción del campo. Este texto aparecerá encima, al lado o dentro del Campo al que hace referencia y debe ser utilizado para especificar la información solicitada o para presentar el texto de la pregunta que se desea hacer al usuario.
- | Anchura: permite definir la anchura del Campo y puede asumir un valor variable desde el 5 al 100% del espacio disponible.
- | Mostrar en la misma fila que el campo anterior: activando esta opción, el Campo no es colocado en una nueva fila sino junto al Campo precedente. Juntar dos Campos en la misma fila es posible sólo se si tienen anchuras que sumadas no superen el 100% del espacio disponible.
- | Póngase como campo obligatorio: esta opción establece que el usuario obligatoriamente responda a la pregunta. Esta opción no está disponible para los Campos de Elección múltiple y está activada por defecto para los Campos Pregunta de control.

Para cada tipo de Campo se añaden, además de las comunes, las siguientes opciones específicas:
Campo texto:

-

Número máx. de caracteres: activando esta opción es posible especificar el número máximo de caracteres que se pueden introducir en el campo. Por ejemplo, se puede fijar en 15 el número máximo de caracteres para un Campo de texto destinado a recoger el Código de Identificación fiscal del usuario.

-

Filtro sobre la inserción del texto: permite predisponer un control sobre la exactitud de los datos introducidos por el usuario en el campo. Es posible elegir alguno de los siguientes filtros:
- | Ninguno: son aceptados números y caracteres.
- | Solo números: solamente son aceptados caracteres numéricos.
- | Número telefónico/fax: acepta caracteres numéricos, el carácter "-" y el espacio.
- | Fecha: acepta caracteres numéricos y el carácter "/".
Correo electrónico:

-

Solicitar confirmación de dirección de correo electrónico: activando esta opción es añadido automáticamente un Campo donde el usuario debe escribir una segunda vez la propia dirección de correo electrónico. En automático será controlada la exacta correspondencia de la dirección de correo electrónico escrita en los dos Campos y, si es necesario, aparecerá un mensaje de aviso.
Área de texto:

-

Número máximo de caracteres: activando esta opción es posible especificar el número máximo de caracteres que se pueden introducir en el campo.

-

Número filas: permite definir la altura del Campo, especificando el número de filas en las que se puede disponer el texto (con un máximo de 30).
Fecha:

-

Formato fecha: permite elegir qué formato debe tener la fecha introducida con las normales disposiciones nacionales e internacionales.

-

Mostrar icono de "Calendario": activa por defecto, permite visualizar, junto al Campo Fecha, el icono "Calendario". Haciendo clic en este icono aparece visualizado un calendario mediante el cual el usuario puede introducir la fecha solicitada sin tener que escribirla manualmente.
Lista:

-

Número filas: permite definir la altura del Campo, especificando el número de filas visualizadas (con un máximo de 30).
Elección Múltiple/Única:

-

Número de columnas: permite definir el número de columnas en que se deben disponer las posibles modalidades de respuesta.
Contraseña:

-

Solicitar confirmación de contraseña: activando esta opción se añade automñaticamente un Campo donde el usuario debe escribr una segunda vez la contraseña elegida. En automático se controlará la correspondencia exacta de la contraseña escrita en los dos campos y, si es necesario, aparecerá un mensaje de aviso.
Pregunta de control:

-

Respuesta correcta: permite especificar la respuesta correcta que será comparada con la dada por el usuario.
Condiciones de aceptación:

-

Texto de la condición: permite insertar el texto de las condiciones que el usuario deberá aceptar antes de poder iniciar el envío efectivo de los datos.

Por último, es preciso especificar que para los campos Lista desplegable, Lista, Elección múltiple y Elección única es posible crear la lista de las respuestas posibles mediante los siguientes comandos:
- | Agregar / Eliminar: permiten, respectivamente, añadir una nueva modalidad de respuesta o eliminar la modalidad de respuesta seleccionada. Basta hacer clic una segunda vez en una opción seleccionada para poderla modificar.
- | Subir / Bajar: permiten, respectivamente, modificar el orden de visualización de las posibles respuestas, desplazando hacia arriba o hacia la bajo la seleccionada.
- | Modificar: permite modificar la modalidad de respuesta seleccionada.

Temas relacionados:

-

Objeto Formulario de envío de correo electrónico| Sección Lista


Objeto Formulario de envío de correo electrónico - Sección Lista

Objeto Formulario de envío de correo electrónico| Sección Lista| Opciones

Las opciones presentes en la sección Opciones de la ventana Insertar campo permiten modificar algunas propiedades avanzadas de los Campos de un Formulario de correo electrónico.

Concretamente, las opciones disponibles son:
- | Descripción de campo: permite insertar un mensaje cuya función es explicar el tipo de información que debe introducir el usuario en el Campo. En el caso en el que esté presente, junto al Campo aparece un icono (personalizable) que comunica la disponibilidad de más información: cuando se pasa el ratón sobre dicho icono aparece una Tip con las informaciones disponibles.
- | Atributo <name>: permite especificar el valor que asociar al atributo <name> del campo, en el momento en el que se genera el código HTML relativo al Formulario. Esta opción es útil, por ejemplo, cuando como método de Envío de los datos (ver: Objeto Formulario de envío de correo electrónico| Sección Enviar) se predispone Enviar datos a un archivo.
- | Nombre de campo base de datos: permite especificar el nombre que atribuir al campo para que el dato recogido pueda ser correctamente reconocido e insertado dentro de la base de datos. Esta opción es útil, por ejemplo, cuando, como método de Envío de los datos (ver: Objeto Formulario de envío de correo electrónico | Sección Enviar) se predispone Enviar datos a una base de datos.

Temas relacionados:
- | Objeto Formulario de envío de correo electrónico| Sección Lista
- | Objeto Formulario de envío de correo electrónico| Sección Enviar


Objeto Formulario de envío de correo electrónico - Sección Enviar

Objeto Formulario de envío de correo electrónico| Sección Enviar

Mediante los comandos de la Sección Enviar de la ventana Objeto formulario de correo electrónico se pueden definir las modalidades relativas al envío mediante correo electrónico de los datos recogidos con el formulario creado.

En el recuadro Envío de los datos se pide que se especifique cómo deben ser enviados al administrador el Sitio los datos recogidos mediante el formulario. Es posible escoger entre tres alternativas:

Enviar los datos por correo electrónico: es la opción prevista por defecto. Los datos recogidos con el formulario son enviados automáticamente mediante correo electrónico, aprovechando un script PHP ya predispuesto.

Enviar los datos a una Base de datos: los datos recogidos con el Formulario son enviados automáticamente a la base de datos MySQL especificada, mediante un script PHP ya predispuesto.

Enviar datos a un archivo de script: los datos recogidos con el Formulario son tratados aprovechando el script especificado (PHP, ASP, etc.). Esta opción es útil si se desea utilizar un propio script, por ejemplo para enviar datos si PHP no está disponible en el propio Servidor, o bien si desean activar procedimientos y gestiones particulares.

En base al método de envío seleccionado es preciso especificar una serie de parámetros:
Enviar los datos por correo electrónico: | - | Correo electrónico del remitente: activando esta opción, es posible especificar qué dirección utilizar como remite del correo electrónico que es enviado con los datos recogidos mediante el Formulario creado. Por defecto, como correo electrónico del remitente se utiliza el mismo correo electrónico del destinatario que, en este caso, corresponde con el administrador del Sitio. Si se especifica usar como correo electrónico del remitente el del usuario que ha compilado el Formulario, será posible, por ejemplo, utilizar directamente el comando Responder del programa de Correo electrónico.
 | - | Correo electrónico de destino: permite especificar la dirección de correo electrónico a dónde será enviada la información contenida en el formulario. Es posible especificar más de una dirección de correo electrónico: para hacerlo es preciso escribir todas las direcciones de correo electrónico separadas por un punto y coma.
 | - | Objeto: permite especificar el objeto del correo electrónico con los datos recogidos mediante el Formulario creado.
 | - | Mensaje: permite insertar el texto que aparecerá en el correo electrónico introduciendo los datos obtenidos a través del Formulario creado.
 | - | Incluir los datos recogidos en formato CSV: permite hacer que los datos recogidos sean guardados también en un archivo de formato CSV, incluído al final del correo electrónico. En un archivo CSV los datos son presentados bajo forma de texto, como una larga lista de opciones separadas por un punto y coma: dichos archivos pueden ser fácilmente importados en los programas para la gestión de las hojas de cálculo (por ejemplo, Microsoft Excel).
Enviar los datos a una Base de datos: | - | Nombre del host: es la dirección URL del Servidor MySQL en la que reside la Base de datos en línea que se desea utilizar. En la mayor parte de los casos, la Base de datos reside en el mismo Servidor que aloja también el sitio Web al que se está conectado y, por lo tanto, puede ser localizada con la expresión "localhost". En cualquier caso, es conveniente verificar el dato con el propio Proveedor.
 | - | Nombre de la base de datos: en este campo se debe introducir el nombre de la Base de datos en la que se desea trabajar (dato suministrado por el Proveedor).
 | - | Nombre de la tabla: en este campo se debe insertar el nombre de la Tabla, dentro de la Base de datos, en la que se desea recoger los datos. Las Tablas pueden ser creadas accediendo a la Base de datos mediante la especial aplicación en línea. En cualquier caso, si se introduce el nombre de una Tabla aún no existente, ésta será creada automáticamente.
 | - | Nombre usuario: en este campo se debe insertar el Nombre usuario establecido para poder acceder la propia Base de datos en línea (dato suministrado por el Proveedor).
 | - | Contraseña: en este campo se debe insertar la Contraseña establecida para poder acceder a la propia Base de datos en línea (dato suministrado por el Proveedor).
Enviar datos a un archivo: | - | Archivo de script (por ejemplo: PHP, ASP): permite importar el archivo de elaboración que se desea utilizar para recoger los datos del Formulario y enviarlos. En este caso, el archivo de elaboración debe ser creado manualmente para resolver la tarea deseada.

En cambio, en el recuadro Correo electrónico de confirmación para el usuario, se presentan las siguientes opciones:
- | Enviar un correo electrónico de confirmación al usuario: activando esta opción, es posible hacer que después de haber compilado el formulario y de haber enviado los datos, el usuario reciba automáticamente un correo electrónico de confirmación.
- | Correo electrónico del remitente: activando esta opción, es posible escribir una dirección de correo electrónico válida y activa que utilizar como remite del correo electrónico de confirmación. Por defecto, como correo electrónico del remitente, que en este caso es el correo electrónico del administrador del Sitio, se utiliza la dirección introducida como Correo electrónico destinatario especificada en la sección Envío de los datos. Escribiendo un Correo electrónico de remite distinto es posible enviar el correo electrónico de confirmación desde una dirección distinta de aquella en la que se reciben los correos electrónicos provenientes del formulario. Esta opción es útil si se prefiere utilizar para las comunicaciones con los usuarios una dirección genérica (info@miempresa.com o bien noreply@miempresa.com) en lugar de una dirección personal (nombre.apellido@miempresa.com).
- | Correo electrónico de destino: permite especificar cuál de los Campos del Formulario contendrá la información de la dirección de correo electrónico del usuario a la cual enviar el mensaje de confirmación.
- | Objeto: permite especificar el objeto del correo electrónico de confirmación.
- | Mensaje: permite especificar el mensaje del correo electrónico de confirmación.
- | Incluir al final los datos recogidos: permite agregar al final del correo electrónico de confirmación, los datos recogidos a través del Formulario compilado.

Por último, en el recuadro Opciones aparecen las siguientes opciones:
- | Activar el control anti-spam "Captcha": permite agregar al final de la form el control anti-spam Captcha. Es decir, se introduce la imagen de algunas letras visualizadas de manera deformada en un fondo confuso: el usuario debe copiar correctamente las letras en un Campo especial para poder enviar el mensaje.
- | Página de Confirmación después del envío de los datos: permite acceder al Mapa del Sitio para definir qué Página debe ser automáticamente visualizada una vez que el Formulario ha sido compilado y los datos recogidos han sido enviados por correo electrónico. En lugar de mandar directamente a la Página de inicio, es mejor predisponer una página específica con un mensaje de agradecimiento: esta Página deberá estar No visible en el menú a través del especial comando disponible en el Paso 2 - Creación del mapa.

 Para personalizar el aspecto gráfico de los correos electrónicos enviados automáticamente mediante el Formulario creado, es necesario utilizar las opciones propuestas en la ventana Estilos y Plantillas | Sección Correo electrónico del Paso 4 - Ajustes avanzados.

Temas relacionados:
- | Objeto Formulario de envío de correo electrónico
- | Estilos y Plantillas| Sección Correo electrónico


Objeto Formulario de envío de correo electrónico| Sección Estilo

Mediante los comandos de la Sección Estilo de la ventana Objeto Formulario de envío de correo electrónico se pueden definir algunas predisposiciones gráficas relativas al aspecto del Formulario que se está creando.

En primer lugar, es preciso seleccionar el Elemento del módulo sobre el que se desea trabajar: es posible hacerlo a través del menú desplegable de la homónima opción, o bien, haciendo clic directamente en el elemento de la ventana de Vista previa disponible.

Los elementos que se pueden modificar son:

 Etiquetas: es el texto de descripción del Campo y sirve para especificar la información requerida o introducir el texto de la pregunta que se desea formular.

Campos: es el recuadro dentro del cual el usuario podrá introducir la información requerida.

Botones de "Envíar" y "Restablecer": sono los botones introducidos automaticamente al final del Formulario de envío de correo electrónico. Sirven, respectivamente, para enviar todos los datos introducidos en los Campos y para vaciar los Campos de los valores eventualmente presentes.

Descripción y validación de campo: se trata de los mensajes visualizados para dar informaciones adicionales sobre cómo compilar los Campos, para invitar a corregir un dato introducido o para exhortar a completar un campo obligatorio dejado vacío.

En base al elemento del Formulario seleccionado, es posible modificar las distintas opciones presentadas en la sección Estilo:
Etiquetas de texto: | - | Tipo de fuente: permite especificar, mediante la ventana abierta, el Tipo de carácter, el Estilo y el tamaño del texto.
 | - | Color: permite especificar, mediante la ventana Color abierta, el color que debe ser utilizado para el texto.
 | - | Repetir: permite definir dónde se debe colocar la Etiqueta respeto al Campo. Es posible escoger entre tres opciones: Mostrar etiqueta sobre los campos, Mostrar etiqueta dentro de los campos y Mostrar etiqueta a la izquierda de las Campos. Si se elige colocar las Etiquetas a la izquierda de los Campos es posible definir la Anchura (%), o sea el porcentaje de espacio que deberá ocupar la etiqueta misma en la fila.
Campos: | - | Color: permite especificar, mediante la ventana Color abierta, el color que debe ser utilizado para el texto (en el estado normal y "en selección"), para el fondo (en el estado normal y "en selección") y para el borde (en el estado normal y "en error").
Botones de "Envíar" y "Restablecer": | - | Color Fondo: permite especificar, mediante la ventana Color abierta, el color que se debe utilizar para el texto, para el fondo y para la borde de los botones.
 | - | Imagen de fondo: permite importar un archivo gráfico (formato .JPG, .GIF y .PNG) que utilizar como imagen de fondo de los botones.
 | - | Mostrar el botón 'Restablecer': activada por defecto, hace que al terminar el formulario se introduzca automáticamente también el botón "Cancela" (útil para vaciar los campos ya compilados) además del botón "Envía".
Descripción y validación de campo: | - | Archivo de icono de descripción del campo: permite importar un archivo gráfico (formato .JPG, .GIF y .PNG) para utilizarlo como icono que poner al lado del Campo para indicar la disponibilidad de más información.
 | - | Mostrar la Descripción al seleccionar del campo: activando esta opción aparece visualizado automáticamente el mensaje con las informaciones adicionales, en cuanto se hace clic dentro del Campo.
 | - | En presencia de errores durante la validación de los datos: permite elegir cómo debe ser visualizado el mensaje previsto en el caso en el que un Campo no haya sido compilado correctamente o, si está predispuesto como Obligatorio, se deje vacío. Es posible escoger entre una de las siguientes opciones: Mostrar la ventana de diálogo del Navegador, Mostrar ventana de popup interna o Mostrar sugerencia al lado del Campo no válido.

 Para personalizar el aspecto gráfico de los correos electrónicos enviados automáticamente mediante el formulario creado, es necesario utilizar las opciones propuestas en la ventana Estilos y Plantillas | Sección Correo electrónico del Paso 4 - Configuración avanzada.

Temas relacionados:
- | Objeto Formulario de envío de correo electrónico
- | Estilos y Plantillas| Sección Correo electrónico


Objeto Lista Productos

Una de le funciones más interesantes de WebSite X5 es aquella que permite crear y manejar Sitios de Comercio electrónico, a través de los cuales es posible, no sólo presentar los propios Productos en un escaparate potencialmente abierto al mundo entero, sino también venderlos directamente en línea.

Además de permitir la inserción de los Productos y la gestión del carrito, WebSite X5 permite preparar un verdadero catálogo en línea mediante un objeto especial llamado Lista Productos. Este Objeto permite presentar un grupo de Productos, seleccionados entre los introducidos ya en el Carrito de la compra de comercio electrónico, a través de las Fichas de producto que resumen sus informaciones principales y permiten su compra.

Consejos Práticos

Haciendo doble clic en el Objeto de Lista Productos introducido en la Rejilla de paginación, se accede a la ventana Lista Productos. Mediante esta ventana es posible crear la lista de todos los Productos que se deseen presentar y definir la modalidad de visualización de las relativas Fichas Producto.

Los comandos disponibles están divididos en dos secciones:
- | Sección Lista
- | Sección Ajustes

 Para que el Objeto Lista Productos funcione correctamente, es necesario haber introducido precedentemente Productos dentro del Carrito de la compra de comercio electrónico mediante los comandos de la sección Carrito de la compra de comercio electrónico del Paso 4 - Ajustes avanzados.

Temas relacionados:
- | La Rejilla de paginación en la Creación de la Página
- | La lista de los Objetos en la Creación de la página
- | Carrito de la compra de comercio electrónico


Objeto Lista Productos| Sección Lista

Mediante la Sección Lista de la ventana Objeto Lista Productos, es posible especificar qué Productos deben ser visualizados en el Objeto Lista Productos.

La ventana presenta la Lista completa de las Categorías y de los Productos introducidos durante la creación del Carrito de la compra de comercio electrónico disponible en el Paso 4 - Ajustes Avanzados.

Al lado de cada Categoría y de cada Producto hay una casilla de control: basta hacer clic en las casillas de control correspondientes a las Categorías y/o a los Productos que se desea activar, para que éstos sean introducidos en el Objeto Lista Productos que se está haciendo.

Activar una Categoría o activar todos los Productos pertenecientes a una Categoría no es la misma cosa: en efecto, sólo en el primer caso, si en un segundo momento se añadirán nuevos Productos a una Categoría, éstos serán añadidos automáticamente en los Objetos Lista Productos a los que están vinculados.

Temas relacionados:
- | Objeto Lista Productos
- | Carrito de la compra de comercio electrónico


Objeto Lista Productos| Sección Ajustes

Mediante las opciones propuestas en la Sección Ajustes de la ventana Objeto Lista Productos es posible definir algunos ajustes gráficos relativos a las Fichas mediante los cuales se presentan los Productos introducidos en la lista.

En primer lugar, es preciso especificar el Modo de visualización: eligiendo entre los siguientes tipos de Fichas Producto:

 Sólo texto
En la Ficha Producto se presentan, una tras otra, las siguientes informaciones: Nombre del Producto, descripción, lista desplegable con las variantes (si están disponibles), coste y, al lado, campo para la cantidad con el botón "Comprar".

Imagen y Texto
En la Ficha Producto aparece a la izquierda la imagen del Producto y a la derecha todas las informaciones relativas al mismo.

Texto e Imagen
Análogo al tipo de presentación precedente, coloca el texto en la izquierda y la imagen en la derecha.

Sólo Imagen
En este caso, debajo de la imagen se presentan todas las informaciones asociadas excepto la descripción misma.

Alternar Imagen y Texto
En este caso se alternan Fichas Producto con Imagen y Texto a la derecha y Fichas Producto con Imagen y Texto a la izquierda.

Así pues, mediante las funciones del recuadro Configuració de marcos es posible definir:
- | Fichas por fila: permite especificar cuántas Fichas Producto deben estar una junto a otra en una única fila.
- | Altura fichas: permite especificar el valor en pixel que debe asumir en altura cada Ficha Producto. En base a dicho parámetro, el tamaño de las imágenes asociadas a los Productos es modificado automáticamente. Si los textos de descripción de los Productos son demasiado largos para poder ser visualizados completamente, aparece la barra de desplazamiento.
- | Ancho imagen (%): permite especificar, si se ha elegido un tipo de presentación en el que texto e imagen estén juntos, cuánto espacio de la Ficha Producto debe ser ocupado por la imagen y cuánto por el texto. Consejos prácticos: si la imagen ocupa la 30% de la anchura de la Ficha Producto, el restante 70% será ocupado por el texto.
- | Margen Interior: el margen es el espacio entre el borde de la Ficha Producto y su contenido. Así pues, mediante esta opción es posible definir cuánto espacio debe haber alrededor del contenido dentro de la Ficha Producto.

Después, mediante las funciones del recuadro Gráfica es posible definir:
- | Fuente: permite especificar, mediante la ventana abierta, el tipo de fuente, el estilo y las dimensiones en puntos del texto.
- | Color Texto / Color Fondo / Color Borde: permiten, respectivamente, definir mediante la ventana Color abierta, el color para el texto, el fondo y el borde de las Fichas Producto.
- | Grosor Borde: permite especificar el grosor del borde de la Ficha Producto.

Por último, están disponibles también las siguientes Opciones:
- | Mostrar Campo Cantidad: activando esta opción en la Ficha Producto aparece visualizado el Campo Cantidad útil para permitir al usuario especificar la cantidad del Producto que se desea introducir en el carro.
- | Mostrar precio: activando esta opción, en la Ficha Producto aparece visualizzato también el precio asociado al Producto.
- | Activar vínculo sobre la imagen: activando esta opción se predispone automáticamente en las distintas imágenes de las Fichas Producto el enlace con las relativas imágenes ampliadas. Dichas imágenes ampliadas son visualizadas mediante la ventana ShowBox.

 El aspecto de la ventana ShowBox puede ser completamente personalizado: mediante las opciones presentes en la sección Estilos y Plantillas| Sección ShowBox del Paso 4 - Ajustes avanzados es posible, por ejemplo, predisponer colores, sombras, opacidades y efectos de apertura.

Temas relacionados:
- | Objeto Lista Productos
- | Estilos y Plantillas| Sección ShowBox


Objeto HTML y Widgets

WebSite X5 propone un Objeto específico para cada tipo de contenido que se puede querer insertar al interno de una Página: texto, imagen, animación, formulario de correo electrónico, etc. Además, gracias a la posibilidad de gestionar también el Objeto HTML y Widgets, las posibilidades son virtualmente ilimitadas. En efecto, gracias al Objeto HTML y Widgets es posible insertar directamente porciones de código y resolver así funciones particulares, incluso no previstas inicialmente.

Particularmente útiles son las Widget puestas a disposición: pequeñas aplicaciones ya listas y funcionantes creadas para resolver una tarea particular. El ejemplo más simple es el de la Widget para Google Maps: con la definición de pocos parámetros, permite crear e insertar el mapa del lugar deseado, sin tener que configurarlo directamente en el Sitio de Google Maps.

Consejos Práticos

Haciendo doble clic en el Objeto HTML y Widgets insertado dentro de la Rejilla de paginación se accede a la ventana Objeto HTML y Widgets. A través de esta ventana se tiene a disposición un editor de texto mediante el cual es posible digitar el código HTML y/o CSS. El código puede ser escrito desde cero, copiado y pegado de Sitios que lo ponen a disposición,o bien, insertado mediante la simple elección de una Widget.

En concreto, se presentan las siguientes secciones:
- | Sección Código HTML
- | Sección Avanzado

Temas relacionados:
- | La Rejilla de paginación en la Creación de la página
- | La lista de los Objetos en la Creación de la página


Objeto HTML y Widgets| Sección Código HTML

Mediante los comandos de la sección Código HTML de la ventana objeto HTML y Widgets es posible disponer de un editor mediante el cual componer el código HTML que se desea introducir en la página, escribiéndolo manualmente o haciendo doble clic en una de las Widgets disponibles.

El editor disponible en el recuadro Código HTML pone a disposición los siguientes comandos:

 Cortar [CTRL+X] - Copiar [CTRL + C] - Pegar [CTRL + V]
Permiten, respectivamente, cortar, copiar y pegar la porción de código seleccionado.

Deshacer [CTRL+Z] - Restablecer [ALT+MAYUSC+BACKSPACE]
Permiten, respectivamente, anular y restablecer la última operación efectuada/anulada.

Para facilitar la escritura/lectura del código, en el editor HTML se ha introducido la evidenciación de la sintaxis (Syntax highlighting). Esta función hace que determinados elementos del código sean distinguidos mediante el uso de colores, sin que para esto se modifique en modo alguno el significado del texto. Gracias a la evidenciación, la estructura del código se hace clara y, de consecuencia, es mas simple localizar eventuales errores.

En el recuadro Lista Widgets, en cambio, se propone la lista de todas las Widgets disponibles. Haciendo doble clic en la Widget deseada, se abre la ventana Widget mediante la cual es posible definir los parámetros previstos. Confirmando, el código HTML relativo al Widget es compuesto e insertado automáticamente en el editor.

Por último, en el recuadro Propiedades están disponibles las siguientes opciones:
- | Ancho: permite visualizar el valor de la anchura del Objeto HTML y Widgtes; dicho valor es automáticamente definido en base al espacio disponible en la Rejilla de paginación.
- | Altura: permite predisponer el valor de la altura del Objeto HTML y Widgtes.
- | Visualiza Barras de desplazamiento: activa por defecto, hace que aparezca automáticamente la barra de desplazamiento si el Objeto HTML y Widgtes tiene altura superior a la predispuesta mediante la correspondiente opción Altura.

Temas relacionados:

-

Objeto HTML y Widgets


Objeto HTML y Widgets| Sección Avanzado

Mediante los comandos de la Sección Avanzado de la ventana Objeto HTML y Widgets es posible crear una Hoja de estilo (CSS) y/o definir la lista de los archivos que adjuntar al Objeto HTML y Widgtes en el que se está trabajando.

En el recuadro Código CSS está disponible un editor (análogo al presente en la Sección código HTML) mediante el cual es posible escribir las instrucciones para componer la Hoja de estilo. Recordamos que la finalidad de los CSS es definir el aspecto gráfico de las páginas HTML a las que están conectados.

En cambio, en el recuadro Archivos adjuntos al código, son visualizados todos los archivos vinculados a través de una tabla resumen en la que, además del nombre del archivo, se presenta también la Ruta relativa en el Servidor.

R Para componer la lista de los archivos vinculados al Código HTML es posible utilizar los siguientes comandos:
- | Agregar: permite, mediante la ventana Publicar archivo vinculado abierta, insertar un nuevo archivo vinculado.
- | Editar: permite abrir la ventana Publicar archivo vinculado para modificar las predisposiciones definidas para el archivo seleccionado en la tabla resumen de los Archivos vinculados.
- | Eliminar: permite eliminar el archivo seleccionado de entre los presentes en la tabla resumen de los Archivos vinculados.

Temas relacionados:
- | Objeto HTML y Widgets
- | Ventana Publicar archivo vinculado


Editor gráfico

WebSiteX5, además de optimizar automáticamente las imágenes que importa, también ofrece un editor gráfico interno muy versátil para darle el toque final a sus fotografías e imágenes.
El editor gráfico puede ser activado mediante el botón Modificar disponible, en general, en las ventanas en que es posible importar un archivo gráfico como, por ejemplo, aquellas relativas al Objeto Imagen, al Objeto Galería, a la creación de un nuevo Producto en el Carrito de la compra de comercio electrónico.

El editor gráfico está organizado en las siguientes secciones:
- | Sección Recorte y rotación
- | Sección Filtros
- | Sección Marca de agua
- | Sección Máscara
- | Sección Marco
- | Sección Efectos
- | Sección Biblioteca

El editor gráfico es completado por los siguientes botones:
- | Aceptar: esta opción cierra el editor gráfico y regresa a la ventana principal guardando y aplicando las modificaciones efectuadas sobre la imagen.
- | Cancelar: esta opción cierra el editor gráfico y regresa a la ventana principal anulando las modificaciones efectuadas sobre la imagen.
- | Guardar como...: permite guardar una copia de la imagen original en formato .PNG.

Temas relacionados:
- | Objeto Imagen
- | Objeto Galería
- | Carrito de la compra de comercio electrónico


Editor gráfico| Sección Recorte y rotación

Mediante los comandos de la Sección Recorte y rotación del Editor gráfico es posible recortar el área de la imagen que se desea visualizar, eliminando el resto.

Es posible dibujar el área de corte directamente en la vista previa de la imagen utilizando las anclas para efectuar la modificación. La sección de corte puede ser desplazada para ponerla en primer plano del área deseada: para hacer esto basta arrastrarla mientras se presiona el botón izquierdo del ratón y posicionarla correctamente.

No es necesario confirmar el corte: en cualquier caso, la porción externa a la selección del corte (más oscura respecto al original) no será considerada. En cambio, para anular el corte, basta hacer clic en la imagen, fuera el área seleccionada.

Los siguientes recuadros son mostrados a un lado de la imagen:
- | Cortar: presenta los valores en pixel de la Coordenada X y de la Coordenada Y que identifican la posición del vértice superior izquierdo del área seleccionada con el corte, además de los valores de la Anchura y de la Altura asumidos por ésta. Además de ser retomados directamente en función del área de corte dibujada, los valores de los parámetros citados también pueden ser introducidos en las campos relativos o predispuestos mediante los cursores.
- | Espejo: permite reflejar la Imagen en sentido horizontal(según el eje vertical) y/o vertical (según el eje horizontal).
- | Rotación: permite girar la Imagen en sentido horario de 0°, 90°,180° o 270°.

Temas relacionados:

-

Editor gráfico


Editor gráfico| Sección Filtros

Mediante los comandos de la Sección Filtros del Editor gráfico es posible corregir los principales ajustes de color y predisponer algunos filtros gráficos en la Imagen importada.

- | Filtros: presenta la lista de los filtros que es posible aplicar a la Imagen. La lista incluye: Luminosidad/Contraste, Color RGB, Intensidad (HSL), Claro, Desenfocado, Blanco y negro, Sepia, Mosaico, Punteado, Difusión, Pintura al óleo, Lienzo, Ruido, Mármol. Para aplicar un filtro basta hacer clic al lado para que aparezca el signo de marca en el relativo check box.
- | Ajustes: presenta las predisposiciones que se pueden utilizar para definir el filtro seleccionado.

Los cambios relativos a los filtros predispuestos son aplicados inmediatamente y aparecen enseguida en la vista previa.

Temas relacionados:

-

Editor gráfico


Editor gráfico| Sección Marca de agua

Mediante los comandos de la Sección Marca de agua del Editor gráfico es posible aplicar una marca de agua a la Imagen importada para protegerla de la copia no autorizada. En efecto, la finalidad de la marca de agua es alterar la imagen, quizás presentando explícitamente la indicación del copyright, para desanimar la copia y el uso.

- | Marca de agua: presenta la lista de las marcas de agua que es posible aplicar a la Imagen. Además de las imágenes de marcas de agua puestas a disposición, es posible aplicar una marca de agua personal: solamente hay que seleccionar la segunda vista previa de la lista (Personalizada…) e importar el archivo gráfico especialmente preparado.
- | Ajustes: permite girar de 90°, 180° o 270 ° o de reflejar horizontal o verticalmente la marca de agua aplicada a la Imagen.

 Una marca de agua debe ser preparada como archivo gráfico en formato .GIF, .PNG, .PSD o .WMF para el cual se predispone la transparencia: la marca de agua se sobrepone a la Imagen original para permitir la visualización sólo de las partes correspondientes a las áreas transparentes.
Puesto que el formato .GIF maneja un único nivel de trasparencia, mientras que los formatos .PNG y .PSD manejan hasta 256, se recomienda guardar las marcas de agua en uno de estos últimos formatos.

+

=

Temas relacionados:

-

Editor gráfico


Editor gráfico| Sección Máscara

Mediante los comandos de la Sección Máscara del Editor gráfico es posible aplicar una máscara a la Imagen importada para modificar su forma.

- | Máscara: aquí se indica la lista de las diferentes máscaras que se pueden aplicar a la imagen. Además de las máscaras establecidas, es posible aplicar una máscara personalizada: solamente hay que seleccionar la segunda vista previa de la lista (Personalizada…) e importar el archivo gráfico especialmente preparado.
- | Ajustes: permite girar de 90°, 180° o 270° o reflejar horizontal o verticalmente la máscara aplicada a la Imagen.

 Una máscara es sólo una imagen con 256 colores en una escala de grises: la máscara se aplica a la Imagen de origen, así que las zonas en negro se hacen invisibles mientras que las zonas en blanco se dejan visibles.

+

=

Temas relacionados:

-

Editor gráfico


Editor gráfico| Sección Marco

Mediante los comandos de la Sección Marco del Editor gráfico es posible aplicar un marco a la Imagen importada.

- | Marco: muestra la lista de los marcos disponibles que pueden ser aplicados a la imagen. Además de los marcos disponibles, es posible aplicar un marco personalizado: solamente hay que seleccionar la segunda vista previa de la lista (Personalizada…) e importar el archivo gráfico especialmente preparado.
- | Ajustes: permite girar de 90°, 180° o 270°o reflejar horizontal o verticalmente el marco aplicado a la Imagen.

 Un marco debe ser preparado como archivo gráfico en formato .GIF, .PNG, .PSD o .WMF para el cual se predispone la transparencia: el marco es sobrepuesto a Imagen original para permitir la visualización sólo de las partes correspondientes a las áreas transparentes.
Desde el momento que el formato .GIF maneja solamente un nivel de transparencia, mientras que los formatos .PNG y .PSD manejan hasta 256, sugerimos guardar los marcos en uno de estos últimos formatos.

+

=

Temas relacionados:

-

Editor gráfico


Editor gráfico| Sección Efectos

Mediante los comandos de la Sección Efectos del Editor gráfico es posible corregir los principales ajustes de color y predisponer algunos efectos gráficos en la Imagen importada.

- | Efectos: presenta la lista de los efectos que es posible aplicar a la Imagen. La lista incluye: Sombra, Espejo, Brillo exterior, Borde coloreado, Marco, Borde difuminado, Alto relieve, Bajo relieve, Convexo, Opacidad, Distorsión, Perspectiva y Rotación. Para aplicar un efecto basta hacer clic al lado para que aparezca el signo de marca en el relativo check box.
- | Ajustes: presenta las predisposiciones que se pueden utilizar para definir el efecto seleccionado.

Los cambios relativos a los efectos predispuestos son aplicados inmediatamente y aparecen enseguida en la vista previa.

Temas relacionados:

-

Editor gráfico


Editor gráfico| Sección Biblioteca

Mediante la Sección Biblioteca del Editor gráfico es posible elegir un set de predisposiciones, guardadas como Estilo, y aplicarlas a la imagen en curso o, al contrario, guardar las predisposiciones definidas para la imagen en curso en un nuevo Estilo que podrá ser retomado y aplicado a las demás imágenes.

La Biblioteca presenta una lista de todos los Estilos preestablecidos y de los Estilos personalizados ya creados. Además, están disponibles los siguientes comandos:
- | Aplicar: permite aplicar a la imagen en curso todas las predisposiciones previstas para el Estilo seleccionado.
- | Agregar: permite guardar todas las predisposiciones definidas en las secciones precedentes del Editor gráfico para la imagen en curso en un Estilo y agregarlo a la lista de los Estilos personalizados.
- | Eliminar: permite eliminar el Estilo seleccionado de entre los presentes en la lista Estilos personalizados. No es posible eliminar los Estilos preestablecidos.

Consejos Práticos

Gracias a la biblioteca es posible reducir los tiempos de trabajo: si se prevé tener que dar a varias imágenes las mismas predisposiciones puestas a disposición por el Editor, es conveniente definirlas para la primera imagen, guardar el Estilo y aplicarlo, sin crearlo de nuevo todas las veces, a las otras imágenes.

Para crear un nuevo Estilo:
- | Abrir la sección General de la ventana Objeto Imagen y hacer clic en el botón Modificar, situado bajo la Vista previa, para acceder al Editor gráfico.
- | Utilizar las opciones puestas a disposición en las distintas secciones del Editor gráfico para obtener el resultado deseado.
- | Abrir la sección Biblioteca y hacer clic en el botón Agregar: en base a las predisposiciones definidas se crea un nuevo Estilo. Una vista previa del Estilo creado es añadida a la lista de los Estilos personalizados.

Para aplicar un Estilo:
- | Abrir la sección General de la ventana Objeto Imagen y hacer clic en el botón Modificar, situado bajo la Vista previa, para acceder al Editor gráfico.
- | Abrir directamente la sección Biblioteca y seleccionar la vista previa del Estilo que se desea utilizar, eligiéndolo de la lista de los Estilos preestablecidos o en la de los Estilos personalizados.
- | Hacer clic en el botón Aplicar.

Temas relacionados:

-

Editor gráfico


Estilo de la celda

WebSite X5 permite proceder a la creación de cada Página de un Sitio mediante una Rejilla de paginación que subdivide el espacio disponible en Celdas. El número de Celdas disponibles depende del número de Filas y Columnas insertadas y, para cada celda, es posible insertar un contenido distinto (mediante el simple Drag & Drop de los Objetos disponibles).

La Celda equivale, pues, a un espacio determinado de la Página: tiene su contenido y puede tener un aspecto gráfico especial. Así pues, modificando los márgenes, bordes y fondo de la Celda es posible crear recuadros dentro de la Página mediante los cuales organizar los contenidos y resaltar adecuadamente aquellos que se desea poner en primer plano.

Consejos Práticos

Trabajando en la Creación de una página, después de haber arrastrado uno de los Objetos disponibles al interior de una Celda de la Rejilla de paginación, es posible definir el aspecto gráfico de dicha Celda haciendo clic en el botón [image] y utilizando las opciones propuestas por la ventana Estilo de la celda abierta.

Las opciones disponibles están divididas en 2 secciones:
- | Sección Estilo
- | Sección Textos
- | Sección Biblioteca

Temas relacionados:
- | Creación de una página
- | Rejilla de paginación


Estilo de la celda| Sección Estilo

Mediante los comandos de la Sección Estilo de la ventana Estilo de la celda se pueden definir las predisposiciones gráficas de la Celda en curso de la Rejilla de paginación.

En primer lugar es necesario definir el tipo de Fondo que se desea predisponer para la Celda, eligiendo entre:

 Fondo coloreado: el fondo de la Celda es coloreado con un único color.

Fondo degradado: el fondo de la Celda es llenado con una gradación de la que se pueden definir los colores inicial y final y la dirección del difuminado.

Fondo con imagen: el fondo de la Celda es creado mediante la importación de una imagen.

Ajustar imagen a la Celda: el fondo de la Celda es creado mediante la importación de una imagen que es cortada en bloques y recompuesta de modo que se pueda adaptar perfectamente al tamaño de la Celda misma. (ver, Cómo crear una imagen de fondo que se adapte al tamaño de la Celda)

En función del tipo de Fondo, es posible activar las distintas opciones del recuadro Ajustes.

Para el Fondo coloreado, las opciones disponibles son:
- | Color Fondo: permite especificar, mediante la ventana Color activada, el color que utilizar para el llenado del fondo de la Celda.
- | Opacidad: permite predisponer el grado de opacidad del color de fondo aplicado. Para valores que tienden a 0, diminuye la opacidad y el fondo de la Celda se vuelve más transparente, dejando ver el fondo de la Página.

Para el Fondo difuminado, las opciones disponibles son:
- | Color inicial / Color final: permiten especificar, mediante la ventana Color abierta, los colores inicial y final que utilizar para componer el difuminado.
- | Difusión: permite establecer si en el difuminado debe predominar el color inicial o el color final , definendo el espacio (en pixel) en el que se debe producir la transición del primero al segundo. Por ejemplo, en un difuminado vertical en que se pasa del gris al blanco con una difusión a 250, la gradación es efectuada en los primeros 250 px y después el fondo quedará uniformemente blanco.
- | Dirección: permite seleccionar el tipo de sombreado que será aplicado, eligiendo entre desde Arriba, desde Abajo, desde la Izquierda, desde la Derecha.
- | Opacidad: permite predisponer el grado de opacidad del difuminado de fondo aplicado. Para valores que tienden a 0, diminuye la opacidad y el fondo de la Celda se vuelve más transparente, dejando ver el fondo de la Página.

Para el Fondo con imagen, las opciones disponibles son:
- | Color Fondo: permite especificar, mediante la ventana Color activada, el color a utilizar para el llenado del fondo de la Celda.
- | Archivo imagen: permite seleccionar el archivo gráfico relativo a la imagen que utilizar como fondo de la Celda. Pueden ser utilizados archivos en formato .JPG, .GIF, .PNG.
- | Repetir: esta opción permite especificar si la imagen utilizada como fondo de la celda debe repetirse o no. La imagen puede repetirse de forma horizontal, vertical o en ambas direcciones, con el propósito de llenar el espacio disponible.
- | Alineación: permite especificar la alineación de la imagen utilizada como fondo en relación al área ocupada por la Celda.
- | Saturación del color: permite especificar, mediante la ventana Color abierta, el color hacia el que debe tender la imagen introducida como fondo de la Celda. Es decir, se aplica un efecto "colorize" en la imagen para que tienda al color deseado.
- | Opacidad: permite predisponer el grado de opacidad de la imagen de fondo aplicada. Para valores que tienden a 0, diminuye la opacidad y el fondo de la celda se vuelve más transparente, dejando ver el fondo de la Página.

Para Ajustar imagen a la Celda, las opciones disponibles son:
- | Color fondo: permite especificar, mediante la ventana Color activada, el color a utilizar para el llenado del fondo de la Celda.
- | Archivo imagen: permite seleccionar el archivo gráfico relativo a la imagen que utilizar como fondo de la Celda. Pueden ser utilizados archivos en formato .JPG, .GIF, .PNG.
- | Bloquear Ancho /Bloquear Altura: permiten predisponer el tamaño de los bloques en los que se corta la imagen de fondo para determinar qué porciones de la imagen deben ser mantenidas inalteradas y cuáles deben ser repetidas. (ver, Cómo crear una imagen de fondo que se adapte al tamaño de la celda)
- | Saturación del color: permite especificar, mediante la ventana Color abierta, el color hacia el que debe tender la imagen introducida como fondo de la celda. Es decir, se aplica un efecto "colorize" en la imagen para que tienda al color deseado.
- | Opacidad: permite predisponer el grado de opacidad de la imagen de fondo aplicada. Para valores que tienden a 0, diminuye la opacidad y el fondo de la Celda se vuelve más transparente, dejando ver el fondo de la Página.

Por último, mediante las opciones del recuadro Borde es posible definir:
- | Color y Grosor: la primera opción permite especificar, mediante la ventana Color abierta, el color del borde de la celda, la segunda predisponer el grosor.
- | Bordes personalizados: activando esta opción es posible definir independientemente el color y el grosor de cada borde de la celda.

 El color del borde se utiliza también como color para la transparencia de la imagen.

Temas relacionados:
- | Estilo de la celda
- | Cómo crear una imagen de fondo que se adapte al tamaño de la celda


Estilo de la celda| Sección Textos

Mediante los comandos de la Sección Textos de la ventana Estilo de la celda es posible insertar y definir el aspecto gráfico de los elementos de texto que completan el estilo de la Celda en curso de la Rejilla de paginación.

En primer lugar hay que definir el elemento, Texto o Imagen, que se desea insertar y sobre el que se desea trabajar. Es posible elegir entre las siguientes opciones:

 Título: es el texto que aparece visualizado como título de la Celda en curso.

Imagen del encabezado: es una imagen que puede ser insertada en la cabecera de la Celda en curso, eventualmente junto al Título.

Texto descriptivo: es el texto que aparece visualizado como explicación de la Celda en curso.

Una vez insertados, los distintos elementos pueden ser seleccionados mediante el especial menú deplegable o haciendo clic directamente en la imagen de Vista previa.

En función del tipo de elemento seleccionado es posibe activar las distintas opciones del recuadro Ajustes.

Para los elementos Título y para el Texto descriptivo, las opciones disponibles son:
- | Contenido: permite escribir el Título o el Texto descriptivo de la Celda.
- | Color Texto: permite especificar, mediante la ventana Color abierta, el color del texto en el que se está trabajando.
- | Fuente: permite especificar, mediante la ventana abierta, el tipo de fuente, el estilo y el tamaño en puntos del texto.
- | Alineación: permite especificar si el texto debe ser alineado a la Izquierda, en el Centro o a la Derecha respecto a la celda.
- | Margen horizontal / Margen vertical: permiten predisponer el valor en pixel de los márgenes del texto, para poderlo colocar con precisión decidiendo a qué distancia colocarlo de los bordes de la celda.

En cambio, para el elemento Imagen del encabezado, las opciones disponibles son:
- | Archivo imagen: permite seleccionar el archivo gráfico relativo a la imagen a utilizar. Pueden ser utilizados archivos en formato .JPG, .GIF, .PNG.
- | Alineación: permite especificar si la imagen insertada debe ser alineada a la Izquierda, en el Centro o a la Derecha respeto a la celda.
- | Margen horizontal / Margen vertical: permiten predisponer el valor en pixel para los márgenes de la imagen insertada, para poderla colocar con precisión respecto a los bordes de la Celda y, de consecuencia, respecto al Título eventualmente presente.

Temas relacionados:

-

Estilo de la celda


Estilo de la celda| Sección Biblioteca

Mediante la Sección Biblioteca de la ventana Estilo de la celda es posible elegir un set de predisposiciones, guardadas como Estilo, y aplicarlas a la Celda en curso,o bien, guardar las predisposiciones definidas para la Celda en curso en un nuevo Estilo que podrá ser activado después y aplicado a otras Celdas.

La Biblioteca presenta una lista de todos los Estilos predeterminados y de los Estilos personalizados ya creados. Además, están disponibles los siguientes comandos:
- | Aplicar: permite aplicar a la Celda en curso todas las predisposiciones previstas para el estilo seleccionado.
- | Agregar: permite guardar todas las predisposiciones gráficas definidas en las Secciones Estilo y Textos para la Celda en curso, en un Estilo y agregarlo a la lista de los Estilos Personalizados.
- | Eliminar: permite eliminar el Estilo seleccionado de entre los presentes en la lista Estilos personalizados. No es posible eliminar los Estilos predeterminados.

 En la composición de un Estilo se mantienen todas las predisposiciones gráficas definidas para la Celda pero no los contenidos que podrían cambiar de una celda a otra. De este modo, por ejemplo, en el Estilo se guarda el Color texto o el Tipo de Fuente pero no el Contenido especificado para elementos como el Título y el Texto descriptivo asociado a una Celda.

Consejos Práticos

Gracias a la biblioteca es posible reducir los tiempos de trabajo: si se prevé tener que dar a varias Celdas las mismas predisposiciones gráficas, es conveniente definirlas para la primera Celda, guardar el Estilo y aplicarlo, sin crearlo de nuevo cada vez, a las demás celdas.

Para crear un nuevo Estilo:
- | Seleccionar en la Rejilla de paginación la Celda en la que se desea trabajar y hacer clic en el botón [image] para abrir la ventana Estilo de la celda.
- | Utilizar las opciones puestas a disposición en las distintas secciones Estilo y Textos para obtener el resultado deseado.
- | Abrir la sección Biblioteca y hacer clic en el botón Agregar: en base a las predisposiciones definidas se crea un nuevo Estilo. Una vista previa del Estilo creado es añadida a la lista de los Estilos personalizados.

Para aplicar un Estilo:
- | Seleccionar en la Rejilla de paginación la celda en la que se desea trabajar y hacer clic en el botón [image] para abrir la ventana Estilo de la celda.
- | Abrir directamente la sección Biblioteca y seleccionar la vista previa del Estilo que se desea utilizar, eligiéndolo de la lista de los Estilos predeterminados o en la de los Estilos personalizados.
- | Hacer clic en el botón Aplicar.

Temas relacionados:

-

Estilo de la celda


Enlace

Además de los menús de navegación fija, creados en automático en base al Mapa, WebSite X5 permite introducir en Textos e Imágenes, los Enlaces necesarios para resolver una serie de operaciones distintas: abrir páginas internas o externas, abrir archivos, visualizar imágenes, añadir un producto al carro, etc.

Al predisponer un Enlace es posible, no sólo elegir el tipo de acción, sino también definir y personalizar la tooltip asociada para proporcionar una explicación de lo que ocurrirá con el clic.

Consejos Práticos

Cada vez que es posible insertar un Enlace en un Texto o en una Imagen, está disponible el comando [image] Asociar/Insertar Enlace: haciendo clic en este botón se abre la homónima ventana que permite definir el tipo de Enlace hipertextual que se debe introducir.

Las diferentes opciones se presentan en las siguientes secciones:
- | Sección Acción
- | Sección Descripción

Temas relacionados:
- | Editor de plantilla| Barra herramientas
- | Objeto Texto
- | Objeto Imagen
- | Objeto Galería


Enlace| Sección Acción

Mediante los comandos de la Sección Acción de la ventana Enlace es posible especificar el tipo de acción que asociar al Enlace mismo:

 Página del sitio
Permite predisponer un Enlace a otra Página del Sitio. Haciendo clic en el botón [image] es posible ojear el Mapa del sitio y seleccionar qué Página conectar. Es posible especificar si la Página conectada debe ser visualizada en la misma ventana, en una nueva ventana del Navegador o en una ventana de PopUp. En este último caso, como PopUp se abre una nueva ventana del Navegador del que se puede predisponer el tamaño (Anchura y Altura).

Archivo o URL
Permite predisponer un Enlace a cualquier recurso, archivo o página HTML, presente en el ordenador en el que se está trabajando o ya publicado en el Web. Para especificar qué archivo conectar, basta activar la opción Archivo local y hacer clic en el botón [image] para ojear los recursos guardados en el sistema, o bien activar la opción URL o Archivo de Internet y escribir la dirección (URL) que identifica su posición en la red.
También en este caso, es posible especificar si el recurso conectado debe ser visualizado en la misma ventana, en una nueva ventana del Navegador o en una ventana de PopUp de la que se puede predisponer el tamaño (Anchura y Altura).

Archivo o URL con ShowBox
Permite predisponer un Enlace mediante el cual visualizar un archivo cualquiera, presente en el ordenador en el que se está trabajando o ya publicado en el Web, en una especial ventana ShowBox. A diferencia de cuanto ocurre para la ventana de PopUp, con la ventana ShowBox, el archivo activado es visualizado en primer plano sobre el fondo de la Página original, que se vuelve automáticamente más opaca y claro/oscura.
Para especificar qué archivo conectar, basta activar la opción Archivo local y hacer clic en el botón [image] para ojear los recursos guardados en el sistema, o bien activar la opción URL o Archivo de Internet y escribir la dirección (URL) que identifica su posición en la red. Mediante las opciones disponibles, es posible predisponer el tamaño (Anchura y Altura) de la ventana ShowBox, además de una Didascalia que aparecerá en la parte inferior.
La conexión con la ventana ShowBox es especialmente indicada para la visualización de imágenes, pero puede ser utilizada también para la visualización de recursos distintos como, por ejemplo, los documentos .PDF.

Galería Archivo con ShowBox
Permite predisponer un Enlace mediante el cual activar la reproducción de una Galería de imagenes dentro de una ventana ShowBox. Para crear la lista de las imágenes basta utilizar los comandos disponibles: Agregar, Eliminar, Subir y Bajar. Además, es posible predisponer el tamaño (Anchura y Altura) de la ventana ShowBox.

El aspecto de la ventana ShowBox puede ser completamente personalizado: mediante las opciones presentes en la sección Estilos y Plantillas| Sección ShowBox del Paso 4 - Ajustes avanzados es posible, por ejemplo, predisponer colores, sombras, opacidades y efectos de apertura.

Correo electrónico
Permite predisponer un Enlace para abrir el programa predeterminado para el envío de correos electrónicos y así enviar uno. Para seleccionar este tipo de enlace basta introducir la dirección de correo electrónico del destinatario.
Activando la opción Activar protección de dirección de correo electónico es posible hacer que la dirección de correo electrónico especificada aparezca de forma criptada dentro del código HTML de la Página: de este modo no será reconocida por los robot que buscan en la red direcciones para las campañas de correo basura.

Llamada Internet
Esta opción permite predisponer un enlace con el programa asociado para realizar llamadas a través del internet, por ejemplo, Skype, y conversar así con un determinado usuario. Los datos del usuario al cual se desea llamar, deberán especificarse en el campo requerido. Además, es posible especificar el Tipo de acción eligiendo entre: Llamar, Agregar contacto, Chat, Mostrar perfil, Skype VoiceMail y Enviar archivo.

Sonido
Permite predisponer un Enlace mediante el cual lanzar la reproducción de un sonido. Para especificar qué archivo conectar basta activar la opción Archivo local y hacer clic en el botón [image] para ojear los recursos guardados en el sistema, o bien activar la opción Archivo de Internet y escribir la dirección (URL) que identifica su posición en red. Es posible conectar archivos en formato .MP3.
Haciendo clic en el enlace aparece una ToolTip que contiene el botón Play/Pause para activar/interrumpir la reproducción del sonido. Haciendo salir el ratón de la Tooltip, ésta se cierra y la reproducción del sonido es interrumpida.

La ToolTip en el enlace con el sonido es creada automaticamente por el Programa: el aspecto es definido en base a la predisposiciones activadas en la ventanaEstilos y Plantillas| Sección ToolTip del Paso 4 - Ajustes avanzados.

Imprimir Pagina
Permite predisponer un Enlace para iniciar la impresión de la página mostrada.

Mensaje de aviso
Permite predisponer un Enlace mediante el cual ver un mensaje de aviso. Para definir este tipo de conexión basta escribir el Texto del mensaje en el campo especial. Activando la opción Mostrar como ventana de popup, el mensaje de aviso aparece en una ventana de diálogo estilo Windows.

Favoritos y página predeterminada
Permite predisponer un Enlace mediante el cual abrir la ventana de Internet Explorer que permite añadir el sitio Internet indicado dentro de los Sitios web favoritos del usuario que conecta a nuestras Páginas (Agregar el sitio web a Favoritos) o predisponer el Sitio especificado como Página predeterminada para la apertura del Navegador Internet (Establecer el sitio web como Página de inicio predeterminada del navegador).
Para definir este tipo de conexión basta especificar el URL del Sitio y el Título del Sitio que se desea proponer.

Sindicación Web (Feed RSS)
Esta opción permite mostrar la sindicación web (Feed RSS) del Sitio: la conexión está activa sólo si se ha creado efectivamente una Sindicación web (RSS) mediante la especial ventana del Paso 4 - Ajustes avanzados.

Cuando se prueba el funcionamiento del Sitio creado en local, una ventana de aviso advierte que las Sindicaciones web (RSS) serán visualizadas sólo una vez que el Sitio sea publicado en línea.

Blog
Permite predisponer un Enlace mediante el cual abrir el Blog vinculado al Sitio en curso. Para que esta conexión funcione correctamente, es necesario haber creado precedentemente un Blog mediante la especial sección del Paso 4 - Ajustes avanzados.
Mediante las opciones disponibles es posible especificar si el Blog vinculado debe ser visualizado en la misma ventana o en una nueva ventana del Navegador.

Mapa de sitio
Permite predisponer un Enlace mediante el cual ver el Mapa del sitio completo en una Página especial. Los elementos del mapa de sitio, creados automáticamente, son Enlaces con la página correspondiente. por lo tanto, el Mapa representa una herramienta útil para la orientación y las navegación puesta a disposición del Usuario. La visualización de las opciones del Mapa puede ser modificada mediante los comandos Expandir todo y Reducir todo.

Incluso si el enlace Mapa del sitio no es utilizado, el SiteMap XML es igualmente creado y conectado en el código HTML de las Páginas mediante el metatag <sitemap>, para permitir una mejor indexación de los contenidos por parte de los Motores de búsqueda.

Verr el Carrito de la compra
Permite predisponer un Enlace mediante el cual visualizar la página del Carrito con la lista de todos los productos ya pedidos.

Agregar al Carro
Permite predisponer un Enlace mediante el cual permitir al Usuario acceder al Carrito de la compra de comercio electrónico para efectuar el pedido o insertar directamente un Producto especificado de los disponibles.
En el primer caso es preciso activar la opción Mostrar la lista de productos de la categoría seleccionada y seleccionar la Categoría deseada mediante el esquema que repropone todo el catálogo de los Productos.
En el segundo caso, en cambio, es preciso activar la opción Agregar el producto seleccionado directamente al carrito y seleccionar el Producto siempre mediante la lista especial. Además, también es posible especificar la Variante y la Cantidad del producto que se introducirá en el carrito.

Para que los enlaces Ver el carrito de la compra y Agregar al carrito funcionen correctamente, es necesario haber creado anteriormente el Carrito de la compra de comercio electrónico mediante los comandos de la sección Carrito de la compra de comercio electrónico del Paso 4 - Ajustes avanzados.

Temas relacionados:

-

Enlace


Enlace| Sección Descripción

Mediante los comandos de la Sección Descripción de la ventana Enlace es posible asociar una descripción al Enlace. Esta descripción es introducida como valor del atributo <title> del elemento <a> en el código HTML y se utiliza para componer una nota explicativa, llamada "ToolTip" o "Tip". El ToolTip aparece junto al puntero del ratón cuando éste es situado en correspondencia del Enlace mismo y debería servir para explicar qué ocurrirá si se hace clic: se pasará a una Página o a un Sitio distinto, aparecerá una imagen, iniciará el download de un archivo, etc.

Los comandos disponibles para la composición del ToolTip son:
- | Texto: permite especificar la descripción del Enlace.
- | Imagen: permite especificar una imagen que se mostrará en el Tooltip junto a la descripción del link o en su lugar.
- | Ancho: permite predisponer la anchura en pixel del ToolTip.

 Texto, Imagen y Anchura son parámetros que cambian para cada Enlace y, por lo tanto, deben ser predispuestos cada vez. Otras predisposiciones gráficas, relativas al aspecto del ToolTip y, por lo tanto, comunes para todo el Proyecto, pueden ser definidas en la ventana Estilos y Plantillas | Sección ToolTip del Paso 4 - Ajustes avanzados.

Temas relacionados:
- | Enlace
- | Estilos y Plantillas| Sección ToolTip


Ventana de Color

Cada vez que es posible definir el color de un elemento, la opción de Color se presenta con un pulsador coloreado con el color predeterminado o con el último color utilizado.

Al hacer clic en el pulsador junto a la opción Color, aparecerá un menú que contiene una paleta con 48 colores: para seleccionar el color deseado basta hacer clic en el mismo.

Además de la paleta principal, la ventana presenta los siguientes elementos:
- | Transparente: este control, propuesto sólo cuando es posible, permite hacer transparente o sin color el elemento deseado.
- | Colores recientes: la línea con colores ubicada debajo de la paleta muestra los últimos 8 colores utilizados en el proyecto.
- | Más colores…: este comando abre la ventana en la cual es posible definir los colores personalizados.
- | Cuentagotas: esta herramienta permite tomar el color de cualquier elemento mostrado en la pantalla, ya sea dentro o fuera de la ventana del programa WebSite X5. Basta hacer clic en la herramienta cuentagotas y mantener pulsada la tecla derecha del ratón hasta que el puntero se sitúe en correspondencia del color que se desea "succionar".


Ventana Propiedad Efecto

Esta ventana presenta los comandos necesarios para predisponer un efecto de entrada en las Imágenes seleccionadas del objeto Presentación, disponible en el editor para el Editor de plantilla, y en las Imágenes seleccionadas del Objeto de galería.

Los comandos disponibles están distribuidos en las siguientes secciones:

1. Sección Tipo de efecto
En esta sección es posible elegir el tipo de efecto en entrada que aplicar a las Imágenes sobre las que se está trabajando:
- | Lista de los efectos: presenta la lista de todos los efectos disponibles. Seleccionando la opción "1 - Aleatorio" el efecto que aplicar es elegido automáticamente de manera casual. Una vez seleccionado, de cada efecto se muestra la vista previa mediante la ventana especial.
- | Tiempo de visualización: permite predisponer el tiempo (en segundos) para la visualización de la imagen.

2. Sección Zoom y posición
En esta sección es posible definir el tipo de movimiento y de ampliación que aplicar a las imágenes en que se está trabajando.
- | Posición inicial: permite definir el factor de ampliación y las Coordenadas X y Y que definen la posición inicial desde la que inicia el movimiento de la Imagen.
- | Posición final: permite definir el factor de ampliación y las Coordenadas X y Y que definen la posición final en la que termina el movimiento de la imagen.
En ambos casos, es posible actuar directamente sobre la Imagen de vista previa para arrastrarla hasta la posición deseada y definir así las posiciones inicial y final del movimiento.

 En una misma Imagen es posible predisponer tanto un efecto en entrada como un efecto que prevé el movimiento y el zoom. En este caso, se aplica antes el efecto en entrada y la Imagen es visualizada según las coordenadas y el tamaño definidos para la posición inicial. A continuación, se reproduce el desplazamiento, y eventualmente el cambio de tamaño, que lleva la Imagén a alcanzar las coordenadas y el tamaño definidos para la posición final.

Sólo en el caso de Imágenes del objeto Presentación, disponible en el editor para la personalización del Editor de plantilla, está disponible también la siguiente sección:

3. Sección Página
En esta sección es posible especificar las páginas del Sitio en que se deben ver las Imágenes seleccionadas de la Presentación. Para hacerlo basta hacer una marca junto a las Páginas deseadas, directamente en el Mapa del sitio propuesto.

Especificar en qué Páginas de un Sitio se deben ver determinadas imágenes de una Presentación puede ser muy útil en caso, por ejemplo, de mensajes publicitarios. Mediante la Presentación se predisponen todos los banner que usar en el Sitio y después de hace que para cada Página o sección se vean sólo los mensajes pertinentes.

Temas relacionados:
- | Editor de plantilla| Recuadro Presentación
- | Objeto de galería| Sección Lista


Ventana Cargar archivo vinculado

Esta ventana es abierta por el botón Agregar... relativo a la composición de la lista de los archivos vinculados o a una Animación Flash (ver,Objeto de Animación Flash| Sección Avanzado) o a un Código HTML (ver, Objeto HTML y Widgets| Sección Avanzado).

R Los comandos disponibles son:
- | Archivo adjunto para cargar en servidor: permite importar un archivo vinculado a la Animación Flash en que se está trabajando.
- | Ruta del servidor: permite especificar la ruta de acceso relativa de la carpeta en la que debe ser publicado el archivo importado, porque está vinculado al Objeto.
- | Vincular archivo a la Página (sólo para archivos .js y .css): si el archivo importado es un archivo JavaScript (formato .js) o una Hoja de Estilo (formato .css), para poder funcionar debe ser vinculado a la Página. En estos casos, activando esta opción, el código necesario es automáticamente insertado en la sección <HEAD> del código HTML de la Página.

Temas relacionados:
- | Objeto de Animación Flash| Sección Avanzado
- | Objeto HTML y Widgets| Sección Avanzado


Ajustes avanzados

Después de haber dibujado el Mapa del Sitio en el Paso 2 y de haber creado cada Página introduciendo todos los contenidos necesarios en el Paso 3, es posible continuar con el Paso 4 donde se proponen una serie de secciones con numerosas funciones avanzadas. Así es posible proceder con la definición del Estilo de los distintos Menús de navegación y de los textos, pero también con la creación de secciones de Sitio importantes como el Carrito de la compra de comercio electrónico, el Blog o el Área reservada.

Concretamente, las funciones avanzadas disponibles son:

 Menú principal
En esta sección es posible definir el aspecto gráfico de las opciones del Menú de primer nivel, o sea del Menú que se ve siempre en la parte superior (estructura con Menú horizontal) o lateral (estructura con Menú vertical) del Sitio que resuelve la navejación fija.

Menú desplegable
En esta sección es posible definir el aspecto gráfico de las opciones del Menú desplegable, o sea el Menú que aparece pasando con el ratón sobre una opción del Menú principal.

Menú de Página
En esta sección es posible definir el aspecto gráfico de Submenú, o sea del Menú que propone la lista de las Páginas del Nivel en curso.

Estilos y Plantillas
En esta sección es posible definir los estilos que aplicar a los distintos elementos de texto presentes en las Páginas, a la ventana ShowBox vinculada al Objeto Galería, a las ToolTip que pueden ser asociadas a los Enlaces y a los correos electrónicos generados si se utiliza el Objeto Formulario de envío de correo electrónico o si se crea un Carrito de la compra de comercio electrónico.

Página de bienvenida
En esta sección es posible predisponer una Página de bienvenida que sirve de introducción al Sitio, con una columna sonora y los enlaces necesarios para la elección del idioma de consulta.

Mensaje de publicidad
En esta sección es posible predisponer y personalizar un mensaje pubblicitario que podrá aparecer sólo en la Página de inicio o en todas las páginas del Sitio, en la posición especificada.

Blog
En esta sección es posible crear y controlar Blog, una especie de diario en Web en el que publicar noticias que los usuarios podrán comentar.

Sindicación Web (Feed RSS)
En esta sección es posible crear y administrar la sindicación web (Feed RSS), muy útil como canal de información constante y actualizado.

Gestión accesos
En esta sección es posible crear los perfiles Usuario que podrán acceder a las Páginas protegidas del Sitio y gestionarlos en Grupos. Las Páginas protegidas, definidas en el Paso 2, durante la Creación del mapa, forman el Área reservada a la que los usuarios podrán acceder sólo mediante el login: las credenciales de acceso utilizadas determinan qué Páginas protegidas podrán ser efectivamente visualizadas.

Carrito de la compra
En esta sección es posible crear y gestionar un carrito de la compra de comercio electrónico, definiendo aspectos como: la lista de los Productos, los métodos de Envío y Pago, la composición del formulario a compilar para el envío del pedido.

Para mayor información acerca de la creación del mapa del sitio y las diferencias entre los elementos del primer y segundo nivel, menús desplegables y sub-menús, hacer refencia a cuanto se explicado en - Creación del Mapa.


Estilo del Menú principal

Esta ventana presenta los comandos mediante los cuales es posible efectuar la definición de algunos ajustes avanzados sobre el estilo gráfico de los Botones relativos a las opciones de primer nivel del Menú.

Los Menús son creados y actualizados automáticametne por el programa en base al Mapa del Sitio diseñado en el Paso 2 - Creación del Mapa. El Menú principal es el que presenta las opciones de primer Nivel del Mapa que compondrán la navegación fija del Sitio. En los Sitios con estructura de Menú Horizontal, el Menú principal está siempre presente, situado inmediatamente por encima o por debajo del Encabezamiento. En los sitios con estructura de Menú Vertical, en cambio, el Menú principal está sempre visible, situado en una especial columna a la izquierda o a la derecha del contenido de la Página.

En función de los ajustes de Estilo definidos, WebSite X5 creará los botones relativos a las opciones del Menú principal de uno de los siguientes modos:
- | Botón Gráfico: si se mantiene una forma rectangular, eligiendo un color único, los Bbotones del Menú son creados en texto y su aspecto se define con el uso de las Hojas de Estilo (CSS). Los Botones Gráficos ofrecen la ventaja de ser más ligeros para ser cargados y visualizados en línea.
- | Botón 3D: si se elige cualquier forma distinta del rectángulo y se predispone un estilo 3D, los Botones del Menú son creados en gráfica, o sea, para cada botón se guarda una imagen. Los botones 3D ofrecen la ventaja de permitir un mayor grado de libertad en la elección de los ajustes gráficos y del font del texto.

Consejos Práticos

Después de haber predispuesto la estructura del Sitio eligiendo entre Menú Horizontal o Menú Vertical (Paso 1 - Selección de plantillas o Paso 1 - Plantilla personalizada) y de haber diseñado el Mapa del Sitio (Paso 2 - Creación del mapa), WebSite X5 es capaz de crear el Menú y permitir la navegación entre las Páginas. Accediendo al Paso 4 - Ajustes avanzados y haciendo clic en Estilo del Menú principal, se puede personalizar el aspecto del Menú de navegación fija.

Los comandos necesarios para efectuar la personalización de los Botones están organizados en las siguientes secciones:
- | Sección General
- | Sección Elementos de Menú
- | Sección Estilo de 3D

Temas relacionados:

-

Ajustes avanzados


Estilo del Menú principal| Sección General

Mediante las opciones propuestas en la Sección General de la ventana Estilo del Menú principal es posible definir algunos ajustes generales del Menú principal.

Las opciones disponibles en el recuadro Estilo son:
- | Ancho: permite predisponer el valor en pixel de la anchura de los Botones que contienen las opciones de Menú.
- | Margen horizontal / Margen vertical: el margen es el espacio entre el borde del Botón y el texto contenido. Así pues, mediante estas opciones es posible definir cuánto espacio debe haber horizontal y/o verticalmente alrededor del texto dentro del Botón.
- | Distancia entre los Botones: permite establecer el margen externo, o sea, el espacio existente entre un botón y otro.

Las opciones presentes el recuadro Texto son:
- | Fuente: permite especificar, mediante la ventana abierta, el Tipo de carácter, el Estilo y el tamaño del texto
- | Alineación: permite definir la alineación del texto a la Izquierda, al Centro o a la Derecha respecto al Botón.
- | Usar antialias para visualizar el texto: activando esta opción, un efecto de anti alias es aplicado al texto para hacer que los bordes sean menos irregulares.

Por último, el recuadro Opciones propone:

-

Desplazamiento automático del menú: al activar esta opción el Menú de navegación se desliza automáticamente junto al Contenido de la Página, de modo que siempre esté disponible y visible.

La anchura de los Botones debe ser definida teniendo en cuenta también el espacio total disponible para el Menú: dicho parámetro puede ser libremente modificado en el caso que no se utilice un modelo gráfico predefinido (ver, Plantilla personalizada).

Temas relacionados:

-

Estilo del Menú principal


Estilo del Menú principal| Sección Opciones Menú

Mediante las opciones propuestas en la Sección Opciones Menú de la ventana Estilo del Menú principal es posible definir los colores, las imágenes de fondo y el estilo de los textos para los distintos estados de los Botones del Menú principal.

También en este caso es preciso, en primer lugar, seleccionar el Elemento del Menú en que se desea trabajar: es posible definir el aspecto tanto de la [image] Opción activa como de la [image] Opción al paso del ratón / Página en curso. Para seleccionar el elemento del Menú es posible utilizar el especial menú desplegable, o bien, modificar directamente la imagen de la Vista previa que es constantemente actualizada en función de los cambios aportados.

Para ambos Elementos del Menú es posible utilizar las siguientes opciones del recuadro Estilo:
- | Color Fondo / Color Texto / Color Borde: permiten definir, mediante la ventana Color abierta, el color para el fondo, para el texto y para el borde del Botón.
- | Imagen de Fondo: permite definire la Imagen que debe ser visualizada como fondo del Botón. Para seleccionar la imagen a utilizar basta hacer clic en el botón [image] para ojear los recursos disponibles: se pueden utilizar archivos en formato .JPG, .GIF, .PNG.
- | Estilo fuente: para el Elemento Opción activa, permite definir el estilo del texto del Botón eligiendo entre Ninguno, Bajo relieve, Alto relieve y Sombra. El Elemento Opción al paso del ratón / Página en curso hereda automáticamente el ajuste definido para el Elemento Opción activa: además, es posible añadir uno de los siguientes estilos: Normal, Negrita, Cursiva y Negrita Cursiva.

Temas relacionados:

-

Estilo del Menú principal


Estilo del Menú principal| Sección Estilo 3D

Mediante los comandos propuestos en la Sección Estilo 3D de la ventana Estilo del Menú principal es posible definir forma y aspecto 3D de los botones.

Mediante las opciones disponibles en el recuadro Forma es posible definir:
- | Forma: permite definir la forma del Botón, eligiéndola entre las propuestas.
- | Factor de esquina: permite definir el factor de esquina de los Botones con formas de ángulos redondos u otros que no sean rectangulares.
- | Unir forma de los botones: activando esta opción, se aplica la forma seleccionada a los Botones combinados, como que si fueran un solo bloque.

En el recuadro Estilo de 3D están disponibles las opciones:
- | Estilo: permite definir el aspecto del Botón como Convexo, Plano, Convexo plano, Cóncavo, etc.
- | Dirección de la luz: permite definir la dirección del efecto de luz establecido para el botón.
- | Factor Difuminar: permite definir el factor de difuminar que aplicar en el Botón.
- | Transparencia Imagen: permite definir el factor de transparencia para las Imágenes insertadas en los Botones del Menú a través de las especiales opciones de la sección Opciones Menú.

Por último, el recuadro Borde 3D presenta las siguientes opciones:
- | Estilo borde: permite definir el estilo del borde del Botón como Normal, Convexo, Cóncavo.
- | Grosor externo / Grosor interno: permiten definir, respectivamente, el grosor externo e interno del borde del Botón
- | Sólo borde exterior: activando esta opciónse dibuja el borde según los ajustes definidos, no para cada Botón, sino sólo para todo el bloque de los Botones considerados en su conjunto.

Temas relacionados:

-

Estilo del Menú principal


Estilo del Menú Desplegable

Esta ventana presenta los comandos a través los cuales es posible definir algunos ajustes avanzados relacionados con el estilo gráfico del Menú Desplegable.

Los Menús son creados y actualizados automáticametne por el programa en base al Mapa del Sitio diseñado en el Paso 2 - Creación del Mapa. Los Menús Desplegables son aquellos visualizados al pasar el ratón sobre una opción de Nivel del Menú Principal.

Como para el Menú Principal, en base a los ajustes de Estilo definidos, WebSite X5 creará los Botones relativos a las opciones de los Menús Desplegables o como Botones Gráficos o como Botones 3D (ver, Estilo del Menú Principal).

Consejos Práticos

Después de haber predispuesto la estructura del Sitio eligiendo entre Menú Horizontal o Menú Vertical (Paso 1 - Elección de la Plantilla o Paso 1 - Plantilla personalizada) y de haber diseñado el Mapa del Sitio (Paso 2 - Creación del mapa), WebSite X5 es capaz de crear el Menú y de permitir la navegación entre las Páginas. Accediendo al Paso 4 - Ajustes avanzados y haciendo clic en Estilo del Menú Desplegable, se puede personalizar el aspecto de dicho Menú.

Los comandos necesarios para efectuar la personalización de los Botones están organizados en las siguientes secciones:
- | Sección General
- | Sección Elementos de Menú
- | Sección Estilo 3D

Temas relacionados:

-

Ajustes avanzados


Estilo del Menú Desplegable| Sección General

Mediante las opciones propuestas en la Sección General de la ventana Estilo del Menú Desplegable es posible proceder a la definición de algunos ajustes generales.

En primer lugar es preciso definir el Tipo de Menú que se desea realizar eligiendo entre:

 Ordenar en una columna: todas las opciones del Menú Desplegable están organizadas en una única columna, una tras otra.

Ordenar en más columnas: las opciones del Menú Desplegable están organizadas en varias columnas, una junto a otra. Se crea automáticamente una nueva columna cuando:
- | el número de opciones alcanza o supera el valor predispuesto para la opción Opciones máx. por Columna;
- | la lista de las Páginas es interrumpida por un Separador (ver, Crear el Mapa del sitio).

Además, si en la ventana Selección de plantillas o en la ventana Plantilla personalizada se ha predispuesto el Menú Vertical, está disponible también:

 Acordeón vertical: todas las opciones del Menú Desplegable están organizadas en una única columna; haciendo clic en una opción, todas las opciones sucesivas se mueven hacia la bajo para dejar espacio a la visualización de las sub-opciones relacionadas.

Una vez elegido el Tipo de Menú, es posible definir las opciones propuestas en el recuadro Estilo:
- | Ancho: permite predisponer el valor en pixel de la anchura de los Botones que contienen las opciones de Menú.
- | Margen horizontal / Margen vertical: el margen es el espacio entre el borde del Botón y el texto contenido. Así pues, mediante estas opciones es posible definir cuánto espacio debe haber horizontal y/o verticalmente alrededor del texto dentro del Botón.
- | Elementos por columna: activo sólo para el Tipo de Menú Disposición en varias columnas, permite predisponer el número máximo de opciones que puede contener cada columna del Menú Desplegable.

Las opciones presentes el recuadro Texto son:
- | Fuente: permite especificar, mediante la ventana abierta, el Tipo de carácter, el Estilo y el tamaño del texto.
- | Alineación: permite definir la alineación del texto a la Izquierda, al Centro o a la Derecha respecto al Botón.

Por último, el recuadro Opciones propone:

-

Efecto: permite definir el efecto de visualización para el Menú desplegable, eligiendo entre Ninguno, Difuminado, Deslizamiento por arriba, Deslizamiento por la izquierda, Deslizamiento por arriba a la izquierda.

Temas relacionados:

-

Estilo del Menú Desplegable


Estilo del Menú Desplegable| Sección Opciones Menú

Mediante las opciones propuestas en la Sección Opciones Menú de la ventana Estilo del Menú Desplegable es posible definir los colores, las imágenes de fondo y el estilo de los textos para los distintos estados de los Botones del Menú Desplegable.

También en este caso es preciso, en primer lugar, seleccionar el Elemento del Menú en que se desea trabajar: es posible definir el aspecto de la [image] Elemento de menú, de la [image] Elemento al pasar el ratón y del [image] Separador. Para seleccionar el elemento del Menú es posible utilizar el especial menú desplegable, o bien, modificar directamente la imagen de la Vista previa que es constantemente actualizada en función de los cambios aportados.

Para los Elementos del Menú es posible utilizar las siguientes opciones del recuadro Estilo:
- | Color Fondo / Color Texto / Color Borde: permiten definir, mediante la ventana Color abierta, el color para el fondo, para el texto y para el borde del Botón. Para el elemento Separador está disponible sólo el comando Color Texto.
- | Imagen de fondo: para los elementos Opción activa y Opción al paso del ratón, permite definir la imagen que se debe ver como fondo del Botón. Para seleccionar la imagen a utilizar basta hacer clic en el botón [image] para ojear los recursos disponibles: se pueden utilizar archivos en formato .JPG, .GIF, .PNG.
- | Fuente: para los elementos Opción al paso del ratón y Separador,permite definir el estilo del texto eligiendo entre Normal, Negrita, Cursiva y Negrita Cursiva.
- | Icono de viñeta: permite definir la imagen que se debe utilizar como punto lista junto a las opciones de los Botones o de los Separadores insertados. También en este caso es preciso hacer clic en el botón [image] y seleccionar un archivo en formato .JPG, .GIF, .PNG.

Temas relacionados:

-

Estilo del Menú Principal


Estilo del Menú Desplegable| Sección Estilo 3D

Mediante los comandos propuestos en la Sección Estilo 3D de la ventana Estilo del Menú Desplegable es posible definir forma y aspecto 3D de los botones.

Mediante las opciones disponibles en el recuadro Forma es posible definir:
- | Forma: permite definir la forma del Botón, eligiéndola de entre las propuestas.
- | Factor de esquina: permite definir el factor de esquina de los botones con formas de ángulos redondos u otros que no sean rectangulares.
- | Unir forma de los botones: activando esta opción, se aplica la forma seleccionada a los Botones combinados, como que si fueran un solo bloque.

En el recuadro Estilo de 3D están disponibles las opciones:
- | Estilo: permite definir el aspecto del Botón como Convexo, Plano, Convexo plano, Cóncavo, etc.
- | Dirección de la luz: permite definir la dirección del efecto de luz establecido para el botón.
- | Factor de difuminar: permite definir el factor de difuminar que aplicar en el Botón.
- | Transparencia Imagen: permite definir el factor de transparencia para las Imágenes insertadas en los Botones del Menú a través de las especiales opciones de la sección Opciones Menú.

Por último, el recuadro Borde 3D presenta las siguientes opciones:
- | Estilo borde: permite definir el estilo del borde del Botón como Normal, Convexo, Cóncavo.
- | Grosor externo / Grosor interno: permiten definir, respectivamente, el grosor externo e interno del borde del Botón.
- | Sólo borde exterior: activando esta opciónse dibuja el borde según los ajustes definidos, no para cada Botón, sino sólo para todo el bloque de los Botones considerados en su conjunto.

Temas relacionados:

-

Estilo del Menú Principal


Estilo del Menú de Página

Esta ventana presenta los comandos mediante los cuales es posible definir algunos ajustes avanzados relativos al estilo gráfico de los Botones de los Menús de Página.

Los Menús son creados y actualizados automáticametne por el programa en base al Mapa del Sitio diseñado en el Paso 2 - Creación del Mapa. Los Menús de Página son aquellos que, opcionalmente, pueden ser visualizados para proponer la lista de las Páginas del Nivel en curso. En otras palabras, si se abre una página que pertenece a un Nivel y este nivel contiene también otras páginas, el Menú de Página propone la lista de todas las Páginas de dicho Nivel. Los Menús de Página se proponen siempre como menús verticales, situados a la derecha o a la izquierda de los contenidos de Página.

Como para el Menú principal, en base a los ajustes de Estilo definidos, WebSite X5 creará los Botones relativos a las opciones de los Menús de Página o como Botones Gráficos o como Botones 3D (ver, Estilo del Menú Principal).

Consejos Práticos

Después de haber predispuesto la estructura del Sitio eligiendo entre Menú Horizontal o Menú Vertical (Paso 1 - Selección de plantillas o Paso 1 - Plantilla personalizada) y de haber diseñado el Mapa del Sitio (Paso 2 - Creación del mapa), WebSite X5 es capaz de crear el Menú y permitir la navegación entre las Páginas. Accediendo al Paso 4 - Ajustes Avanzados y haciendo clic en Estilo del Menú de Página, se puede personalizar el aspecto de dicho Menú.

Los comandos necesarios para efectuar la personalización de los Botones están organizados en las siguientes secciones:
- | Sección General
- | Sección Elementos de Menú

Temas relacionados:

-

Ajustes Avanzados


Estilo del Menú de Página| Sección General

Mediante las opciones propuestas en la Sección General de la ventana Estilo del Menú de Página es posible definir algunos ajustes generales del Menú de Página.

En primer lugar, si se desea que aparezca un Menú de Página con la lista de las Páginas del Nivel en curso, es preciso activar la opción Visualizar Menú de Página.

Una vez hecho esto, este elemento permite utilizar las opciones del recuadro Estilo:
- | Posición del menú: permite especificar si el Menú de Página debe ser visualizado en el lado derecho o izquierdo de la Página.
- | Ancho: permite definir la anchura en pixel de los Botones que componen el Menú de Página.
- | Margen horizontal / Margen vertical: el margen es el espacio entre el borde del Botón y el texto contenido. Así pues, mediante estas opciones es posible definir cuánto espacio debe haber horizontal y/o verticalmente alrededor del texto dentro del Botón.
- | Distancia entre botones: permite establecer el margen externo, o sea, el espacio existente entre un botón y otro.

Las opciones presentes el recuadro Texto son:
- | Fuente: permite especificar, mediante la ventana abierta, el Tipo de carácter, el Estilo y el tamaño del texto.
- | Alineación: permite definir la alineación del texto a la Izquierda, al Centro o a la Derecha respecto al Botón.

Por último, el recuadro Borde presenta las siguientes opciones:
- | Color borde: permite definir, mediante la ventana Color abierta, el color para el borde del Botón.
- | Grosor: permite definir el grosor del borde del Botón.

Temas relacionados:

-

Ajustes Avanzados


Estilo del Menú de Página| Sección Opciones Menú

Mediante las opciones propuestas en la Sección Opciones Menú de la ventana Estilo del Menú de Página es posible definir algunos parámetros gráficos para determinar el aspecto de las opciones del Menú de Página.

También en este caso es preciso, en primer lugar, seleccionar el Elemento del Menú en que se desea trabajar: es posible definir el aspecto de la [image] Opción Activa, de la [image] Opción al paso del ratón / Página en curso, del [image] Separador y de la [image] Línea de separación. Para seleccionar el elemento del Menú es posible utilizar el especial menú desplegable, o bien, modificar directamente la imagen de la Vista previa que es constantemente actualizada en función de los cambios aportados.

- | Color Fondo / Color Texto / Color Línea: permiten definir, mediante la ventana Color abierta, el color para el fondo y para el texto de la Opción Activa, de la Opción al paso del ratón / Página en curso y del Separador, así como el color de la línea para la Línea de separación.
- | Icono de viñeta: disponible para los Elementos Opción Activa, Opción al paso del ratón / Página en curso y Separador, permite importar la imagen (archivo en formato .JPG, .GIF, .PNG) que debe preceder a las opciones de la Menú de Página, como si se tratase de un punto de lista.
- | Estilo fuente: para los elementos Opción al paso del ratón / Página en curso y Separador permite definir el estilo del texto del Botón eligiendo entre Normal, Negrita, Cursiva y Negrita Cursiva.
- | Estilo de línea: disponible sólo para el Elemento Línea de separación permite predisponer el tipo de trazo eligiendo entre Lleno, Discontinuo, Puntos, Bajo relieve, Alto relieve.

Temas relacionados:

-

Ajustes Avanzados


Estilos y Plantillas

Esta ventana presenta los comandos mediante los cuales es posible definir los estilos que aplicar a los distintos elementos de texto presentes en las Páginas, a la ventana ShowBox vinculada a elementos como el Objeto Galería y el Objeto Lista Productos, a las ToolTip que pueden ser asociadas los Enlaces y a los correos electrónicos creados si se utiliza el Objeto Formulario de envío de correo electrónico o si se crea un Carrito de la compra de comercio electrónico.

Un Estilo puede ser genéricamente definido como un conjunto de ajustes relativos a la formatación del texto y a la gráfica que se puede aplicar a un elemento para modificar su aspecto. Así pues, la aplicación de un Estilo, permite asociar varios formatos contemporáneamente con una única operación.

Consejos Práticos

Después de haber diseñado el Mapa del Sitio (Paso 2 - Creación del Mapa) e insertado los contenidos de las Páginas (Paso 3 - Creación de Páginas), es posible acceder al Paso 4 - Ajustes avanzados y definir los Estilos para personalizar el aspecto de algunos elementos recurrentes del Sitio.

Las diferentes opciones se presentan en las siguientes secciones:
- | Sección Textos
- | Sección ShowBox
- | Sección ToolTip
- | Sección Correo electrónico

Temas relacionados:

-

Ajustes Avanzados


Estilos y Plantillas| Sección Texto

Estilos y Plantillas| Sección Textos

Mediante los comandos de la Sección Textos de la ventana Estilos y Plantillas es posible definir los Estilos que se pueden utilizar para los Textos presentes en el Sitio.

En primer lugar, es preciso elegir el Elemento de Página del que se desea definir el Estilo, seleccionándolo del especial menú desplegable o, en alternativa, haciendo clic directamente en él en la Vista previa.

Concretamente, los Elementos de Página para los que se identifica y aplica un Estilo son:

 Título de la página: es el Título de las distintas Páginas del Sitio. Se toma el nombre dado a las Páginas en fase de costrucción del Mapa en la ventana Creación del mapa o, si se ha especificado de otro modo, del Título por extenso de la ventana Propiedades de la página.

Ruta de acceso de la Página: este es el texto que aparece justamente debajo del título de la página, en el cual la ruta de acceso lógica es creada facilitándonos por si misma su ubicación dentro del sitio. El Programa genera automáticamente la ruta de acceso lógica.

Texto de la Página: es el texto de cada párrafo insertado mediante el Objeto Texto. El estilo de este elemento es aplicado por defecto cuando se abre el editor relativo al Objeto Texto: Después, mediante los comandos puestos a disposición por el editor mismo, es posible efecturar ulteriores modificaciones y personalizaciones. El Estilo definido para este tipo de elemento es aplicado también a todos los textos creados e introducidos automáticamente por el Programa como, por ejemplo, las Páginas del Área reservada, del Blog, del Motor de búsqueda interno y del Mapa de sitio.

Enlace activo / Enlace al pasar encima el ráton / Enlace ya visitado: son los enlaces hipertextuales creados mediante el Objeto Texto. Un enlace puede presentar un aspecto distinto según el estado asumido: activo, al pasar del ratón (efecto mouseover) o visitado. Distinguir visualmente un enlace activo de un enlace ya visitado, es útil para simplificar la navegación del usuario pues le recuerda qué secciones ha explorado ya.

Menú del pie de página: es el Menú, presente en el pie de cada Página, en el que se proponen las opciones del Menú Principal.

Seleccionado el Elemento de Página, es posible modificar su estilo mediante las siguientes opciones incluídas en el recuadro Estilo:
- | Visualizar: activando esta opción es posible hacer que el elemento de Página sea visible o no. Esta opción, obviamente, no está disponible para el Texto de la Página y los distintos estados del Enlace que no pueden ser invisibles. Es importante especificar que hacer invisible un Elemento de la Página no significa eliminarlo también del código de la Página misma: se puede, por ejemplo, hacer invisible el Título de la Página porque se prefiere insertarlo como imagen pero, tampoco en este caso, será eliminado el tag <title> del el código HTML.
- | Color Fondo / Color Texto: permiten especificar, mediante la ventana Color abierta, el color del fondo y del texto del Elemento de Página seleccionado. Sólo para el Texto de la Página no es posible definir el color del fondo puesto que se predispone en base a la Plantilla elegida (ver, Selección de plantillas, o Plantilla personalizada) y/o al Aspecto de la celda en que está insertado el Objeto Texto.
- | Fuente: permite especificar, mediante la ventana abierta, el tipo de fuente, el estilo y el tamaño en puntos del texto.
- | Alineación: permite de especificar la alineación del Elemento de Página, eligiendo entre Izquierda, Centro y Derecha. Esta opción no está disponible para los distintos estados del Enlace puesto que la alineación de los enlaces hipertextuales es definida, independientemente del estilo, en fase de creación del Objeto Texto.
- | Estilo del texto: disponible sólo para el Enlace en los distintos estados, permite predisponer el estilo del texto como Normal o Subrayado.
- | Puntero: disponible sólo para el Enlace activo, y heredado automáticamente también por los otros dos estados del Enlace, permite especificar el aspecto asumido por el puntero del ratón al pasar sobre el enlace. haciendo clic en [image] se puede seleccionar el archivo .CUR, .ICO que utilizar.
- | Borde superior / Borde inferior: permite especificar, mediante la ventana Color abierta, el color del borde superior y/o inferior que puede ser añadido al Título de la página, a la Ruta de acceso de la página y al Menú del pie de página.

Temas relacionados:

-

Estilos y Plantillas


Estilos y Plantillas| Sección ShowBox

Mediante los comandos de la Sección ShowBox de la ventana Estilos y Plantillas es posible definir el Estilo de la ventana ShowBox utilizada en las Galerías en JavaScript (ver, Objeto Galería), en el Enlace Galería con ShowBox (ver, Enlace| Sección Acción) y en el Objeto Lista Productos. En todos los casos, la ventana ShowBox se abre bajo enlace y sirve para visualizar una imagen ampliada, un Vídeo o una serie entera de Imágenes: haciendo clic en el enlace, se oscurece la ventana del Navegador para resaltar la ventana ShowBox, visualizada sobrepuesta en base al efecto de entrada predispuesto.

Las opciones disponibles en la sección Estilo son:
- | Efecto: permite predisponer un efecto de entrada para la ventana ShowBox eligiendo entre Ninguno, Disolver y Desplazar desde arriba.
- | Color externo del fondo / Color interno del fondo: permiten definir, mediante la ventana Color abierta, el color del fondo externo y/o interno a la ventana ShowBox. El color del fondo externo es el que queda semi-trasparente (en base al valor predispuesto para la opción Opacidad Fondo) y utilizado para oscurecer la ventana del Navegador que está debajo.
- | Opacidad del fondo: permite predisponer el valor de opacidad del fondo externo a la ventana ShowBox. Cuanto más alto sea el valor de la opacidad, menos será visible la ventana del Navegador que está debajo.
- | Mostrar sombra del desplegable (CSS3): permite añadir una sombra a la ventana ShowBox. Dicha sombra será visualizada sólo en Navegadores que soporten CSS3.

El recuadro Borde presenta las siguientes opciones:
- | Color borde: permite definir, mediante la ventana Color abierta, el color para el borde de la ventana ShowBox.
- | Grosor: permite definir el grosor del borde de la ventana ShowBox.

Por último, las opciones presentes el recuadro Texto son:
- | Fuente: permite especificar, mediante la ventana abierta, el Tipo de carácter, el Estilo y el tamaño del texto de la ventana ShowBox.
- | Alineación: Permite definir la alineación del texto a la Izquierda, al Centro o a la Derecha respecto a la ventana ShowBox.
- | Color Texto: permite definir, mediante la ventana Color abierta, el color para el texto de la ventana ShowBox.

Temas relacionados:
- | Estilos y Plantillas
- | Objeto Galería
- | Enlace| Sección Acción
- | Objeto Lista Productos


Estilos y Plantillas| Sección ToolTip

Mediante los comandos de la Sección ToolTip de la ventana Estilos y Plantillas es posible definir el estilo que aplicar a las ToolTip asociadas a los Enlaces insertados en Textos o Imágenes mediante el especial comando Insertar enlace Insertar Enlace. La ToolTip es un breve texto de ayuda, visualizado dentro de un box en relación al paso del ratón sobre un Enlace: su función es ofrecer una explicación sobre qué ocurrirá haciendo clic.

Para definir el aspecto de las ToolTip es posible, en primer lugar, utilizar las opciones presentes el recuadro Estilo:
- | Posición Tooltip: permite especificar la posición de las ToolTip respecto al Enlace al cual están asociadas, eligiendo entre Arriba, Abajo, Izquierda y Derecha.
- | Efecto: permite elegir si las ToolTip se deben ver con un efecto de transición como el Disolver o el Efecto rebote.
- | Color Fondo: permite especificar, mediante la ventana Color abierta, el color del fondo de las ToolTip.
- | Factor de esquina: permite definir cuánto deben ser redondeados los ángulos de las ToolTip.
- | Mostrar sombra del desplegable (CSS3): permite predisponer una sombra alrededor del perfil de las ToolTip.
- | Mostrar cola: permite añadir al baloon (o sea, al el bocadillo) de las ToolTip una flecha en dirección del enlace al que están asociadas.

El recuadro Borde presenta las siguientes opciones:
- | Color Borde: permite definir, mediante la ventana Color abierta, el color para el borde de las ToolTip.
- | Grosor: permite definir el grosor del borde de las ToolTip.

Por último, las opciones presentes el recuadro Texto son:
- | Fuente: permite especificar, mediante la ventana abierta, el Tipo de carácter, el Estilo y el tamaño del texto de las ToolTip.
- | Alineación: Permite definir la alineación del texto a la Izquierda, al Centro o a la Derecha respeto a la ToolTip.
- | Color Texto: permite definir, mediante la ventana Color abierta, el color para el texto de las ToolTip.

 Los ajustes de Estilo son válidos para todo el Proyecto y, por lo tanto, todas las ToolTip tendrán el mismo aspecto gráfico. En cambio, para definir el contenido (texto e imagen) de cada ToolTip es necesario servirse de la Sección Descripción de la ventana Enlace.

Temas relacionados:
- | Estilos y Plantillas
- | Insertar Enlace| Sección Descripción


Estilos y Plantillas| Sección Correo electrónico

Mediante los comandos de la Sección Correo electrónico de la ventana Estilos y Plantillas es posible definir el Estilo de los Correos electrónico creados por el Objeto Formulario de envío de correo electrónico o por el Carrito de la compra de comercio electrónico.

En primer lugar, es preciso seleccionar el Elemento del Correo electrónico del que se desea definir el Estilo seleccionándolo mediante el especial menú desplegable o, en alternativa, haciendo clic directamente sobre él en la Vista previa.

Concretamente, los Elementos del Correo electrónico para los que se identifica y aplica un Estilo, son:

 Diseño del correo electrónico: los correos electrónicos creados por el programa tienen todos una idéntica estructura que prevé un marco externo de fondo y un cuerpo central con el mensaje. Entre el marco externo y el cuerpo central se puede prever también un borde que separa o crea profundidad y grosor.

Imagen/Logotipo empresa: es una imagen que puede ser añadida al encabezamiento del correo electrónico. Se puede insertar un simple logotipo empresarial o un banner que llega a ocupar toda la anchura del los correos electrónicos.

Contenido del mensaje: es el cuerpo del correo electrónico donde se propone el mensaje.

Nota de pie de página: son las notas de cierre de los correos electrónicos que, en general, contienen un mensaje estándar y se distinguen visualmente por el cuerpo del mensaje, al menos por el hecho de tener un tamaño de font inferior.

Según el Elemento del correo electrónico seleccionado es posible modificar las distintas opciones presentadas en la sección Estilo:
Diseño del correo electrónico:

-

Color externo del fondo / Color interno del fondo: permiten especificar, mediante la ventana Color abierta, el color del fondo externo, o sea del marco, y del fondo interno, o sea del cuerpo central del correo electrónico.

-

Color Borde / Grosor: permiten, respectivamente, especificar el color y el grosor del borde que separa el marco externo del cuerpo del correo electrónico.
Imagen/Logotipo empresa:

-

Archivo imagen: permite seleccionar la imagen que se desea insertar en el encabezado del correo electrónico. Basta hacer clic en [image] para seleccionar el archivo gráfico en formato .JPG, .GIF o .PNG que se desea importar.

-

Alineación: permite especificar la alineación de la Imagen introducida, eligiendo entre Izquierda, Centro y Derecha.

-

Posición: permite especificar si la Imagen introducida debe ser situada Interior del marco o Exterior del marco relativo al cuerpo del correo electrónico.

-

Ancho: presenta en automático la anchura original de la Imagen y permite modificarla libremente.

La anchura máxima para las imágenes es de 700 pixel y depende de la estructura del correo electrónico. Dicho parámetro garantiza una correcta visualización por parte de todos los client de correo.
Contenido del mensaje:

-

Color Texto: permite especificar, mediante la ventana Color abierta, el color del texto del mensaje de correo electrónico.

-

Fuente: permite especificar, mediante la ventana abierta, el tipo de fuente, el estilo y el tamaño en puntos del texto del mensaje de correo electrónico.
Nota de pie de página:

-

Color Texto: permite especificar, mediante la ventana Color abierta, el color del texto de las notas presentes en el cierre del correo electrónico.

-

Fuente: permite especificar, mediante la ventana abierta, el tipo de fuente, el estilo y el tamaño en puntos del texto de las notas presentadas en el cierre del correo electrónico.

-

Alineación: permite especificar la alineación de las Notas a pie de Página, eligiendo entre Izquierda, Centro y Derecha.

-

Posición: permite especificar si las Notas a pie de Página deben ser situadas Interior del marco o Exterior del marco relativo al cuerpo del correo electrónico.

-

Texto: permite componer el texto que debe ser presentado como Nota a Pie de página. Por defecto se propone un texto sobre la privacidad del mensaje.

Temas relacionados:
- | Estilos y Plantillas
- | Objeto Formulario de envío de correo electrónico
- | Carrito de la compra de comercio electrónico


Página de Bienvenida

Esta ventana presenta los comandos mediante los cuales es posible proceder a la creación de una Página de introducción al Sitio y a la predisposición para su consulta en diversos idiomas.

Como su nombre indica, la Página de Bienvenida es una especie de portada inicial del Sitio: normalmente presenta sólo una Imagen, un Vídeo o una Animación Flash y permite acceder a la verdadera Página de inicio al concluir un tiempo predeterminado o al hacer clic en un enlace. Si es necesario, esta Página introductiva puede presentar también los enlaces para permitir la elección del Idioma de consulta del Sitio.

Consejos Práticos

Puesto que la Página de Bienvenida es un elemento facultativo de un Sitio, para que sea introducida es necesario, en primer lugar, activar la opción Mostrar la página de bienvenida. Si está presente, la Página de Bienvenida es la primera que es visualizada y, sólo al terminar un tiempo predeterminado o al hacer clic en un enlace especialmente predispuesto, aparece la Página de inicio del Sitio.

Es posible componer la Página de Bienvenida definiendo su Fondo y Contenido, así como una Columna sonora eventual.

Las opciones presentadas en el recuadro Fondo de la página son:
- | Color Fondo: permite especificar, mediante la ventana Color abierta, el color de fondo de la Página de Bienvenida.
- | Archivo imagen: permite importar el archivo gráfico (en formato .JPG, .GIF, .PNG) que utilizar como fondo de la Página de Bienvenida.
- | Repetir: esta opción permite especificar si la Imagen utilizada como fondo de la celda debe repetirse o no. La imagen puede repetirse de forma horizontal, vertical o en ambas direcciones, con el propósito de llenar el espacio disponible. Además, es posible hacer que la imagen sea adaptada, es decir, que se cambien sus dimensiones de modo que cubra todo el fondo: en este caso, quizás no se respeten las proporciones originales.
- | Alineación: permite especificar cómo se debe alinear la Imagen introducida respecto a la ventana del Navegador.

Las opciones presentadas en el recuadro Contenido de la Página son:
- | Tipo: permite especificar qué tipo de contenido se desea introducir en la Página de Bienvenida, eligiendo entre Imagen, Animación Flash, Vídeo y Código HTML.
- | Archivo: en el caso que se elija como Tipo de contenido la Imagen, la Animación Flash o el Vídeo, permite importar el archivo gráfico (en formato .JPG, .GIF, .PNG), el archivo Animación Flash (en formato .SWF) o el Archivo Vídeo (en formato .FLV, .MP4) que utilizar.
- | Código HTML: en el caso que se elija como Tipo de contenido Código HTML, permite escribir el código que insertar en la Página de Bienvenida.
- | Ancho / Altura: permiten especificar la anchura y la altura en pixel de la Imagen, de la Animación Flash, del Vídeo o del Código HTML introducidos.

Por último, el recuadro Opciones presenta las siguientes opciones:
- | Sonido al entrar: permite especificar el archivo audio (en formato .MP3) que utilizar como fondo musical durante la visualización de la Página de Bienvenida.
- | Ir a la página de inicio después de [seg]: activando esta opción, es posible especificar el número de segundos para la visualización de la Página de Bienvenida. Una vez transcurrido el período de tiempo determinado, aparecerá automáticamente la Página de inicio del Sitio web.

Idioma de consulta - Consejo Prático

Si el Sitio debe poder ser consultado en varios Idiomas y si se desea dar la posibilidad al usuario de seleccionar el que utilizar mediante Botones insertados en la Página de Bienvenida, es necesario, en primer lugar, activar la opción Visualizar enlace a otros Idiomas.

En el recuadro Lista de idiomas es necesario componer la lista de los Idiomas en los que estará disponible el Sitio. Por defecto se propone una lista compuesta por 5 idiomas que, en cualquier caso, puede ser libremente modificada mediante los comandos disponibles:
- | Agregar / Eliminar: ayudan a componer la lista de los idiomas de consulta permitiendo, respectivamente, añadir un nuevo Idioma (mediante la ventana abierta Configurar Idioma) o cancelar uno ya introducido.
- | Subir / Bajar: permiten modificar el orden de los Idiomas ya presentes en la lista, desplazando hacia arriba o hacia la bajo el Idioma seleccionado.
- | Valor: permite predisponer el Idioma seleccionado dentro de la Lista Idiomas como "predeterminado". Se debe configurar como "predeterminado" el Idioma del Sitio al cual los usuarios deben acceder inmediatamente, antes aún de efectuar la elección del Idioma de consulta preferido. El Sitio en el Idioma predetermindo es el único que presenta la Página de Bienvenida (para más información, ver Cómo crear un Sitio multi-idioma mediante la Página de Bienvenida).
- | Modificar: permite abrir la ventana Configurar Idioma para modificar los parámetros predispuestos del Idioma seleccionado de entre los ya introducidos en la Lista.

La ventana Configurar Idioma presenta las siguientes opciones:
- | Nombre de idioma que debe mostrarse: permite introducir el nombre del Idioma que se desea poner a disposición. Haciendo clic en la flecha junto al campo es posible abrir un menú desplegable con una lista de Idiomas y seleccionar aquel que se desea insertar: en cualquier caso, en alternativa, es posible escribir directamente el nombre del Idioma.
- | Archivo Imagen para el Idioma (ej: bandera): permite importar el archivo gráfico que utilizar para crear el Botón asociado al Idioma. haciendo clic en [image] se puede seleccionar el archivo .JPG, .GIF o .PNG que utilizar, por ejemplo, para crear un Botón con la Imagen de la bandera relativa al Idioma. Si no se asocia ninguna Imagen, en lugar de un Botón gráfico se creará automáticamente un enlace textual utilizando el Nombre del Idioma como texto y predisponiendo el color que mejor contrasta respeto al de fondo de la Página.
- | Carpeta en Servidor o URL del Sitio para este Idioma: permite especificar el nombre de la sub-carpeta en el Servidor dentro de la cual se publicará el Sitio relativo al Idioma sobre el que se está trabajando, por ejemplo "En" para el Sitio en Idioma Inglés. En alternativa, también es possible escribir la URL completa del Sitio que se desea conectar, por ejemplo" http://www.misitio.com/en/index.html". En el caso que se esté trabajando en el Idioma predispuesto como Predeterminado no es posible especificar un URL para la publicación sino sólo una sub-carpeta en Servidor.
- | Mostrar este idioma pero informar de que todavía no está disponible: activando esta opción es posible prever un Idioma de consulta para el que aún no se ha creado y/o publicado el Sitio. Haciendo clic en el Botón (o el enlace textual) relativo a dicho Idioma, el usuario verá automáticamente un mensaje de aviso de que el Idioma solicitado aún no está disponible.

Por último, está disponible la opción:

-

Efectuar enlace en una nueva ventana: activando esta opción, el Sitio es abierto en una nueva ventana del Navegador, distinta de la ya abierta en la Página de Bienvenida.

Aunque en la ventana relativa a la Página de Bienvenida se habla explícitamente de Idiomas, es posible aprovechar esta gestión para permitir al usuario elegir no sólo entre Idiomas de consulta distintos sino, más genéricamente, entre distintas versiones de un mismo Sitio. Por ejemplo, se podría predisponer la elección entre "Versión HTML / Versión Flash" o entre "Versión apta para menores / Versión sólo para adultos".

Temas relacionados:
- | Ajustes avanzados
- | Cómo manejar los Idiomas para los textos insertados en automático


Mensaje Publicitario

Esta ventana presenta los comandos a través de los cuales es posible proceder a la predisposición de un Mensaje Publicitario en la Página de inicio o en todas las Páginas del sitio.

El Mensaje Publicitario puede ser creado como una Imagen o una Animación Flash, visualizada en una posición determinada de la Página, en la que se predispone un enlace a una Landing Page (o Página de destino). Obviamente, la Landing Page, que no es otra cosa que una Página interna del Sitio, deberá ser estudiada para conseguir convencer al usuario a terminar la acción deseada: compilar un formulario, efectuar una compra, etc.

Consejos Práticos

Si se desea introducir un Mensaje Publicitario es preciso, en primer lugar, activar la opción Mostrar el Mensaje Publicitario.

Es posible elegir el Tipo de mensaje que predisponer, seleccionando una de las siguientes opciones:

 Mostrar anuncios en la esquina superior derecha: corresponde al efecto que es indicado generalmente como PagePeel en el que, colocando el ratón en el ángulo superior derecho de la Página, se puede "hojear" descubriendo el mensaje publicitario que está debajo.

Mostrar anuncios en un cuadro: el mensaje publicitario es introducido en un recuadro, visualizado en una posición especifica de la ventana del Browser, en sobreposición respecto a los contenidos de la Página.

Mostrar anuncios en una barra horizontal: el mensaje publicitario es propuesto mediante una barra horizontal visualizada en la parte superior de la ventana del Browser, antes del contenido real de la Página, o en el fondo de la ventana del Browser, en sobreposición respecto a los contenidos de la página.

Para cualquier Tipo de mensaje seleccionado, es posible utilizar la opción del recuadro Ajustes:

-

Archivo de imagen/Animación: permite especificar al archivo gráfico (en formato .JPG, .GIF, .PNG) o el archivo de la Animación Flash (en formato .SWF) que contiene el Mensaje Publicitario que se desea proponer.

Para el Mensaje en el ángulo superior derecho las demás opciones disponibles son:
- | Estilo: permite elegir, además del clásico efecto del ángulo de la página doblado (PagePeel), también entre otras animaciones a tema. En cualquier caso, el funcionamiento del efecto permanece inalterado: al pasar el ratón sobre la animación, el usuario abre el Mensaje publicitario.
- | Ancho/Altura: permite especificar el valor en pixel que deben tener la anchura y la altura del área destinada a visualizar el Mensaje publicitario.

Para el Mensaje en recuadro las demás opciones disponibles son:
- | Posición: permite establecer la posición en la que aparecerá visualizado el Mensaje Publicitario dentro de la ventana del Browser. Es posible colocarlo en el Centro, Arriba a la izquierda, Arriba a la derecha, Abajo a la izquierda y Abajo a la Derecha.
- | Efecto: permite predisponer un efecto de visualización eligiendo entre Disolver, Aparición por arriba, Aparición pora abajo, Aparición por la izquierda, Aparición por la derecha.
- | Mostrar este mensaje una sola vez: si está activada, esta opción hace que el Mensaje publicitario sea visualizado sólo una vez, en la primera apertura de una Página del sitio. Abriendo una nueva sesión de navegación, el Mensaje publicitario será propuesto de nuevo.

Por último, para el Mensaje en barra horizontal las demás opciones disponibles son:
- | Posición: permite definir si la barra con el Mensaje publicitario debe ser visualizada arriba, antes de los contenidos de la página, o en el fondo, en sobreposición sobre la parte final de la Página.
- | Color Fondo: permite definir, mediante la ventana Color abierta, el color para el fondo de la barra horizontal que contiene el Mensaje publicitario.
- | Mostrar este mensaje una sola vez: si está activada, esta opción hace que el Mensaje publicitario sea visualizado sólo una vez, en la primera apertura de una Página del sitio. Abriendo una nueva sesión de navegación, el Mensaje publicitario será propuesto de nuevo.

Los elementos presentes en el recuadro Opciones, comunes a todos los tipos de mensaje, son:

-

Sonido al entrar: permite predisponer el archivo de sonido (en formato .MP3) que debe ser reproducido durante la visualización del Mensaje publicitario.

-

Página conectada: permite especificar la página (Landing Page) que debe ser vinculada al Mensaje publicitario, seleccionándola directamente del Mapa del sitio abierto mediante el botón [image].

¿Qué es una Landing page?
La Landing Page es una página destinada a acoger a un visitante y aparece porque está conectada, por ejemplo, a un enlace o a un banner publicitario. Como sugiere el propio nombre, es la página en la que "aterriza" el usuario y debe ser construida de manera que éste pueda encontrar enseguida las informaciones deseadas, evitándole la navegación en el sitio para buscarlas.
La mecanismo puede ser eficazmente explicado con un ejemplo: publicamos un banner para hacer publicidad a un producto. Las informaciones dirigidas desde el banner son pocas y esenciales pero podemos predisponer un enlace para guiar al usuario interesado a nuestro sitio. En este caso, es perjudicial enlazar directamente la Página de inicio de nuestro sitio: es demasiado genérica y obligaría al usuario a emprender una navegación interna antes de encontrar las informaciones necesarias sobre el producto y sobre cómo proceder a la compra. El riesgo es perder enseguida un cliente potencial. En cambio, la mejor solución es construir una Página especial en la que presentar, con una disposición simple y funcional, todas las informaciones que el usuario se espera encontrar en el producto anunciado en el banner, incluídas las instrucciones para proceder con la compra. Muy a menudo una Página de este tipo debe ser construida a posta pero, si está bien hecha, tiene la ventaja de guiar hacia el objetivo deseado (en el ejemplo, la compra de un producto) al usuario atraído por nuestro mensaje publicitario.

Por último, en el recuadro Modo de visualización están disponibles las opciones:

-

Mostrar sólo en la Página de inicio / Mostrar en todas las páginas del sitio: permiten definir dónde debe ser visualizado el Mensaje publicitario, si sólo en la Página de inicio o bien en todas las Páginas del sitio.

Temas relacionados:

-

Ajustes avanzados


Blog

Esta ventana propone las herramientas y las opciones necesarias para crear un Blog y gestionar los comentarios que pueden dejar los usuarios como respuesta a las Noticias publicadas.

Un Blog es una especie de diario en red en el que el autor cuenta aquello de lo que desea hablar mediante una serie de Noticias (o Post) publicados con frecuencia y regularidad variable.

Una vez publicado, el Blog creado con WebSite X5 representa una sección independiente del Sitio principal y en el Mapa es añadido automáticamente dentro de la carpeta Páginas especiales (ver, Creación del mapa). Si se desidera insertar la opción "Blog" dentro del menú de navegación, es preciso crear un Alias de la Página especial seleccionándolo y arrastrándolo al interior de la carpeta Menú.

Siendo parte integrante del sitio Web, el Blog comparte con él la gráfica, retomando automáticamente la plantilla gráfica predispuesta.

El Blog creado es publicado con la URL www.misitio.es/blog donde www.misitio.es es la URL del sitio al que está conectado.

En la página principal del Blog es visualizada la lista de todas las Noticias (o Post) publicadas, dispuestas en orden cronológico empezando por la más reciente.
Para todas las Noticias se presenta un título, la indicación de autor, categoría, fecha y hora de pubblicazione, la descripción breve y el enlace "Leer todo". Sólo para la primera Noticia, en lugar de la descripción breve, se propone el contenido completo.
El enlace "Leer todo" lleva a una página totalmente dedicada a un único post: en este caso aparece todo el texto de la noticia, seguido de la lista de los comentarios ya publicados y del formulario que los lectores pueden utilizar para enviar un nuevo comentario.

Más allá de sus contenidos, todas las Páginas del Blog presentan una estructura análoga que prevé una columna colocada en la derecha, dedicada a la presentación de herramientas como: la sección con las Noticias recientes, el Archivo por mes o por categorías, las Nubes. En base a las propias exigencias, es posible personalizar esta columna y decidir qué herramientas poner a disposición y en qué orden presentarlas.

Por último, como ya se ha dicho, una de las peculiaridades de los Blog es la de permitir dejar un comentario a quien lee las noticias: de este modo, partiendo de una idea presentada por el Post publicado, se puede desarrollar una discusión entre quién escribe y aquellos que leen. Para evitar que queden publicados también comentarios no deseados, por ofensivos o no inherenti al tema, es necesario poderlos gestionar: para hacerlo, WebSite X5 pone a disposición un especial Panel de control en línea.

Consejos Práticos

Para crear un Blog basta predisponer algunos parámetros generales y crear la lista de las noticias que se desea distribuir.

Los comandos necesarios para configurar el Blog y proceder a la creación de las noticias se recogen en tres secciones:
- | Sección Noticias
- | Sección Diseño
- | Sección Comentarios

Una vez predispuesto, será necesario mantener vivo el interés de los lectores proponiendo nuevos post con una cierta regularidad y frecuencia. A tal propósito, en fase de exportación será posible publicar sólo las actualizaciones relativas a los Blog gracias a la opción Exportar solamente Blog y RSS disponible en la ventana Exportación del sitio a Internet.

Temas relacionados:
- | Ajustes avanzados
- | Panel de control en línea


Blog| Sección Noticias

Mediante los comandos propuestos en la Sección Noticias de la ventana Blog es posible definir algunos parámetros generales y proceder a la composición de la lista de las Noticias (o Post) que deberán ser publicadas en el Blog.

En el recuadro Ajustes generales están incluídas las siguientes opciones:
- | Título: en este campo se puede escribir el título que se desea dar al Blog. Este título será visualizado en la Barra del título del Browser y es, obviamente, un parámetro importante para permitir localizar correctamente el Blog a usuarios y Motores de búsqueda. Si no se especifica ningún título para el Blog, se toma automáticamente el título asociado al Sitio mediante la opción correspondiente de la ventana Ajustes generales| Sección General.
- | Descripción: en este campo se puede escribir una breve descripción del Blog. Se recomienda que el contenido de la descripción sea conciso, eficaz y significativo para el Blog al que hace referencia: En efecto, esta descripción será utilizada en el código HTML como contenido del metatag <description> y será analizada por los spider de los Motores de búsqueda. También en este caso, si no se especifica ninguna descripción para el Blog, se toma automáticamente la descripción asociada al sitio mediante la opción correspondiente de la ventana Ajustes generales| Sección General.
- | Crear una sindicación web (RSS) que incluya el contenido del blog: esta opción, activa por defecto, hace que se cree automáticamente una Sindicación web (RSS) con todas las Noticias del Blog.

En cambio, en el recuadro Lista de artículos están disponibles una Tabla resumen que contiene el Título, el Autor, la Categoría de pertenencia y la Fecha de efectuación de todos los Post ya insertados y los comandos necesarios para crear la lista de las Noticias:
- | Agregar: permite abrir la ventana Predisposiciones artículo para proceder a la inserción de una nueva Noticia.
- | Eliminar: permite eliminar la Noticia seleccionada de entre las presentes en la Lista de artículos.
- | Modificar: permite abrir la ventana Predisposiciones artículo para modificar la noticia seleccionada de entre las presentes en la Lista de artículos.

La ventana Predisposiciones artículo abierta por el comando Agregar o por el comando Modificar se presenta como en la imagen siguiente y, como se ve, está dividida en dos secciones:
- | Sección General
- | Sección Avanzado

Los comandos presentes en la sección General de la ventana Predisposiciones artículo son:
- | Título: permite especificar el título de la Noticia.
- | Publicado el: permite predisponer la fecha de publicación de la Noticia seleccionándola mediante un calendario especial.
- | Autor: permite especificar el autor de la Noticia. En este campo es posible escribir directamente el nombre del autor, o bien abrir la lista desplegable y seleccionar un nombre de entre los ya insertados anteriormente.
- | Categoría: permite especificar la categoría en la que entra la Noticia. Como para el campo Autor, es posible escribir el nombre de una nueva Categoría, o seleccionar una de las Categorías ya insertadas anteriormente.
- | Etiqueta: permite especificar una lista de etiquetas (tag), o sea de breves descripciones de conceptos clave asociados a la Noticia. Es posible asociar más de una Etiqueta para cada Artículo, escribiéndolas una tras otra, separadas por una coma (por ejemplo: " etiqueta1, etiqueta2, etiqueta3., ...").
- | Contenido: permite elaborar la Noticia mediante un editor análogo al disponible para el Objeto Texto.
- | Descripción breve: permite especificar una breve descripción que asociar a la Noticia.

En cambio, los comandos presentes en la sección Avanzado de la ventana Predisposiciones artículo son:

-

Audio/Vídeo conectado: permite especificar un archivo audio (en formato .MP3, .WMA, .WAV, .MID, .AIF, .M4A) o un archivo vídeo (en formato .MP4, .FLV, .AVI, .WMV, .MPG, .MOV) que asociar a la Noticia. Utilizando esta opción, se crea automáticamente un enlace al archivo audio/vídeo visualizado en fondo a la Noticia.

¿Puedo introducir un vídeo en un post de modo que sea inmediatamente visible?

Es posible hacer de modo que el vídeo sea visualizado directamente en una Noticia, insertando manualmente el código HTML necesario en el editor de texto durante la composición del post mismo.
Por ejemplo, es posible copiar el código de un vídeo YouTube tal como se suministra en el portal y pegarlo al interior del post.

-

Fuentes de la noticia: permite elaborar la lista de las fuentes utilizadas para efectuar la noticia mediante los siguientes comandos:
- | Agregar / Eliminar: permiten, respectivamente, agregar una nueva fuente o eliminar una seleccionada. Basta hacer clic una segunda vez en una opción seleccionada para poderla modificar.
- | Subir / Bajar: permiten ordenar la lista, desplazando hacia arriba o hacia la bajo la opción seleccionada.
- | Modificar: permite modificar la opción seleccionada.
Para insertar correctamente una fuente es preciso escribir el nombre del Sitio seguido de la URL incluída entre los caracteres < > (por ejemplo: "WebSite X5 <http://www.websitex5.com>"): como fuente aparecerá sólo el texto y la URL será utilizada para crear el enlace asociado al mismo.

-

No habilitar los comentarios para este artículo: activando esta opción se impide a los usuarios dejar comentarios para la Noticia en curso.

Temas relacionados:

-

Blog


Blog| Sección Diseño

Mediante los comandos propuestos en la Sección Diseño de la ventana Blog es posible proceder a la definición de algunos aspectos gráficos del Blog.

En el recuadro General están disponibles las siguientes opciones:

-

Mostrar botón "AddThis" para compartir su sitio web en las redes sociales: activando esta opción, debajo de cada post del Blog se inserta automáticamente el botón "AddThis". Haciendo clic en este botón, aparece en el lector un submenú con una lista de las Social Network más conocidas: si se dispone de un perfil en uno de estos circuitos, se podra seleccionar y compartir el enlace al Post con los propios contactos.

-

Tipo de botón: permite definir el aspecto del botón "AddThis" eligiendo entre las gráficas propuestas en el menu desplegable.

-

Cuenta 'AddThis' permite, si se dispone de una Cuenta 'AddThis' (añadir), especificarla. Tener una cuenta permite visualizar algunas estadísticas sobre el uso hecho por los lectores del servicio AddThis.

Para más información sobre el servicio AddThis y para obtener una cuenta, hacer clic en el botón [image] y acceder al sitio oficial: www.addthis.com.

En cambio, en el recuadro Bloques laterales están disponibles una Tabla resumen que contiene el Título, el Tipo y la Anchura de todos los Bloques de contenido insertados en la barra lateral y los comandos necesarios para crear la lista de dichos Bloques:
- | Agregar: permite abrir la ventana Bloque lateral para proceder a la inserción de un nuevo Bloque.
- | Duplicar: permite crear una copia del Bloque seleccionado entre los ya insertados.
- | Eliminar: permite eliminar el Bloque seleccionado de entre los presentes en la lista Bloques laterales.
- | Subir / Bajar: permiten, respectivamente, desplazar el Bloque seleccionado a antes o después del Bloque precedente o sucesivo de entre los insertados ya en la lista Bloques laterales.
- | Modificar: permite abrir la ventana Bloque lateral para modificar el Bloque seleccionado entre los presentes en la lista Bloques laterales.

La ventana Bloque lateral abierta con el comando Agregar y con el comando Modificar permite definir efectivamente los Bloques de contenido que se desea poner a disposición en la columna lateral de todas las Páginas del Blog. Esta ventana presenta dos secciones:
- | Sección General
- | Sección Estilo

Temas relacionados:

-

Blog


Blog| Sección Diseño| Bloques laterales| General

Los comandos presentes en la sección General de la ventana Bloques laterales (ver,Blog| Sección Diseño) permiten crear la lista de los Bloques que deberán completar la Página del Blog.

Los tipos de Bloque entre los que es posible elegir son:

 Noticias recientes: Bloque en el que aparecen todos los Post más recientes publicados en el Blog. Haciendo clic en el título se accede a la página donde es posible leer la noticia.

Categorías: Bloque en el que se ve la lista de todas las Categorías en que están organizados los Post del Blog. Haciendo clic en una Categoría se ve la lista de las Noticias insertadas.

Noticias mensuales: Bloque en el que aparece lista de los Post publicados, organizados por mes.

Nubes: Bloque en el que aparece la lista de todas las Categorías o de todas Etiquetas asociadas a las Noticias publicadas. En este caso, los nombres de las Categorías o las Etiquetas son visualizados con tamaños diferentes en función del número de Post conectados: cuanto mayor es el número de los Post conectados, mayor es el tamaño de las letras. Haciendo clic en una opción (Categoría o Etiqueta) se visualiza la lista de las Noticias relacionadas con ella.

Blogs amigos: Bloque para la visualización de la lista de los Blogs amigos, es decir de otros sitios Web o Blog que se desea conectar para sugerir su visita a los propios lectores.

Facebook: Bloque que aprovecha la Social Plug-in "Like Box" de Facebook para permitir a los usuarios:
- | ver a cuántas personas y/o a cuántos de los propios amigos les gusta la Página Facebook propuesta;
- | leer los Post recientes publicados en la Página Facebook propuesta;
- | decir que la Página Facebook propuesta gusta sin tener que visitarla por fuerza.

Anuncios de Google AdSense: Bloque para la visualización de las mensajes publicitarios proporcionados por el circuito Google AdSense.

Código HTML: Bloque completamente personalizable que puede ser utilizado para insertar cualquier función no prevista en automático por el programa.

En función del tipo de Bloque seleccionado, se presentan distintas opciones sobre las que se puede actuar.

Las opciones comunes a todos los Bloques son:
- | Título: permite insertar el título que asociar y visualizar para el Bloque.
- | Ancho: permite definir la anchura en pixel del Bloque.

Además de las opciones comunes, para cada tipo de Bloque se añaden las siguientes opciones específicas:
Noticias recientes / Categorías/
Noticias mensuales:

-

Número máximo de elementos: permite especificar el número máximo de elementos que ver dentro del Bloque.
Nubes:

-

Mostrar categorías en una nube / Mostrar etiquetas en una nube: permiten elegir si en el Bloque Nubes se deben presentar las Categorías, o bien, las Etiquetas utilizadas para las Noticias ya publicadas.
Blogs amigos:

-

Lista de blogs amigos: permite elaborar la lista de los Blogs amigos mediante los siguientes comandos:
- | Agregar / Eliminar: permiten, respectivamente, agregar un nuevo Sitio amigo o eliminar uno seleccionado. Basta hacer clic una segunda vez en una opción seleccionada para poderla modificar.
- | Subir / Bajar: permiten ordenar la lista, desplazando hacia arriba o hacia la bajo la opción seleccionada.
- | Editar: permite modificar la opción seleccionada.
Para insertar correctamente un Sitio amigo es preciso escribir el nombre del sitio seguido de la URL incluída entre los caracteres < > (por ejemplo: "WebSite X5 <http://www.websitex5.com>"): como Sitio amigo aparecerá sólo el texto y la URL será utilizada para crear el enlace asociado a la misma.
Facebook:

-

URL de Facebook: permite especificar la URL de la página Facebook que se desea proponer.

-

Color Fondo: permite predisponer un Fondo Claro u Oscuro para el Bloque.

-

Altura: permite definir la altura en pixel del Bloque.

-

Mostrar Fotos amigos: activando esta opción, en el Bloque aparecen también la fotos de los perfiles de los amigos (es decir, de las conexiones).

-

Mostrar últimos post: activando esta opción, en el Bloque aparecen automáticamente las últimas publicaciones introducidas en el Muro de la página Facebook propuesta.

-

Mostrar encabezado de Facebook: activando esta opción, en el Bloque aparece un encabezado de Facebook.
Anuncios de Google AdSense:

-

Código HTML de Google AdSense: permite introducir el código HTML proporcionado por Google AdSense para la visualización de un bloque de mensajes publicitarios.
Código HTML:

-

Código HTML: permite introducir el código HTML para crear un Bloque completamente personalizado.

Temas relacionados:

-

Blog| Sección Diseño


Blog| Sección Diseño| Bloques laterales| Estilo

Los comandos presentes en la sección Estilo de la ventana Bloques laterales (ver, Blog| Sección Estilo) permiten definir el aspecto gráfico de los Bloques de contenido que deberán completar la Página del Blog.

Las opciones presentes el recuadro Texto son:
- | Fuente: permite especificar, mediante la ventana abierta, el Tipo de carácter, el Estilo y el tamaño del texto.
- | Color Texto: permite definir, mediante la ventana Color abierta, el color para los textos del Bloque.
- | Margen horizontal / Margen vertical: el margen es el espacio entre el borde del Bloque y el texto contenido. Así pues, mediante estas opciones es posible definir cuánto espacio debe haber horizontal y/o verticalmente alrededor del texto dentro del Bloque.

En el recuadro Fondo, en cambio, están disponibles las siguientes opciones:
- | Color Fondo / Color Borde permiten definir, mediante la ventana Color abierta, el color para el fondo y para la borde del Bloque.
- | Espesor Borde: permite predisponer el grosor del borde del Bloque.
- | Archivo imagen: permite especificar una imagen (.jpg, .gif o .png) que insertar como fondo del Bloque.
- | Repetir: permite especificar si la imagen insertada como fondo del Bloque debe ser repetida o no. La imagen puede repetirse de forma horizontal, vertical o en ambas direcciones, con el propósito de llenar el espacio disponible.
- | Alineación: permite especificar cómo se debe alinear la imagen insertada como fondo respecto al Bloque.

Temas relacionados:

-

Blog| Sección Estilo


Blog| Sección Comentarios

A través de los comandos propuestos en la Sección Comentarios de la ventana Blog es posible gestionar la inserción de los comentarios dejados por los visitantes como feedback a las Noticias publicadas en el Blog.

Las opciones disponibles en la sección General son:

-

Permite la inserción de Comentarios para las Noticias del Blog: activando esta opción se permite a los usuarios dejar comentarios a las Noticias publicadas en el Blog.

-

Carpeta de Servidor con acceso de escritura: en este campo es necesario especificar la ruta en Servidor de la carpeta con acceso en escritura, es decir de la carpeta dentro de la cual está habilitada la escritura por parte del código PHP.

Normalmente, los Provider permiten el acceso en escritura para cada carpeta del Servidor: en estos casos no es necesario especificar ninguna ruta para la carpeta pública. Al contrario, para conocer la ruta completa de la carpeta pública es necesario ponerse en contacto con el propio Provider del espacio Web.
Mediante la sección WebSite Test del Panel de control online es posible verificar si la carpeta con acceso en escritura especificada existe y, en caso afirmativo, si permite efectivamente la escritura de los datos.

-

Activa el control anti-spam "Captcha": permite agregar al final del formulario para la inserción de un comentario, el control anti-spam del Captcha. Es decir, se introduce la imagen de algunas letras visualizadas de manera deformada en un fondo confuso: el usuario debe copiar correctamente las letras en un especial Campo para poder enviar el comentario.

El recuadro Control de los comentarios pone a disposición, en cambio, las siguientes opciones:
- | Correo electrónico para envío de aviso recepción Comentarios: permite especificar la dirección de correo electrónico en la que se desea recibir el aviso de recepción de comentarios a las Noticias publicadas en el Blog.
- | Visualizar enseguida los commentarios insertados / Visualizar commentarios después de aprobación desde panel de control: permiten elegir si los comentarios dejados por los visitantes pueden ser visualizados enseguida en las Páginas del Blog, o bien si antes deben ser aprobados mediante los comandos de la sección Blog del Panel de control en línea.

Temas relacionados:
- | Blog
- | Panel de control en línea
- | Cómo gestionar los comentarios del Blog desde el Panel de control


Sindicación web (Feed RSS)

Esta ventana presenta las herramientas y las opciones necesarias para crear la sindicación web, uno de los formatos más conocidos para la distribución de contenidos Web.

La Sindicación web (RSS) es una herramienta muy versátil que se presta para divulgar noticias, imágenes o vídeos: puede ser útil cuando se tiene muchas noticias que proponer con cierta frecuencia, o bien, cuando se desea señalar acontecimientos, las actualizaciones efectuadas dentro de un Sitio, los nuevos post o los comentarios publicados en un Blog.

Suscribiendo la Sindicación web (RSS) asociada al Sitio Web, los usuarios podrán ser constantemente informados y recibir/leer las noticias directamente a través de su programa news aggregator.

Consejos Práticos

Para crear una Sindicación web (RSS) basta predisponer algunos parámetros generales y crear la lista de las noticias que se desea distribuir.

En el recuadro Lista de artículos está disponible una Tabla resumen que contiene el Título y la Fecha de entrega de todas las noticias ya insertadas y los comandos necesarios para crear la lista de las Noticias:
- | Agregar: permite abrir la ventana Predisposiciones artículo para proceder a la inserción de una nueva Noticia.
- | Eliminar: permite eliminar la Noticia seleccionada de entre las presentes en la Lista de artículos .
- | Modificar: permite abrir la ventana Predisposiciones artículo para modificar la noticia seleccionada de entre las presentes en la Lista de artículos.

La ventana Predisposiciones artículo abierta por el comando Agregar o por el comando Modificar se presenta como en la imagen siguiente.

- | Título: permite especificar el título de la Noticia.
- | Publicado el: permite predisponer la fecha de pubblicazione de la Noticia seleccionándola de un calendario.
- | Contenido: permite elaborar la Noticia mediante un editor análogo al disponible para el Objeto Texto.
- | Página conectada: permite accedere al Mapa del sitio para definir qué Página debe ser enlazada a la Noticia.

Además de crear la lista de noticias, es necesario definir los siguientes parámetros incluídos en el recuadro Ajustes generales para la Sindicación web (RSS):
- | Título: requiere especificar el título de la Sindicación web (RSS) conectado al sitio Web. Este parámetro es obligatorio.
- | Imagen: permite especificar la imagen (archivo en formato .JPG, .GIF, .PNG) que asociar a la Sindicación web (RSS); esta Imagen (normalmente el logotipo de la empresa o del Sitio Web) será visualizada por el programa news aggregator.
- | Descripción: requiere especificar una descripción de la Sindicación web (RSS) conectada al sitio Web. También este parámetro es obligatorio.

 Las sindicaciones web (RSS) funcionarán solamente cuando el Sitio será publicado online.

Temas relacionados:

-

Ajustes avanzados


Gestión accesos

Esta ventana presenta los comandos a través de los que es posible efectuar la creación y gestión de los perfiles Usuario que pueden tener acceso al Área reservada del Sitio, o sea, a las Páginas que durante la fase de Creación de mapa han sido definidas Protegidas.

Consejos Práticos

En el recuadro Lista usuarios y Grupos con acceso a las Páginas protegidas está disponible una Tabla resumen que contiene los Grupos/Usuarios ya insertados además del Login y las Notas asignadas a cada usuario.

Al lado de la tabla están presentes los comandos útiles para proceder a la creación de la lista de los Grupos y de los Usuarios a los que se desea permitir el acceso a las Páginas protegidas del sitio:

-

Nuevo grupo: permite insertar un nuevo grupo, para poder organizar los Usuarios en categorías homogéneas más simples de gestionar. Los grupos no tienen predisposiciones particulares: son simples "Contenedores" y por eso son insertados directamente en la Tabla resumen. Basta hacer doble clic en correspondencia de un Grupo ya insertado para darle un nuevo nombre.
Siempre con el fin de organizar lo mejor posible los accesos por parte de los Usuarios, también es posible crear sub-grupos: no hay límites particulares al número de Ggrupos o de sub Grupos que se pueden utilizar.
Por defecto están presentes dos Grupos: Administradores y Usuarios. El grupo Administradores es el formato por los administradores del Sitio que tienen acceso automáticamente a todas las Páginas protegidas del Sitio.

Mediante su Login y Contraseña, todos los Usuarios del Grupo Administradores pueden acceder al Panel de control online (disponible en la URL www.misitio.es/admin donde www.misitio.es es la URL del sitio) mediante la cual es posible gestionar los comentarios a los Post del Blog, los mensajes del Guestbook (ver Objeto HTML y Widgets) y visualizar informaciones de diagnóstico o sobre la optimización del Sitio para los Motores de búsqueda.

-

Nuevo usuario: permite activar la ventana Nuevo usuario para proceder a la inserción de un nuevo Usuario, con las relativas credenciales de acceso, dentro del Grupo seleccionado.

-

Eliminar: permite eliminar el Grupo o el Usuario seleccionado de entre los ya insertados. No es posible eliminar el Grupo Administradores ni el Usuario Admin en él insertado, previstos por defecto.

-

Modificar: permite activar la ventana Nuevo usuario para modificar las predisposiciones del Usuario seleccionado.

-

Crear un alias: permite crear un Alias para el Usuario seleccionado. Esta opción es útil cuando un mismo Usuario debe ser insertado en Grupos distintos para tener acceso a distintas Páginas protegidas y, por este motivo, no está activada para los Usuarios del Grupo Administradores (que tienen ya acceso automático a todas las Páginas protegidas). El Alias queda vinculado al Usuario de modo que cualquier modificación aportada a uno es automáticamente aplicada también al otro. Un modo alternativo y rápido de crear un Alias es seleccionar un Usuario, arrastrarlo y, antes de soltarlo dentro de un segundo Grupo, pulsar la tecla CTRL.

La ventana Nuevo usuario abierta con el comando Nuevo usuario o con el comando Modificar se presenta como en la imagen siguiente.

Como se ve, los comandos disponibles para crear un nuevo Usuario son:

-

Nombre y apellido: permite especificar el nombre del Usuario del que se desea habilitar las credenciales para permitirle el acceso a determinadas Páginas protegidas del Sitio.

-

Nombre usuario / Contraseña: permiten especificar el Nombre del usuario y la Contraseña que el Usuario deberá utilizar para poder visualizar las Páginas protegidas para las que tiene habilitado el acceso. De modo automático se propone una Contraseña composta por 8 caracteres (letras y números) elegidos con un procedimiento random: En cualquier caso, dicha Contraseña puede ser libremente modificada.

-

Página de entrada: permite acceder al Mapa del sitio para especificar qué Página debe ser visualizada después que el Usuario ha insertado las propias credenciales de acceso.

-

Nota: permite introducir algunas notas facultativas sobre el Usuario.

-

Fecha de registro: permite introducir, mediante la especial ventana Calendario, la fecha en la que se ha producido la inscripción del Usuario.

Las informaciones relativas a las opciones Notas y Fecha de Registro no son incluídas en el código del Sitio Web realizado: sirven únicamente para permitir una mejor gestión de los Usuarios por parte del Administrador del sitio.

Además de la Tabla resumen, en el recuadro Ajustes para la Página de acceso del Área reservada están disponibles las siguientes opciones:

-

Mensaje de bienvenida: permite introducir el texto que debe ser visualizado cuanto un Usuario intenta acceder a una Página protegida sin haber efectuado antes el login. En estos casos, el usuario es dirigido a una página, creada automáticamente por el Programa, que se compone de los siguientes elementos:
- | el texto de bienvenida aquí especificado;
- | los campos en en que se pide introducir Nombre usuario y Contraseña;
- | en el caso que se especifique la Página para la solicitud de inscripción (ver opción sucesiva), el botón Inscripción.

-

Página de registro: permite acceder al Mapa del sitio para especificar qué Página debe ser visualizada cuando el usuario hace clic en el botón Inscripción para solicitar el Nombre usuario y la Contraseña necesarios para acceder a las Páginas protegidas.

Después de haber creado los Usuarios con las relativas credenciales de acceso y de haberlos organizado en Grupos, es posible regresar al Paso 2 - Creación del mapa para definir las páginas que deben ser Protegidas y establecer desde qué Grupos/Usuarios podrá ser visualizada cada Página protegida.

 Cuando se prueba en local el funcionamiento del sitio creado, una ventana de aviso advierte de que las Páginas protegidas son visualizadas sin la solicitud de acceso. Las Páginas protegidas son activadas sólo con la publicación del Sitio en Servidor.

Para el correcto funcionamiento del Área reservada es necesario que el Servidor sobre el cual será publicado el sitio, soporte el lenguaje de programación PHP y las sesiones. Mediante la sección Prueba WebSite del Panel de control en línea es posible tener estas informaciones de diagnóstico sobre el Servidor.

Temas relacionados:
- | Ajustes avanzados
- | Panel de control
- | Creación del mapa


Carrito de la compra de comercio electrónico

Esta ventana propone las herramientas y las opciones necesarias para efectuar la creación y gestión de un carrito de compras electrónico mediante el cual efectuar la venta en línea de los Productos ofrecidos en el sitio Web.

Consejos Práticos

Para crear un Carrito de la compra de comercio electrónico es necesario, en primer lugar, definir el catálogo de los Productos disponibles, organizándolos en categorías y sub-categorías homogéneas. Obviamente, para cada producto es preciso introducir una serie de informaciones indispensables como el nombre, la descripción y el precio, pero también es posible ir más allá, asociando una o más imágenes y predisponiendo variantes (de talla, de color, de modelo, etc.). Una vez creado el catálogo, es preciso definir los métodos de envío y de pago que se desea activar y predisponer el formulario de pedido, configurando también los correos electrónicos que son enviados desde el carro, tanto al gestor del sitio, como a quien hace el pedido.

Concretamente, las distintas opciones para definir los elementos y el funcionamiento del Carrito de la compra se presentan en las siguientes secciones:
- | Sección Productos
- | Sección Pago
- | Sección Detalles del cliente
- | Sección Opciones

Una vez creado el Carrito de la compra de comercio electrónico es preciso insertar en el Sitio las informaciones y los enlaces necesarios para que los usuarios puedan visualizar las informaciones sobre los Productos y efectuar la compra. Para hacer esto es posible proceder de diferentes modos:
1. | Crear Páginas específicas en las que se presenten los Productos del modo que se crea más oportuno (con imágenes, textos, tablas, etc.) e insertar en ésas el botón "Comprar". En este caso, el botón "Comprar" puede ser creado mediante el enlace Agregar al carro (ver, Estilo de enlaces).
2. | Crear páginas en las que se presenten los productos mediante especiales fichas que tienen ya el botón "Comprar". En este caso es preciso utilizar el Objeto de lista de productos.

 Cuando se prueba el funcionamiento del Sitio creato en local, una ventana de aviso advierte que el pedido no será enviado y es efectuado el redirect automático a la Página de confirmación del pedido. El Carrito de comercio electrónico funciona plenamente sólo con la publicación del Sitio en Servidor.

Para el correcto funcionamiento del Carrito de comercio electrónico, es necesario que el Servidorr en el que será publicado el Sitio soporte el lenguaje PHP y que esté activo el comando MAIL. Mediante la sección Prueba WebSite del Panel de control en línea es posible tener estas informaciones de diagnóstico en el Servidor.

Si se verifican problemas en el envío de los correos, es probable que el Servidor utilizado no esté configurado de modo estándar. En estos casos, se recomienda intentar modificar las predisposiciones relativas al script utilizado para el envío de los correos electrónicos mediante la opción correspondiente presente en la ventana Preferencias. Para ulteriores informaciones al respecto, ponerse en contanto con el propio Proveedor de espacio Web.

Temas relacionados:
- | Ajustes avanzados
- | Ventana Enlace
- | Objeto de lista de productos


Carrito de la compra de comercio electrónico | Sección Productos

Mediante las opciones propuestas en la Sección Productos de la ventana Carrito de la compra de comercio electrónico es posible proceder a la inserción de los productos en el carro, organizándolos en Categorías.

Todos los productos ya insertados son visualizados en la Tabla resumen que concretamente presenta, para todas las Categorías ya previstas, todos los Productos insertados con relativa Descripción y Precio.

La Tabla resumen presenta una Barra de herramientas superior con los siguientes comandos:

 Cortar [CTRL + X] - Copiar [CTRL + C] - Pegar [CTRL + V]
Permiten, respectivamente, cortar, copiar y pegar los Productos seleccionados. Estos comandos están presentes también en el menú contextual activado mediante el clic de la tecla derecha del ratón en la lista de los Productos.

Además de la Barra de herramientas, para definir la lista ordenada de los productos que gestionar mediante el Carrito de la compra en línea están disponibles los siguientes comandos:
- | Nueva categoría: permite insertar una nueva Categoría en que organizar los Productos disponibles. Las Categorías no tienen predisposiciones especiales: son simples "Contenedores" y por eso son insertados directamente en la Tabla resumen. Basta hacer doble clic en correspondencia de una Categoría ya insertada para poderla renombrar. Siempre con el fin de organizar lo mejor posibe el catálogo de los Productos, también es posible crear sub Categorías: no hay límites especiales al número de Categorías o de sub Categorías que se pueden utilizar.
- | Nuevo producto: permite abrir la ventana Configuración del producto para proceder a la inserción de un nuevo producto dentro de la categoría seleccionada.
- | Eliminar: permite eliminar la categoría seleccionada, con todos los Productos insertados, o los Productos seleccionados individualmente.
- | Modificar: permite abrir la ventana Configuración del producto para modificar las predisposiciones del Producto seleccionado.

 Para desplazar un Producto de una Categoría a otra es posible hacerlo directamente en la lista de los Productos: basta seleccionarlo, arrastrarlo y soltarlo en la posición que debe asumir (Drag&Drop). Es posible seleccionar varios Productos utilizando las teclas CTRL y SHIFT.

La ventana Configuración del producto abierta con el comando Agregar o con el comando Modificar permite proceder a la definición y a la inserción de un nuevo producto y está organizada en tres secciones:
- | Sección General
- | Sección Imagen
- | Sección Opciones

Sólo después de haber insertado las Categorías y los relativos Productos dentro del Carrito de la compra de comercio electrónico será posible utilizar el Objeto de lista de productos para crear un verdadero catálogo en línea.

Temas relacionados:
- | Carrito de la compra de comercio electrónico
- | Objeto Lista Productos


Carrito de la compra de comercio electrónico| Sección productos| Configuración del producto| General

Las opciones presentes en la sección General de la ventana Configuración del producto permiten introducir alcunas informaciones de base sobre un nuevo Producto que proponer mediante el Carrito de la compra de comercio electrónico.

Las opciones disponibles para definir el nuevo Producto que añadir a la lista son:

-

Nombre/Código: permite introducir o visualizar el nombre o el código identificativo del producto que se desea crear o modificar.

-

Descripción: permite insertar o visualizar una descripción del producto que se desea crear o modificar.

-

Página vinculada al producto: permite acceder al Mapa del sitio para especificar qué Página debe ser vinculada al Producto en curso.

-

Precio: permite especificar el precio del Producto en curso.

-

IVA (%): si está activo, permite especificar el IVA que aplicar para el Producto en curso. Esta opción está disponible sólo si en la Sección opciones se ha activado la opción Impuesto IVA para cada producto.

Como se ve, en función de cómo se desee predisponer el Carrito, es posible introducir para los Productos los precios ya con IVA incluído, o bien, sobre todo en el caso de artículos que requieran la aplicación de un IVA distinto, es posible introducir los precios sin IVA y especificar después, a parte, qué impuesto aplicar caso por caso.

-

Peso: permite especificar el Peso del Producto en curso para poder calcular los gastos de envío que aplicar (ver, Sección Pago| Tipo de envío).

En base al tipo de Productos tratados en el Carrito, es posible utilizar la opción Peso para especificar un peso en kilogramos o en gramos, en lugar de introducir un volumen expresado en litros o en metros cúbicos, o en cualquier otra unidad de medida útil. Así pues, para que los costes de envío sean calculados correctamente es importante elegir una unidad de medida y mantenerla inalterada para todos los Productos del carrito.

Temas relacionados:

-

Carrito de la compra de comercio electrónico| Sección productos


Carrito de la compra de comercio electrónico| Sección productos| Configuración del producto| Imagen

Las opciones presentes en la sección Imagen de la ventana Configuración del producto permiten asociar al Producto que se desea proponer mediante el Carrito de la compra de comercio electrónico, una o varias imágenes para presentarlo.

Importando varias imágenes es posible crear una verdadera Presentación: además, haciendo clic en cada imagen será posible visualizar las mismas ampliadas mediante la especial ventana ShowBox.
Es preciso precisar que sólo la primera de las imágenes asociadas al Producto será visualizada en el Carro. En cambio, todas las demás imágenes eventualmente introducidas son visualizadas en las fichas formadas se utiliza el Objeto de lista de productos.

Las opciones disponibles para crear la lista de imágenes que asociar al producto son:
- | Agregar / Eliminar: permiten, respectivamente, agregar nuevas imágenes o eliminar las imágenes seleccionadas de la lista de aquellas que componen la Presentación. La ventana Seleccionar archivo abierta permite seleccionar incluso varios archivos contemporáneamente.
- | Subir / Bajar: permiten, respectivamente, desplazar la imagen seleccionada a antes o después de la precedente/sucesiva.
- | Modificar: permite activar el Editor gráfico para modificar la imagen seleccionada.

Además, en el recuadro Propiedades de ShowBox están disponibles las siguientes opciones:

-

Ancho máximo / Altura máxima: permiten definir los valores máximos que puede asumir la ventana ShowBox en la que aparecen las imágenes ampliadas.

Para más información sobre cómo personalizar el aspecto de la ventana ShowBox ver en el Paso 4 - Ajustes avanzados la sección Estilos y Plantillas | ShowBox.

Temas relacionados:

-

Carrito de la compra de comercio electrónico| Sección productos


Carrito de la compra de comercio electrónico| Sección productos| Predisposiciones producto| Opciones

Carrito de la compra de comercio electrónico| Sección productos| Configuración del producto| Opciones

Las opciones presentes en la sección Opciones de la ventana Configuración del producto permiten insertar algunos parámetros adicionales para la gestión del nuevo producto que proponer a través del Carrito de la compra de comercio electrónico.

En primer lugar, es posible prever las Opciones de producto. Pueden ser introducidas como Variantes de producto las tallas o los colores disponibles de una prenda de ropa, o bien, los modelos alternativos de un artículo. Todas las Variantes introducidas son visualizadas en la especial lista del Carrito o de la ficha creada si se utiliza el Objeto de lista de productos.
Los comandos disponibles para crear dicha lista de Variantes son:
- | Agregar / Eliminar: permiten, respectivamente, añadir nuevas Variantes de producto o eliminar las Variantes seleccionadas de la lista.
- | Modificar: permite modificar la Variante de Producto seleccionada. También es posible proceder a dicha modificación haciendo clic dos veces consecutivas en una Variante.
- | Subir / Bajar: permiten, respectivamente, desplazar la Variante de producto seleccionada a antes o después a la precedente/sucesiva.

Además, marcando la opción Activar descuento por cantidad es posible crear una lista con los descuentos que aplicar en base a la cantidad del producto solicitada. También en este caso, todos los descuentos por cantidad introducidos son visualizados en una lista especial y los comandos disponibles para crearlos son:
- | Agregar: permite predisponer y agregar, mediante la ventana Descuento por cantidad abierta, un descuento por cantidad para el Producto en curso. Es decir, permite definir la Cantidad de Producto que debe ser alcanzada o superada en el pedido para que se pueda aplicar el Descuento (%) previsto.
- | Eliminar: permite eliminar el descuento por cantidad seleccionado de la lista.
- | Modificar: Permite abrir la ventana Descuento cantidad para poder modificar el descuento cantidad seleccionado. Es posible efectuar dicha modificación también haciendo doble clic en el descuento.

Temas relacionados:

-

Carrito de la compra de comercio electrónico| Sección productos


Carrito de la compra de comercio electrónico| Sección Pago

Mediante las opciones propuestas en la Sección Pago de la ventana Carrito de la compra de comercio electrónico es posible definir los métodos de envío y de pago que se desea poner a disposición para el carro.

En el recuadro Lista de tipos de envío se propone la lista de todos los métodos de envío introducidos, presentando para cada uno de ellos el Nombre, la Descripción y el Precio asociados.

Los comandos disponibles para crear la lista de los métodos de envío activos para el Carro son:
- | Agregar: permite activar la ventana Tipo de envío para proceder a la definición de un nuevo método de envío.
- | Duplicar: permite crear una copia del método de envío seleccionado para poder proceder más rápidamente en la definición de otro método que se desea poner a disposición.
- | Eliminar: permite eliminar el método de envío seleccionado.
- | Modificar: permite activar la ventana Tipo de envío para modificar el método de envío seleccionado. Es posible proceder a dicha modificación también mediante doble clic en el método.
- | Subir / Bajar: permiten, respectivamente, desplazar el método de envío seleccionado a antes o después del precedente/sucesivo.

Análogamente, en el recuadro Lista de tipo de pago se presenta la lista de todos los métodos de pago puestos a disposición en el Carro y para cada uno de ellos se presenta el Nombre, la Descripción y el Precio asociados.

Los comandos disponibles para crear la lista de los métodos de pago son los mismos de los vistos ya para los métodos de envío pero los botones Agregar y Modificar permiten activar la ventana Tipo de pago.

Temas relacionados:
- | Carrito de la compra de comercio electrónico
- | Ventana Tipo de envío
- | Ventana Tipo de pago


Carrito de la compra de comercio electrónico| Sección Pago | Tipo de envío Envío

La ventana Tipo de envío envío, abierta con el comando Agregar o por el comando Modificar presentes en recuadro Lista de los métodos de envío de la Sección Pago, permite definir e insertar los métodos de envío que activar en el Carrito de la compra de comercio electrónico.

La ventana Tipo de envío envío tiene 3 secciones:
- | Sección General
- | Sección Coste
- | Sección Mensaje de correo electrónico

En la Sección general están disponibles las siguientes opciones:
- | Nombre: permite atribuir un nombre al método de envío para poderlo identificar mediante un nombre claro y sintético.
- | Descripción: permite introducir una explicación completa del método de envío.

En la Sección Coste, en cambio, es posible especificar el total de los gastos adicionales aplicados si el Cliente elige el método de envío en curso. Dicho total puede ser predispuesto según una de las siguientes modalidades:

-

Coste fijo: permite especificar un único coste fijo para el método de envío en curso. Dicho coste permanecerá invariado, independientemente de cualquier parámetro relativo al Pedido.

-

Coste relativo a la cantidad pedida: permite crear una o más bandas de coste para el método de envío en curso, en base al total del Pedido alcanzado. Es decir, mediante los botones Agregar y Modificar se abre la ventana Coste del envío mediante la cual es posible definir la Cantidad pedida: que debe ser igualada o superada para que se pueda aplicar el Coste de envío especificado.

-

Coste relativo al peso total: permite crear una o más bandas de coste para el método de envío en curso, en base al total del Peso alcanzado por los Productos introducidos en el Pedido. También en este caso, mediante los botones Agregar y Modificar se abre la ventana Coste del envío mediante la cual es posible definir el Peso total que debe ser igualado o superado para que se pueda aplicar el Coste de envío especificado.

Por lo tanto, para que los costes de envío sean calculados correctamente es importante especificar el peso de cada producto presente en el Carrito mediante la opción correspondiente presente en la ventana Predisposiciones producto.

Además, está disponible también la opción:

-

IVA (%): si está activada, permite especificar el IVA que aplicar sobre el coste asociado al método de envío. Esta opción está disponible sólo si en la Sección opciones se ha activado la opción Impuesto IVA para cada producto.

Por último, en la Sección Mensaje de correo electrónico está presente un campo dentro del cual es posible introducir un texto que describa y explique el método de envío en curso. Se recomienda escribir con atención este mensaje puesto que será utilizado dentro del correo electrónico de confirmación del Pedido que será enviado al Cliente.

Temas relacionados:
- | Carrito de la compra de comercio electrónico| Sección Pago
- | Cómo definir los contenidos del correo electrónico de confirmación de Pedido


Carrito de la compra de comercio electrónico| Sección Pago | Tipo de Pago

Carrito de la compra de comercio electrónico| Sección Pago| Tipo de Pago

La ventana Tipo de Pago, abierta con el comando Agregar o con el comando Modificar presentes el recuadro Lista de métodos de pago de la Sección Pago, permite definir e introducir los métodos de pago que activar en el Carrito de la compra de comercio electrónico.

La ventana Tipo de Pago tiene 3 secciones:
- | Sección General
- | Sección Tipo
- | Sección Mensaje de correo electrónico

En la Sección general están disponibles las siguientes opciones:
- | Nombre: permite atribuir un nombre al tipo de pago para poderlo identificar mediante un nombre claro y sintético.
- | Descripción: permite introducir una explicación completa del método de pago.

En la Sección Tipo, en cambio, es posible especificar el tipo de pago solicitado eligiendo entre:
- | Pago posterior: en este caso el Cliente podrá terminar el Pedido y efectuar el Pago en un segundo momento. Es indicado, por ejemplo, en el caso de pagos mediante Transferencia bancaria.
- | Pago inmediato: en este caso, en cambio, el Cliente podrá terminar el Pedido pero se le pedirá que efectúe inmediatamente el Pago. Es indicado en el caso de pagos mediante PayPal, u otros circuitos analógicos, o bien mediante Tarjeta de crédito.

Activando la opción Pago inmediato es preciso definir el Tipo de Pago solicitado:; depués, en función del tipo elegido, es necesario predisponer algunos parámetros:
PayPal/Tarjeta de Crédito:

-

Cuenta PayPal: permite introducir la cuenta asignada como usuario de PayPal.

-

Página de confirmación de pago: permite abrir el Mapa del Sitio y seleccionar la Página que debe ser visualizada después que ha terminado el Pago.

-

Página de Error de pago: permite abrir el Mapa del Sitio y seleccionar la Página que debe ser visualizada en caso de error durante el procedimiento de Pago.
Código personalizado:

-

Código HTML para el Botón 'Pagar Ahora': si se decide utilizar un sistema de pago alternativo a PayPal, esta opción permite introducir el código HTML suministrado, como consecuencia de la inscripción, por parte del administrador del servicio de transación elegido.

El código HTML que ha sido otorgado por el administrador del servicio de transacción se utiliza para crear el botón de "Pagar Ahora" y debe ser completado con la indicación de qué se compra y el precio correspondiente. Así pues, para que el carrito funcione es necesario introducir manualmente en el código los siguientes tag:
- | [ORDER_NO] - identifica el número de pedido;
- | [PRICE] - identifica el coste total a pagar.

Además, están disponibles también las opciones:
- | Coste: permite especificar el total de los gastos adicionales aplicados en el caso que el Cliente elija el método de pago en curso.
- | IVA (%): si está activada, permite especificar el IVA que aplicar al coste asociado al método de pago. Esta opción está disponible sólo si en la Sección opciones ha sido activada la opción Impuesto IVA para cada Producto.

Por último, en la Sección mensaje de correo electrónico está presente un campo dentro del cual es posible introducir un texto que describe y explica el método de pago en curso. Se recomienda escribir con atención este mensaje puesto que será utilizado dentro del correo electrónico de confirmación del Pedido que será enviado al cliente.

Temas relacionados:
- | Carrito de la compra de comercio electrónico| Sección Pago
- | Cómo definir los contenidos del correo electrónico de confirmación de Pedido


Carrito de la compra de comercio electrónico| Sección Detalles del cliente

A través de las opciones propuestas en la Sección Detalles del cliente de la ventana Carrito de la compra de comercio electrónico es posible definir la composición del formulario que el usuario debe compilar para proceder al pedido mediante Carrito.

En el recuadro Formulario de pedido se propone una Lista Campos con la lista de los campos que pueden ser utilizados para crear el formulario de pedido.
Para insertar un campo en el formulario basta hacer clic de modo que aparezca una marca en el check box correspondiente de la colonna Visible. En cambio, para hacer que el campo deba ser necesariamente compilato para proceder con el pedido es preciso marcar también la check box presente en la columna Obligatorio.

La lista propuesta por defecto contiene ya todos los campos generalmente utilizados en un módulo de inscripción.

El último campo propuesto en la lista corresponde al correo electrónico: este no es posible esconderlo o convertirlo en campo no obligatorio ya que para el correcto funcionamiento del carrito es necesario conocer el correo electrónico del cliente que envía el pedido de compra.

Además de la Lista Campos están disponibles también las siguientes opciones:
- | Mostrar las condiciones del contrato: activando esta opción es posible agregar un campo al pie del formulario en el que se indican las condiciones que el cliente debe aceptar para proceder al envío del pedido. Dicho campo puede ser utilizado, por ejemplo, para presentar las normas que se respetan para la tutela de la privacidad en la tratamiento de los datos recogidos.
- | Mensaje de Condiciones del contrato: permite insertar el texto de las condiciones que el usuario tiene que aceptar antes de que se le envíe el pedido de compra.

En el recuadro Dirección de correo electrónico de resumen Pedido están presentes las siguientes opciones:
- | Dirección de correo electrónico para recibir los Pedidos permite especificar la dirección de correo electrónico a la que el administrador del Sitio desea recibir los pedidos efectuados por los usuarios mediante el carrito.
- | Adjuntar los Datos del Pedido en formato CSV: activando esta opción es posible hacer que los datos recogidos sean guardados también en un archivo de formato .CSV, incluído al final del correo electrónico. En un archivo .CSV los datos son presentados en forma de texto, como una larga lista de elementos separados por un punto y coma: dichos archivos pueden ser fácilmente importados en los programas para la gestión de las hojas de cálculo (por ej., Microsoft Excel).

Por último, en el recuadro Correo electrónico de confirmación del Pedido para el usuario están disponibles los campos mediante los cuales es posible especificar el Texto de introducción y el Texto de cierre para el correo electrónico de confirmación del Pedido que será automáticamente enviado al usuario. En este correo electrónico de confirmación del pedido, además del texto de introducción y del texto de cierre, se proponen también las descripciones relativas a los métodos de envío y pago elegidos.

Temas relacionados:
- | Carrito de la compra de comercio electrónico
- | Cómo definir los contenidos del correo electrónico de confirmación de Pedido


Carrito de la compra de comercio electrónico| Sección Opciones

Mediante las opciones propuestas en la Sección Opciones de la ventana Carrito de la compra de comercio electrónico es posible definir algunos parámetros gráficos, además de los relativos a moneda e IVA, para el Carrito de la compra de comercio electrónico.

En el recuadro Configuración moneda aparecen las siguientes opciones:
- | Moneda: permite definir el símbolo de la moneda que se mostrará en el carrito. El menú emergente propone ya algunas monedas: para modificar la composición de dicha lista de monedas basta hacer clic en el botón [image] para activar la ventana Lista de monedas.
- | Agrupación de dígitos: permite elegir cómo se deben escribir los precios de los productos, eligiendo si los millares deben ser separados por un punto y los decimales por una coma (1.000,00) o viceversa (1,000.00).
- | Mostrar moneda a la derecha: activando esta opción, el símbolo de la moneda es presentado a la derecha de los precios.
- | Mostrar posiciones decimales: activando esta opción, los precios son presentado con dos cifras después de la coma.

En el recuadro Configuración IVA: están disponibles las siguientes opciones:
- | IVA incluído en el precio del producto: activa por defecto, predispone el Carro de modo que los precios de los Productos tengan ya incluído el IVA.
- | Establecer el valor del IVA para cada producto: es preciso activar esta opción si se desea presentar los precios de los productos al neto del IVA y tener la posibilidad de especificar el total caso por caso.
- | Valor IVA predeterminado (%): disponible sólo si se activa la opción Establecer el valor del IVA para cada producto, permite especificar un valor por defecto para el IVA. Este valor es aplicado cuando no se especifica el IVA para un producto mediante la opción correspondiente de la ventana Configuración del producto| General.

En la ventana Opciones aparecen los siguientes comandos:
- | Permitir únicamente pedidos de cantidades mínimas: permite hacer que el pedido no sea aceptado a no ser que alcance el importe mínimo establecido.
- | Cantidad total mínima: disponible sólo se activa la opción Permitir únicamente pedidos de cantidades mínimas, permite definir el valor del importe mínimo que debe ser alcanzado por el total del pedido para que éste sea aceptado.

Por último, en el recuadro Configuración gráfica de la tabla de productos se presentan los comandos necesarios para definir el aspecto de las tablas a través de las cuales se presentan los productos disponibles y/o insertados en el carro:
- | Fondo del encabezado / Texto de encabezado / Fondo celdas / Texto celdas / Borde de la tabla: permiten definir, mediante la ventana Color abierta, el color para los distintos elementos de la tabla Productos.
- | Imagen 'Agregar al carrito' / Imagen 'Eliminar del carrito': permiten especificar las imágenes que utilizar para crear los botones 'Agregar al carro' y 'Eliminar del carro', es decir los botones que el usuario puede utilizar para insertar o eliminar en/de el carro un determinato producto.
- | Imagen 'Vista previa no disponible': permite especificar la imagen a utilizar cuando, para un producto, no se ha especificado la imagen asociada y en la página Lista de productos se ha elegido la presentación "Imagen y texto" o "Texto e imagen" para las fichas.

Temas relacionados:

-

Carrito de la compra de comercio electrónico


Exportar

Llegados al final de una sesión de trabajo o de la creación del Sitio entero, el Paso 5 de WebSite X5 permite elegir la modalidad de exportación para el Proyecto en curso. En primer lugar, gracias al Motor FTP incluído, es posible efectuar directamente la publicación de los archivos en el Servidor: se efectúa también la conexión segura y es posible ahorrar tiempo trabajando en multi-conexión y, en caso de actualizaciones, publicando sólo los archivos modificados. En alternativa, es posible exportar el Sitio a un disco del propio ordenador para poder disponer en local de una copia de los archivos que serán publicados en el Servidor. Por último, todos los archivos del Proyecto pueden ser agrupados dentro de una única carpeta para transferirlos fácilmente a otro ordenador y poder proseguir el trabajo.

Así pues, concretamente las opciones de exportación disponibles son:

 Exportar el sitio a Internet

Exportar el sitio a un disco

Exportar el Proyecto


Exportación del sitio a Internet

Esta ventana permite publicar en la red el sitio creado.

WebSite X5 pone a disposición un Motor FTP interno para poder proceder directamente a la publicación en línea de los sitios realizados. En efecto, todos los archivos necesarios para que un Sitio pueda ser visualizado correctamente en Internet son guardados en el ordenador el que se ha efectuado el trabajo. Así pues, para que los usuarios que se conectan a Internet puedan ver nuestras Páginas, es necesario copiar estos archivos en un Servidor, o sea en un ordenador permanentemente conectado a la red.

Para proceder a la exportación de todos los archivos relativos al Sitio es necesario, en primer lugar, especificar los siguientes Parámetros de conexión (datos proporcionados por el Proveedor administrador del servicio que se utiliza para tener el Espacio Web):

-

Tipo de Servidor: permite especificar el tipo de conexión que utilizar para proceder a la publicación de los archivos del Sitio en el Servidor. En relación a lo que es soportado por el propio Servidor, es posible elegir entre:
- | FTP - File Transfer Protocol: previsto por defecto, es uno de los primeros protocolos para la transmisión de los datos que ha sido introducido y está ampliamente difundido. La especificación original de FTP no prevé ningún cifrado para los datos intercambiados entre Cliente y Servidor.
- | SFTP - SSH File Transfer Protocol: es un protocolo de red que prevé la transferencia segura de los datos, gracias al establecimiento de sesiones remotas cifradas, así como funcionalidades de manipulación en los archivo remotos.
- | FTPS - FTP over explicit TLS/SSL: para resolver los problemas de seguridad, añade al protocolo FTP original un layer de cifrado SSL/TLS además de una serie de comandos y códigos de respuesta.

-

Dirección FTP: en este campo se debe insertar la propia dirección FTP. Un ejemplo de dirección FTP es: "ftp.websitex5.com", dove "websitex5.com" es el nombre del dominio.

-

Nombre usuario / Contraseña: en estos campos es necesario insertar los propios Nombre usuario y Contraseña.

-

Guardar contraseña: activando esta opción, la contraseña especificada es guardada para no tener que introducirla en futuro.

Además, es posible especificar algunos Parámetros opcionales, no indispensables para establecer la conexión al Servidor, como:

-

Carpeta de destino: en este campo se puede especificar la carpeta de destino asignada por el Proveedor para el propio Espacio Web. Si no se introduce una ruta de acceso, será posible igualmente predisponerla en la página de pantalla de WebSite X5 siguiente.

-

Puerto: permite especificar el puerto del Servidor en el que se establece la conexión (dato proporcionado por el Proveedor del espacio Web). En la mayor parte de los casos no es necesario modificar el valor predispuesto por defecto.

-

Conexiones simultáneas: permite especificar el número de conexiones al Servidor que el Motor FTP del Programa debe abrir simultáneamente para proceder a la publicación de los archivos del Sitio. El número de conexiones equivale al número máximo de archivos que pueden ser exportados contemporáneamente.

La conexión simultánea es una funcionalidad que debe ser soportada por el Servidor utilizado. Si es soportada, aumentar el número de conexiones simultáneas, más allá de un cierto límite, no comporta una auténtica ventaja en términos de tiempo. Se recomienda empezar con 3 y probar a modificar dicho parámetro, aumentándolo progresivamente, para poder identificar el mejor número de conexiones en relación al tamaño de la banda manejada por el Servidor utilizado. Indicativamente, no se recomienda superar las 10 conexiones simultáneas.

-

Usar protocolo FTP pasivo: activa por defecto, prevé el uso del FTP pasivo como modalidad de publicación. Esta modalidad se recomienda para obtener una mayor compatibilidad de conexión con el Servidor.

-

Activar compresión gzip: activa por defecto, prevé que los archivos relativos al Sitio sean comprimidos durante la exportación, para poder terminar la publicación en menos tiempo.

No todos los Servidores soportan la compresión en gzip: en el caso en que la opción esté activada y el Servidor utilizado no la soporte, los archivos no serán comprimidos y la publicación será terminada igualmente. La compresión gzip funciona muy bien con archivos de gran tamaño (por ejemplo, los que contienen muchas imágenes o vídeos), mientras que no es aconsejada en el caso de archivos de pequeño tamaño.

Una vez predispuestos los Parámetros necesarios para efectuar la conexión al Servidor, es posible especificar el Tipo de carga, o sea lo que se desea publicar efectivamente:

-

Exportar todos los archivos del Sitio Internet: en este caso el Sitio entero es publicado. Esta modalidad es indicada cuando se procede por primera vez a la publicación de un Proyecto o cuando se han hecho numerosas y substanciales modificaciones al Sitio.

-

Exportar solamente los archivos modificados desde la última exportación con fecha….: en este caso se publican sólo los archivos que han sido modificados respecto a cuanto publicado con la exportación producida en la fecha recordada. Esta modalidad es indicada para aquellos sitios que son constantemente actualizados, ofreciendo la ventaja de ahorrar tiempo respecto a la publicación completa del sitio.

La fecha de publicación es guardada dentro del archivo de proyecto: por esto es muy importante guardar siempre las modificaciones después de haber publicado el sitio.
Aunque se pide la exportación solamente de los archivos modificados, las páginas HTML y los archivos de recursos (presentes en la sub-carpeta Res) son publicados de nuevo: en efecto es muy probable que hayan sufrido también actualizaciones.

-

Exportar solamente Blog y RSS: en este caso se publican sólo los archivos .PHP y .XML del Blog y los archivos .XML de la Sindicación web (RSS) manejados mediante las especiales secciones del Paso 4 - Ajustes avanzados. Esta modalidad, activa sólo si el Blog y/o la Sindicación web (RSS) ya ha sido publicado una primera vez, es indicada cuando no se han aportado actualizaciónes al Sitio sino sólo se han añadido nuevos post en el Blog o nuevas noticias en la Sindicación web (RSS).

Consejos Práticos

Después de haber predispuesto los parámetros requeridos, basta hacer clic en el botón Siguiente para efectuar la conexión al Servidor. Una vez establecida la conexión al Servidor, en una especial ventana aparecen visualizadas las carpetas ya presentes en él. A continuación, utilizando los comandos puestos a disposición, es necesario situarse dentro de la carpeta en la que se desea publicar los archivos relativos al Sitio.

 La carpeta en la cual publicar el Sitio debería contener un archivo index.html. En cualquier caso, si no se sabe con seguridad en qué carpeta publicar, es preciso ponerse en contacto con el propio Provider y pedir confirmación: no todas las carpetas presentes en el Servidor, sirven para la publicación.

Concretamente, los comandos disponibles para trabajar con las carpetas y los archivos presentes en Servidor son:

 Carpeta superior
Permite acceder a la carpeta superior.

Actualizar
Permite actualizar el contenido de la carpeta en curso.

Nueva carpeta
Permite crear una nueva carpeta.

Eliminar
Permite eliminar los archivos o la carpeta seleccionada.

Renombrar
Permite modificar el nombre del archivo o de la carpeta seleccionada.

Cargar el archivo al Servidor / Descargar el archivo seleccionado desde el servidor
Permiten, respectivamente, publicar en el Servidor uno o más archivos que no forman parte del Proyecto y descargar en ordenador local archivos ya publicados en el Servidor.

Mostrar lista / Mostrar detalles
Permiten predisponer cómo se debe visualizar la lista de los archivos.

Por último, está disponible una sección en la que es posible elegir si visualizar:
- | Registro Mensajes: se presentan todos los mensajes (o sea, los log) y los posibles errores generados durante la comunicación con el Servidor.
- | Archivos en cola: muestra los archivos (el número máximo de dichos archivos depende de las Conexiones simultáneas predispuestas) de los que se está efectuando la publicación. Para cada archivo, se muestra el estado de progresión de la publicación mediante una barra de avance. Una vez terminada la publicación, el archivo es eliminado de la Cola de los archivos de transferencias.

 Durante la exportación, WebSite X5 copia en el Servidor todos los archivos contenidos en la carpeta de registración. Si en esta carpeta ya están presentes archivos con el mismo nombre de los que son publicados, estos serán sobreescritos.

Temas relacionados:

-

Exportar


Exportación terminada

Después de haber terminado con éxito la publicación en línea (ver, Exportación del sitio a Internet), esta ventana sugiere algunas acciones para hacer publicidad al Sitio realizado a través de canales como la Galería de WebSite X5, Google, Facebook y Twitter.

Concretamente, las opciones disponibles son:

 ¡Su sitio web está en Internet!
Permite activar el Navegador Internet predeterminado para navegar enseguida en el Sitio apenas puesto en línea y controlar que todo funcione correctamente.

WebSite X5 Gallery
Permite conectarse a la sección dedicada a la Galería de My.WebSiteX5.com para poder señalar el Sitio apenas publicado. Recordamos que la Galería es un conjunto de sitios realizados con WebSite X5 y señalados directamente por sus autores.

Actualizar el SiteMap en Google
Permite enviar a Google la indicación del SiteMap del Sitio apenas publicado, para solicitar la indexación por parte del spider del Motor.

Publicación de difusión en Facebook
Permite visualizar una página de Facebook en la que, después del login, es posible escribir un comentario para señalar a todos los propios contactos la publicación del Sitio. El comentario aparecerá en el muro del propio perfil.

Notificar la publicación en Twitter
Permite visualizar una página de Twitter en la que, después del login, es posible escribir un tweet para señalar a todos los propios contactos la publicación del Sitio. Il tweet aparecerá en la timeline del propio perfil.

Temas relacionados:

-

Exportar


Exportación al disco

Esta ventana permite efectuar la publicación el Sitio creado en otro disco del ordenador.

La exportación en disco sirve para tener una copia en ordenador de los archivos que serán publicados en el Servidor, para poderla copiar en CD/DVD/USB o para poder efectuar eventuales modificaciones en las páginas HTML creadas antes de la efectiva publicación.

Para proceder a la exportación de todos los archivos del Proyecto, basta especificar:

-

Carpeta de destino: permite especificar la carpeta donde exportar el Sitio creado. Si la carpeta especificada no existe, será automáticamente creada por el programa.

Para crear una copia de seguridad del Proyecto es necesario utilizar la función Exportar el Proyecto: en efecto, de este modo se podrá disponer de una copia de los archivos originales del Proyecto y no de los archivos creados por el programa para la publicación.

Temas relacionados:

-

Exportar


Exportar el Proyecto

Esta ventana permite exportar a un único archivo comprimido todos los archivos vinculados al Proyecto, con el fin de poderlos transferir a otro ordenador o crear una copia de seguridad.

Para iniciar la exportazione del archivo de Proyecto basta especificar:

-

Carpeta de destino: en este campo se debe especificar la carpeta a la que exportar el archivo de Proyecto. Si la carpeta especificada no existe, es creada automáticamente.

Así pues, como consecuencia de la exportación, en la carpeta de destino especificada se crea un único archivo comprimido que tiene el mismo nombre del Proyecto y extensión .IWZIP: de este modo, para el proyecto "MiProyecto" se creará el archivo MiProyecto.iwzip. Dentro de este archivo comprimido se guardan tanto el archivo de Proyecto (archivo .IWP) como todos los archivos a él vinculados (por ejemplo, relativos a Imágenes, Vídeos o Animaciones importadas).

El archivo comprimido .IWZIP podrá ser transferido a un ordenador distinto de aquel en que ha sido creado y abierto en el programa mediante la función Importar, disponible en la ventana Elección del Proyecto.

Temas relacionados:
- | Exportar
- | Elección del Proyecto| Importar Proyecto


Navegador (Browser)

Compatibilidad crossbrowser

Un Navegador es una aplicación software que permite al usuario visualizar e interaccionar con las información (textos, imágenes, etc.) presentes dentro de una Página Web. Acttualmente, están disponibles numerosos Navegadores; entre los más conocidos y difundidos están Microsoft Explorer, Firefox, Safari y Google Chrome.

Para proceder a la visualización de los contenidos Web, los Navegadores aprovechan un motor de rendering, es decir un software que, una vez descargados los contenidos (por ejemplo una Página HTML) formatea las informaciones relacionadas con ellos (por ejemplo, los CSS conectados) y las muestra en la pantalla. Navegadores distintos aprovechan motores de rendering distintos y estos últimos se diferencian precisamente por la calidad de la "renderización", respecto a los estándares, y por la velocidad de la misma. El resultado es que una misma Página Web puede ser interpretada también de manera muy distinta según el Navegador (Browser) utilizado. En cualquier caso, puesto que una Página Web no es una página imprimida, un cierto margen de variabilidad es aceptable con tal que la experiencia de uso del Usuario no resulte dañada.

El mejor modo para obtener páginas Web compatibles con los principales Navegadores, en sus distintas versiones, es crear un código lo más limpio y conforme posible a los estándares.

WebSite X5, generando automaticamente código HTML5 con CSS 2.1 o 3 conectados, es capaz de garantizar plena compatibilidad con todas los principales Navegadores además de con dispositivos móviles como teléfonos, palmtop y smartphone.

Navegador interno

Durante el desarrollo de un Proyecto es necesario poder verificar cuál será el resultado final y cómo aparecerá el sitio una vez que esté en línea. Por esto, WebSite X5 permite activar, mediante el botón Prueba siempre disponible (ver, El ambiente de trabajo), una Vista previa del Sitio en local que es mantenida constantemente actualizada (ver, Guardar en cada Vista previa en la ventana Preferencias).

Para la visualización de la Vista previa, WebSite X5 utiliza su Navegador interno que aprovecha el mismo motor de Microsoft Internet Explorer. Dicho Navegador interno presenta los siguientes comandos:

 Atrás
Permite regresar a la Página precedentemente visitada.

Siguiente
Permite avanzar y abrir de nuevo una Página ya visitada.

Página inicial
Permite regresar a la Página de inicio del Sitio.

Barra de las direcciones
Presenta la ruta de acceso de la página visualizada y/o permite especificar la ruta de la página que se desea visualizar.

Ir
Permite activar el cargamento de la Página a la que se llega mediante la ruta introducida en la barra de las direcciones. En alternativa, es posible confirmar la dirección introducida mediante la tecla ENVIAR.

Editar esta página
Permite regresar al programa, abriendo la Página en curso en el Paso 3 - Creación de la página, para poderla modificar. En el caso de páginas pertenecientes al Blog, al Área reservada o al Carro de la compra, este botón permite regresar a la relativa sección del Paso 4 - Ajustes avanzados.

Una vez abierta la ventana del Navegador para obtener la vista previa en local del Proyecto al que se está trabajando, la Página visualizada cambia automáticamente en base a la Página en que se está trabajando. Esto significa que si se pasa a trabajar en una Página distinta, esta misma Página es abierta también en la Vista previa en el Navegador.

El empleo de un Navegador interno para la visualización de la Vista previa del Sitio en costrucción permite obtener las siguientes ventajas:
- | la Vista previa no sustituye el Sitio visualizado en la ventana del Navegador predeterminado eventualmente abierta
- | la Vista previa del Sitio en costrucción es actualizada en la ventana del Navegador interno y no lleva a la apertura de ventanas o fichas distintas del Navegador predeterminado.


Cómo manejar los Idiomas para los textos insertados en automático

Algunos textos presentes en las Páginas creadas con WebSite X5 son insertados automáticamente por el programa; son textos como, por ejemplo, los enlaces a anclas internas, los Botones del Objeto de galería, las etiquetas del Objeto Formulario de envío de correo electrónico, las etiquetas y los textos de los Carritos de la compra de comercio electrónico, los textos del Mapa del Sitio.

Para que estos textos insertados automáticamente estén el Idioma correcto, es necesario especificar el Idioma principal del Sitio mediante la opción Idioma disponible en la ventana Ajustes generales. Por defecto, WebSite X5 permite elegir entre un cierto número de idiomas, como italiano, inglés y alemán, de los que dispone ya de todas las traduciones necesarias. En cualquier caso, las traduciones predispuestas pueden ser modificadas, así como es posible añadir o importar nuevos Idiomas y eliminar los que ya no sirven. Para efectuar esta serie de operaciones es necesario acceder a la ventana Gestión de contenido de idioma haciendo clic en el botón [image] Seleccionar...situado junto a la opción Idioma.

La ventana Gestión de contenido de idioma presenta, en la izquierda, la lista de los Idiomas disponibles y, en la derecha, una Tabla con las traduciones en los distintos idiomas. La primera columna de la Tabla presenta una descripción útil para identificar dónde se utilizan las distintas opciones; sigue una columna para cada Idioma activo. Por Idioma activo se entiende un Idioma en el que se ha puesto una marca entre los presentes en la lista de los Idiomas disponibles. Así pues, es posible trabajar directamente en esta Tabla para modificar o añadir opciones.

Por último, la ventana Gestión de contenido de idioma presenta los siguientes botones:

 Agregar Idioma: permite insertar, mediante la ventana de diálogo abierta, el nombre del nuevo Idioma que crear. El nombre del idioma debe ser insertado respetando el siguiente formato: "ID - NombreIdioma", por ejemplo"EN - English".

Eliminar Idioma: permite eliminar el idioma seleccionado de la lista.

Consejos Práticos - Modificar una opción ya introducida

Un ejemplo de texto insertado automáticamente por el programa son las etiquetas de los botones "Enviar" y "Restablecer" previstos al final del los formularios de contacto.
Si, por ejemplo, se desea modificar la etiqueta "Restablecer" en "Deshacer", después de haber predispuesto "Español" como Idioma, es preciso proceder como sigue:
- | En la ventana Gestión de contenido de idioma, si no está activo aún, hacer clic en el idioma Español para visualizar la columna relativa en la Tabla de los contenidos.
- | En la primera columna de la Tabla de los contenidos, identificar la opción "label_form" que es aquella relativa a la etiqueta a modificar: desplazarse a lo largo de la línea hasta llegar a la celda correspondiente en la colonna del Idioma Español. Hacer doble clic en la celda de modo que aparezca el cursor: cancelar el texto "Restablecer" y escribir "Deshacer".
- | Confirmar y guardar.

Consejos Práticos - Agregar un nueva Idioma

Para crear un Sitio en una Idioma aún no previsto (por ejemplo, en Portugués) evitando que los textos manejados en automático sean insertados en la versión inglesa (utilizada por defecto), es preciso predisponer un nuevo Idioma e introducir las traduciones requeridas. Si se tiene la competencia linguistica necesaria, es una operación muy simple:
- | En la ventana Gestión de contenido de idioma hacer clic en el botón Agregar Idioma y, mediante la ventana de diálogo abierta, escribir "PT - Português": de este modo la nueva opción aparece al final de la lista de los Idiomas disponibles.
- | Hacer clic en la opción "PT - Português" para visualizar la columna relativa a este Idioma en la Tabla de las traduciones.
- | Hacer clic en las distintas celdas de la columna "PT - Português" para introducir las traduciones necesarias.
- | Introducir la traducción, confirmar y guardar.

Temas relacionados:
- | Ajustes Generales| Sección General
- | Ajustes avanzados| Página de bienvenida


Cómo funciona el motor de búsqueda interno de WebSite X5

WebSite X5 permite insertar en los Sitios creados un Campo para la búsqueda en el interior de los Títulos y de los Contenidos de las Páginas. Los resultados de la búsqueda, ordenados en función de su pertinencia, son devueltos después en Páginas creadas automáticamente por el programa.

Para aprovecha al máximo el Motor de búsqueda interno de WebSite X5 es preciso saber que:
- | Páginas Los elementos de la página tomados en consideración por el motor son: Título, Descripción y Palabras clave (ver, ventana Propiedades de la página| General) además de, obviamente, los contenidos textuales. Las apariciones identificadas en los Títulos de las páginas tienen gran importancia y, por eso, aparecen automáticamente multiplicadas por un factor de corrección antes de ser asociadas a las demás apariciones. Después, en base al número de apariciones así calculado, se define la importancia, y por lo tanto la posición, de cada resultado presentado dentro de la página que restituye los resultados de la búsqueda.
- | Área reservada Las Páginas protegidas mediante Login y Contraseña (dentro de un Área reservada) no son tomadas en consideración por el Motor de búsqueda interno si antes no ha sido efectuado el Login por parte del usuario.
- | Páginas no visibles Las páginas predispuestas como No visibles en el Menú de navegación entran normalmente entre las consideradas por el Motor de búsqueda interno.
- | Para excluir una Página de la búsqueda Par hacer que una Página no sea tomada en consideración por el motor de búsqueda interno basta seleccionarla dentro del Mapa, abrir la ventana Propiedades de la página y, en la Sección Avanzado, desactivar la opción Agregar esta página al SiteMap.
- | Mayúsculas/Minúsculas El Motor de búsqueda no es case-sensitive: esto significa que considera iguales las letras mayúsculas y las letras minúsculas.
- | Páginas con resultados de la búsqueda Las páginas con los resultados de la búsqueda son creadas automáticamente por el Programa: el aspecto gráfico de dichas Páginas es establecido por las predisposiciones definidas en el Paso 4 - Ajustes avanzados, en la sección Estilos y Plantillas.

Temas relacionados:
- | Editor de plantilla| Recuadro Campo de búsqueda
- | Ajustes Avanzados: Estilos y Plantillas


El Box Model en WebSite X5

En WebSite X5 las páginas son creadas mediante la ayuda de una Rejilla y la paginación puede ser perfeccionada cambiando los márgenes mediante la ventana Margen de celda abierta por el botón [image] disponible en el Paso 3 - Creación de la página.

Para comprender mejor qué se entiende por Margen y conseguir efectuar con precisión la paginación de los contenidos es necesario comprender el Box Model utilizado.

Cuando se escribe el código de una Página Web, todos los elementos HTML son considerados como bloques (o box) y todo el conjunto de reglas que gestiona el aspecto visual de dichos elementos bloque es indicado como Box Model. Cada box comprende un cierto número de componentes de base, y cada uno se puede modificar con propiedad por los CSS: márgenes, bordes, padding y contenido.

La imagen siguiente ilustra las partes del Box Model:

En WebSite X5 la Rejilla de paginación propuesta identifica una serie de Celdas en las que es posible insertar los distintos contenidos: para cada una de dichas celdas se aplica el Box Model ilustrado.

Por lo tanto los elementos son:
- | Contenido (área en verde): es el contenido insertado mediante el arrastre de uno de los Objetos disponibles.
- | Margen interno (área en rosa): es el espacio entre el contenido actual y el borde.
- | Borde: es el borde dibujado alrededor del contenido; el aspecto de dicho borde puede ser definido a través de las opciones de la ventana Estilo de la celda.
- | Margen externo (área en amarillo): es el espacio entre el borde y las líneas que definen la Rejilla de paginación.
Dadas estas definiciones, el espacio entre dos Objetos situados uno junto a otro (en horizontal o en vertical) es igual a la suma de los Márgenes externos predispuestos para las celdas que los contienen.

Temas relacionados:
- | Rejilla de paginación
- | Estilo de la celda


Cómo crear una imagen de fondo que se adapte al tamaño de la celda

Mediante la ventana Estilo de la celda| Sección Estilo es posible definir el aspecto gráfico de la Celda en curso de la Rejilla de paginación.

Una de las posibilidades disponibles es la de importar una imagen (archivo en formato .JPG, .GIF, .PNG) y utilizarla para componer el fondo de dicha Celda. En función del tipo de imagen importata será necesario elegir la opción Fondo con imagen, definiendo predisposiciones distintas para las opciones Repetir y Alineación, o utilizar la opción Ajustar imagen a la Celda, de modo que se consiga obtener el mejor resultado.

Ejemplo 1
La imagen importata tiene el mismo tamaño de la Celda.
Fondo del sitio: Fondo con imagen
Repetir: No repetir
Alineación: Arriba-Izquierda

Ejemplo 2
La imagen importada es un pattern, es decir una imagen creada de modo que uniendo dos o más iguales, tanto en horizontal como en vertical, no se nota el punto de unión.
Fondo del sitio: Fondo con imagen
Repetir: Imagen en mosaico
Alineación: Arriba-Izquierda

Ejemplo 3
La imagen importada es la de un marco que se deberá adaptar a Cceldas de tamaños diferentes.
Fondo del sitio: Ajustar imagen a la Celda
Anchura bloque /Altura bloque: predisponer los tamaños de los bloques más oportunos.

Para comprender mejor cómo funciona la opción Ajustar imagen a la celda, qué son los bloques y cómo predisponer correctamente los tamaños, hay que considerar las siguientes imágenes:

Imagen 1 | Imagen 2 | Imagen 3

La imagen original (Imagen 1) muestra un marco muy elaborado pero que se presta muy bien para ser cortado en bloques y para adaptarse a cualquier tamaño que asuma la celda: los elementos ornamentales añadidos en los ángulos ocupan, en efecto, un área bien definida y fácilmente delimitable y todos los difuminados pueden ser repetidos como un pattern sin que se verifiquen bruscos cambios de tonalidad.

En la Imagen 2 se ven los bloques de los que hay que predisponer el tamaño (opciones Anchura bloque y Altura bloque). Los valores de la anchura y de la altura de los bloques (todos iguales entre sí) son definidos en porcentaje respeto a la anchura y a la altura de la imagen original y pueden variar entre el 5 y el 45%. En este caso, es preciso predisponer el tamaño del corte al 35% para ambos lados de los bloques para que incluyan completamente la imagen colocada en los ángulos.

Como se ve en la Imagen 3, identificando los bloques A, B, C, D es posible obtener otras 5 secciones, a, b, c, d, e: estos son los cortes que son efectuados por el Programa para obtener de la imagen original todas las imágenes necesarias que compongan el fondo de la Celda. Así, mientras las imágenes correspondientes a los bloques A, B, C, D son mantenidas tal como son y colocadas simplemente en los ángulos, las imágenes correspondientes a las secciones, a, b, c, d, e son repetidas de manera que se llene todo el espacio necesario.
Como se puede comprender fácilmente, este procedimiento permite una notable flexibilidad: en efecto, partiendo de una única imagen adecuadamente realizada, es posible resolver el aspecto de Celdas incluso con tamaños muy distintos entre sí.

Temas relacionados:
- | Rejilla de paginación
- | Aspecto celda


Cómo definir los contenidos del correo electrónico de confirmación de pedido

Una vez terminado un Pedido es importante que el Usuario reciba como retroalimentación un correo electrónico de confirmación gracias al cual puede asegurarse de haber hecho todo correctamente y recibir las indicaciones necesarias para efectuar el pago.

WebSite X5 crea automáticamente el correo electrónico de confirmación del Pedido, tomando sólo las informaciones útiles, en base a las elecciones efectuadas por el Usuario durante la compilación del Pedido mismo.

Concretamente, el correo electrónico de confirmación del pedido está compuesto por:

 | Descripción: | Ejemplo: | Dónde predisponerlo:
Texto de introducción | Es el texto inicial: debería contener un agradecimiento por la compra efectuada y anticipar los contenidos que seguirán. | Estimado cliente, Gracias por su compra. Este es un resumen de su pedido A continuación encontrará una lista de los productos pedidos, la información de facturación y las instrucciones sobre el envío y la forma de pago que ha elegido. | En la Sección Detalles del Cliente mediante la opción Texto de introducción.
Datos usuario | Es la parte en la que se presentan los datos de facturación y de envío introducidos por el Usuario mediante el Formulario de pedido. |  | El Formulario de pedido puede ser compuesto en la Sección Detalles del Cliente; para permitir especificar datos de envío distintos de los de facturación es preciso activar la opción Mostrar formulario de información de envío.
Resumen pedido | Es una tabla en la que se resumen todos los Productos pedidos: se indica la cantidad y el total parcial para Producto además del total del Pedido. |  | No se debe predisponer nada especial: la tabla con el resumen se crea automáticamente en base al Pedido.
Tipo de pago | Es necesario que proporcione, en base al método elegido por el Usuario de entre los disponibles, las instrucciones y las informaciones útiles para permitirle efectuar el pago. | Para el Tipo de pago" Transferencia bancaria": Estos son los datos necesarios para realizar el pago por transferencia bancaria: XXX YYY ZZZ Tenga en cuenta que una vez terminado el pago, debe enviar una copia del recibo junto con el Número de pedido. | En la sección Mensaje de correo electrónico de la ventana Tipo de pago.
Tipo de envío | Es apropiado recordar al usuario el método de envío que ha elegido proporcionándole, si es posible, informaciones sobre tiempo y modos de entrega, además de cualquier otra información útil. | Para el Tipo de envío " Envío urgente": Envío mediante Envío urgente. La mercancía será entregada en 1-2 días laborables. | En la sección Mensaje de correo electrónico de la ventana Tipo de envío.
Texto de cierre | Es la fórmula de cierre con la que se indica la propia disponibilidad y se efectúa la cordial despedida, firmando. | Póngase en contacto con nosotros si requiere información adicional. Atentamente, el personal de Ventas. | En la Sección Detalles del Cliente mediante la opción Texto de cierre.

Como para todos los correos electrónicos elaborados y enviados automáticamente por el Programa, también al correo electrónico de confirmación del pedido es aplicado el estilo gráfico definido en Estilos y Plantillas| Sección Correo electrónico.

El correo electrónico de confirmación del pedido es enviado también en formato texto.

Temas relacionados:
- | Carrito de la compra de comercio electrónico| Sección Datoss del Cliente
- | Ventana Tipo de envío
- | Ventana Tipo de pago
- | Estilos y Plantillas| Sección correo electrónico


Qué hacer para poder usar Google Webmaster Central

Google Webmaster Central es una suite de herramientas puesta a disposición gratuitamente por Google para permitir a los Webmaster hacer los sitios conformes a sus indicaciones. Estas herramientas sirven para descubrir cómo Google ve un sitio y sirven de ayuda para diagnosticar eventuales problemas: si son empleadas correctamente pueden ayudar a mejorar la visibilidad del Sitio en el Motor.

Para poder utilizar Google Webmaster Central es preciso, en primer lugar, tener un propio Account Google y, después, demostrar ser realmente el propietario del Sitio que se desea analizar. Uno de los métodos para demostrar ser el propietario de un Sitio, es copiar un metatag suministrado por Google y pegarlo en Página de inicio del Sitio en la primera sección <head> de la Página, antes de la sección <body>.

Resumiendo, los pasos a seguir son:

-

Tener una cuenta en Google.

-

Acceder a la página de presentación de Google Webmaster Central y hacer el login.

-

En la página Home hacer clic en el botón Agregar un sitio, escribir la URL del Sitio que se desea controlar y confirmar haciendo clic en Continuar.

-

En la página Verificación propiedad a la que se accede,elegir como método de verificación Agregar un metatag a la home page de tu sitio.

-

Copiar el metatag proporcionado por Google y pegarlo en el campo Metatag de verificación para Google Webmaster Central de la ventana Ajustes Generales| Sección Avanzado de WebSite X5: el Programa se preocupará de insertar el metatag en la posición correcta dentro del código HTML de la Página de inicio.

El metatag de control proporcionado por Google se presenta como en el ejemplo siguiente:
<meta name="verify-v1" content="VOPYsjbR4uw/YqV + MWLB0lVmJt0niwdkv9PQTsTREHQ="/>

-

Después de haber publicado el Sitio en línea, regresar a esta misma página de Google Webmaster Central y terminar el procedimiento haciendo clic en Verificación.

Temas relacionados:

-

Ajustes Generales| Sección Avanzado


Cómo activar un servicio de estadísticas como, por ejemplo, Google Analytics

En la red hay numerosos servicios de estadísticas disponibles y, entre éstos, uno de los más conocidos es el proporcionado por Google: Google Analytics. Gracias a esta herramienta, completamente gratuita, es posible disponer de numerosos informes para controlar y analizar, incluso detalladamente, los accesos al sitio. Google Analytics puede ser utilizado a distintos niveles: se puede empezar detectando simplemente el número de visitas o, ir más allá, explorando la evolución de las campañas publicitarias llevadas adelante con el programa Google Adsense.

Para poder aprovechar Google Analytics es preciso decir al Motor qué Sitio se desea analizar y, concretamente, qué Páginas deben ser tenidas bajo control: para hacer esto es preciso introducir un código de control en el interior del código de las páginas del sitio.

Resumiendo, los pasos a seguir son:

-

Tener una cuenta en Google.

-

Acceder a la página de presentación de Google Analytics y hacer el login.

-

En la página Ajustes Analytics insertar el sitio que se desea controlar utilizando el comando Agregar nuevo perfil.

-

Una vez creado el perfil, en la página Panorámica hacer clic en el botón Modificar presente en la columna Acciones para el Sitio Web que se desea modificar.

-

En la página de Ajustes del perfil a la que se accede, se avisa de que se trata de un "Control desconocido": hacer clic en Verificación estado para ver el código que utilizar para la control de las páginas.

-

Copiar el código para el control proporcionado por Google y pegarlo en el campo Código para la activación de la estadística de la ventana Ajustes Generales| Sección Avanzado de WebSite X5: el Programa se preocupará de insertar el metatag en la posición correcta dentro del código HTML de las Páginas del Sitio.

El código para el control proporcionado por Google se presenta como en el ejemplo siguiente:
<script type="text/javascript">
var gaJsHost = (("https:" ¿== document.location.protocol)? " https://ssl." : " http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
try {
var pageTracker = _gat._getTracker("UA-110367-1");
pageTracker._trackPageview();
} catch(err) {}</script>

Temas relacionados:

-

Ajustes Generales| Sección Avanzado


Cómo crear y conectar el SiteMap del Sitio

WebSite X5 puede generar el SiteMap XML del Sitio y conectarlo al código HTML de las Páginas mediante el metatag <sitemap>.

Un SiteMap no es otra cosa que un archivo XML que contiene la lista de las Páginas de un Sitio: ha sido introducido por Google (y ahora es utilizado también por Yahoo Y MSN) para efectuar una mejor y más rápida escansión de los Sitios Web. En otras palabras, creando y enviando el SiteMap, los Webmaster pueden asegurarse de que un Motor de búsqueda, en concreto Google, sepa de todas las Páginas presentes en un Sitio, incluídas aquellas que correrían el riesgo de no ser localizadas mediante un procedimiento de escansión normal.

Mediante el SiteMap es posible dirigir a los Motores de búsqueda también informaciones relativas a los contenidos del Sitio como vídeos, imágenes, noticias, etc. Además, el SiteMap puede contener informaciones adicionales como: la frecuencia con la que es actualizada cada Página; la fecha de la última modificación de las Páginas; la importancia de cada página en la economía del Sitio (dicha prioridad no influye en el colocamiento de las páginas en los resultados de las búsquedas).

Consejos Práticos - Activar el SiteMap

Para generar y conectar el SiteMap a un Sitio basta dejar activa, por defecto, la opción Crear SiteMap automáticamente presente en Ajustes Generales| Sección Avanzado.

Una vez hecho esto, es posible hacer que en el SiteMap se introduzcan algunas informaciones adicionales, específicas para cada Página, del siguiente modo:

- | En el Paso 2 - Creación del Mapa seleccionar la Página en que trabajar.
- | hacer clic en el botón [image] para abrir la ventana Propiedades de Página y abrir la sección Avanzado.
- | Predisponer la Frecuencia de actualización y la Prioridad del contenido.
- | Repetir estas operaciones para las distintas Páginas del Sitio.

Consejos Práticos - Agregar las Imágenes en el SiteMap

El SiteMap puede ser utilizado también para pasar a Google informaciones adicionales sobre las imágenes presentes en un Sitio, ayudándolo así a encontrar imágenes que de otro modo no podría encontrar (por ej., porque están incluídas en módulos JavaScript) y a comprender cuáles son más importantes respecto a otras. No insertando en el SiteMap las imágenes que forman parte de la plantilla gráfica o que tienen un puro valor ornamental, por ejemplo, se indica a Google que son menos importantes de las demás.

Google especifica que dentro de un SiteMap es posible insertar un máximo de 1000 imágenes para cada Página y que, en cualquier caso, no se garantiza la indexación de todas las imágenes o el uso de todas las informaciones insertadas.

Una vez activada la creación del SiteMap, es posible añadir las informaciones a una imagen de modomuy simple:

- | Hacer doble clic en el Objeto Imagen relativo a la Imagen en que se desea trabajarpara poder acceder a la ventana Objeto Imagen.
- | Abrir la sección SiteMap y activar la opción Agregar imagen al SiteMap.
- | Facultativamente, compilar los campos Título, Descripción breve, Posición geográfica y URL del archivo de licencia.
- | Repetir las operaciones descritas para todas las Imágenes importantes contenidas en el Sitio.

Para más información, ver Objeto Imagen | Sección SiteMap.

Consejos Práticos - Agregar las informaciones sobre los Vídeos en el SiteMap

El SiteMap puede ser utilizado también para pasar a Google informaciones sobre los vídeos presentes en un Sitio. También en este caso, aunque Google no da garantías, la inserción de los vídeos en el SiteMap puede hacer que estos contenidos puedan ser más fácilmente detectados y, de consecuencia, incluídos en la búsqueda de Google Vídeos.

Mediante el SiteMap es posible especificar una serie de informaciones adicionales, como por ejemplo título, descripción y duración del vídeo, que pueden simplificar la búsqueda. Así pues, éstas y otras informaciones son propuestas en las Páginas con los resultados de las búsquedas (SERP). Pero hay que subrayar que, en caso de diferencias, Google podría decidir utilizar en las SERP el texto disponible en la páginas del vídeo, en lugar de los contenidos predispuestos mediante el SiteMap.

Para completar el SiteMap del Sitio añadiendo las informaciones en los vídeos presentes, basta proceder del siguiente modo:
- | Hacer doble clic en el Objeto Vídeo relativo al Vídeo en que se desea trabajar para acceder a la ventana Objeto Vídeo/Sonido.
- | Abrir la sección SiteMap y activar la opción Agregar vídeo al SiteMap.
- | Introducir las informaciones que deben estar presentes obligatoriamente en el SiteMap: Título, Descripción breve y Imagen de vista previa.
- | Facultativamente, definir también los siguientes parámetros: Categoría, Palabras clave, Fecha de publicación, Duración y Contenido adecuado a menores de edad.
- | Repetir las operaciones descritas para todos los Vídeos importantes contenidos en el Sitio.

 Para más información, ver Objeto Vídeo/Sonido | Sección SiteMap.

Consejos Práticos - Eliminar una página del SiteMap

Por defecto, una vez activada la creación del SiteMap, todas las Páginas de un Sitio son incluídas en él. En cualquier caso, si se desea que los Motores de búsqueda no tomen en consideración una o más páginas, basta eliminarlas del SiteMap. Para hacer esto basta:
- | En la ventana Creación del mapa (Paso 2), seleccionar la página que se desea eliminar del SiteMap.
- | hacer clic en el botón [image] para abrir la ventana Propiedades de página y abrir la sección Avanzado.
- | Quitar la marca de la opción Agregar esta Página al SiteMap.
- | Confirmar y guardar.

Temas relacionados:
- | Ajustes Generales| Sección Avanzado
- | Creación del mapa| Propiedades de la página| Sección Avanzado
- | Objeto Imagen| Sección SiteMap
- | Objeto Vídeo| Sección SiteMap


Blog| Panel de Control

Panel de Control

Para cada Sitio realizado, WebSite X5 predispone automáticamente un Panel de control en línea útil para permitir al Administrador cumplir operaciones como: manejar los comentarios dejados por los usuarios a los post del Blog o los mensajes insertados en la Guestbook, tener algunas informaciones de diagnóstico sobre el Sitio, visualizar informaciones sobre la optimización para los Motores de búsqueda.

Al Panel de control pueden acceder todos los usuarios presentes en el Grupo Administradores en la sección Gestión accesos disponible en el Paso 4 - Ajustes avanzados.

Para acceder al Panel de Control basta:
- | Conectarse al URL www.misitio.es/admin donde www.misitio.es es la URL del Sitio.
- | Hacer el login utilizando las propias credenciales de acceso (Login y Contraseña).

Una vez hecho el login, el Panel de Control presenta algunas secciones:

-

Blog: permite manejar los comentarios dejados por los usuarios como respuesta a los Post del Blog conectado al Sitio Web. (ver Cómo manejar los comentario a los Post del Blog mediante el Panel de Control en línea)

-

Guestbook: permite manejar los mensajes dejados por los usuarios en el Guestbook insertado en el Sitio Web mediante el especial Widget disponible en el Objeto HTML y Widgets.

-

Prueba WebSite: permite visualizar algunas informaciones de diagnóstico relativas al Sitio Web y al Servidor en el que esto ha sido publicado. Concretamente los controles efectuados se refieren a:
- | Versión de PHP instalada - Para que funcione correctamente el envío de los correos electrónico previstos para el Objeto Formulario de envío de correo electrónico y para el Carrito de la compra de comercio electrónico, así como el acceso a las Páginas protegidas mediante login y Contraseña es necesario que el Servidor soporte el lenguaje PHP. Después, se verifica si el Servidor ofrece dicho soporte y, en caso afirmativo, es especifica qué versión de PHP es soportada.
- | Soporte sesiones - Además del soporte para el PHP, para que el acceso a las Páginas protegidas sea permitido sólo después de la inserción de las correctas credenciales de acceso, es necesario que el Servidor soporte también las sesiones.
- | Carpeta con acceso en escritura - Para poder archivar y manejar los comentarios a los Post del Blog y, más en general, para el funcionamiento de los Widget (ver Objeto HTML y Widgets) que requieren la recogida de datos, es necesario indicar una carpeta en el Servidor para la cual está permitida la escritura mediante la opción correspondiente disponible en Blog| Sección Comentarios. Se verifica primero que la carpeta con acceso en escritura indicada exista realmente y, en caso afirmativo, que en la carpeta indicada esté permitida la escritura de datos.
- | Soporte MySQL y ajustes base de datos - Al predisponer un Objeto Formulario de envío de correo electrónico es posible especificar como método de invio de los datos "Enviar los datos a una Base de datos" (ver Objeto Formulario de envío de correo electrónico| Sección Enviar): en este caso es preciso proporcionar los parámetros para poderse conectar a la Base de datos en Servidor que utilizar. Después, se verifica que el Servidor soporte MySQL y, en caso afirmativo, que los parámetros especificados permitan realmente acceder y operar en la Base de datos.

-

SEO: permite visualizar algunos resultados relativos a la indexación del Sitio por parte de los Motores de búsqueda. Concretamente, aparece el estado del Sitemap, las Claves de búsqueda indexadas y los mensajes restituidos por GoogleBot (el spider Web de Google que barre la Web para actualizar los índices).

Temas relacionados:
- | Blog
- | Cómo manejar los comentarios a los Post del Blog mediante el Panel de Control en línea
- | Objeto HTML y Widgets


Cómo gestionar los comentarios del Blog desde el Panel de control

Un Blog es una especie de diario en red mediante el que es posible publicar noticias de varios tipos y dar la posibilidad a los lectores de dejar comentarios. Si la comunidad de los lectores es activa y adecuadamente estimulada por la calidad de los post, es posible que se desarrollen interesantes discusiones a tema.

Para dar la posibilidad a los lectores de dejar los comentarios a los post publicados es necesario, en primer lugar, configurar el Blog mediante las opciones presentes en la Sección Comentarios de la ventana Blog. En particular, es preciso:
- | Activar la opción Permitir la introducción de comentarios a las Noticias del blog.
- | Especificar la ruta de acceso de la Carpeta en el Servidor con acceso en escritura, o sea, de la carpeta dentro de la cual está habilitada la escritura de los archivos por parte del código PHP.
- | Decidir si activar el control anti-spam "Captcha" para la inserción de Comentarios.
- | Especificar el Correo electrónico para envío de aviso recepción comentarios, o sea, la dirección de correo electrónico en la que se desea recibir los correos que son enviados en automático para avisar de que un lector ha dejado un nuevo comentario.
- | Especificar si los comentarios pueden ser publicados en línea enseguida o si deben ser aprobados antes.

Una vez hecho esto es posible proceder a insertar los post y a la publicación del Blog. Al fondo de los post de la Blog se introducirá automáticamente un formulario mediante el cual los lectores podrán componer y enviar sus comentarios. Mediante dicho form se solicitan: Nombre, Correo electrónico, Sitio Internet y Mensaje. Exceptuando el correspondiente al Sitio Internet, todos los campos son obligatorios.

A continuación, en cuanto un lector deje un comentario, se creará automáticamente un correo de notificación que se enviará a la dirección de correo electrónico especificada. Si se ha activado la opción Visualizar comentarios después de aprobación desde Panel de control, para que el comentario sea visualizado en línea en la parte inferior del post al que hace referencia, es necesario que sea aprobado mediante el comando especial del Panel de control que es automáticamente creado por WebSite X5.

 El Panel de control está disponible en la URL www.misitio.es/admin, donde www.misitio.es es la URL del sitio al que está conectado el Blog , y está a disposición de todos los usuarios insertados en el grupo Administrador en la sección Gestión accesos disponible en el Paso 4 - Ajustes avanzados.

En la sección Blog del Panel de control están disponibles dos menús desplegables que proponen la lista de las categorías y las listas de artículos a él conectadas. Mediante estos menús, es posible identificar el post del que se desean visualizar los comentarios recibidos. A continuación, se presenta la lista de los comentarios: para cada comentario aparece su autor, su dirección de correo electrónico, el texto del comentario, la fecha y la hora a la que ha sido enviado. Si la información está disponible, sobre el nombre del autor aparece predispuesto automáticamente el enlace a su Sitio Internet.

Al contrario de cuanto ocurre en el Blog, donde los comentarios son visualizados en base al orden de inserción (el último insertado queda al fondo de la lista), en el Panel de control los comentarios son visualizados en orden cronológico, empezando por el más reciente.

Así pues, para proceder a la gestión de los comentarios es necesario:

-

Acceder al Panel de control en línea, hacer el login y, después, abrir la sección Blog.

-

Identificar el post del que se desean visualiar los comentarios mediante los menús desplegables que proponen la lista de las categorías previstas y de los relativos post insertados.

-

Deslizar la lista de los comentarios recibidos para el post seleccionado y gestionar la visualización de los comentarios en el Blog mediante los comandos:
- | Eliminar: para eliminar el comentario dejado que, además de no ser publicado en el Blog, es cancelado también de la lista de los comentarios en el Panel de control.
- | Aprueba/Desaprueba: para aprobar un comentario, y por lo tanto permitir que sea visualizado en el Blog, o desaprobarlo, y por lo tanto eliminarlo de la lista de los post visualizados en el Blog. Un comentario desaprobado no es cancelado de las listas presentadas en el Panel de control.
Tener la posibilidad de gestionar la visualización de los comentarios en el Blog es fundamental para tutelarse de acciones de spam y para moderar las discusiones eliminando mensajes considerados ofensivos, que no tienen que ver con el tema o que no están en línea con el estilo que se desea mantener.

Temas relacionados:
- | Blog | Sección Comentarios
- | Panel de control


Información y soporte

es un producto Incomedia
 www.websitex5.com
 www.incomedia.eu

Copyright 2011 Incomedia. All rights reserved.

WebSite X5 utiliza DotNetZip que está cubierto por Licencia Ms-PL (Microsoft Public License)

Para mayores informaciones y para obtener soporte técnico visitar el sitio: www.websitex5.com/help


Microsoft Public License (Ms-PL)

This license governs use of the accompanying software. If you use the software, you accept this license. If you do not accept the license, do not use the software.

1. Definitions

The terms "reproduce," "reproduction," "derivative works," and "distribution" have the same meaning here as under U.S. copyright law.

A "contribution" is the original software, or any additions or changes to the software.

A "contributor" is any person that distributes its contribution under this license.

"Licensed patents" are a contributor's patent claims that read directly on its contribution.

2. Grant of Rights

(A) Copyright Grant- Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free copyright license to reproduce its contribution, prepare derivative works of its contribution, and distribute its contribution or any derivative works that you create.

(B) Patent Grant- Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free license under its licensed patents to make, have made, use, sell, offer for sale, import, and/or otherwise dispose of its contribution in the software or derivative works of the contribution in the software.

3. Conditions and Limitations

(A) No Trademark License- This license does not grant you rights to use any contributors' name, logo, or trademarks.

(B) If you bring a patent claim against any contributor over patents that you claim are infringed by the software, your patent license from such contributor to the software ends automatically.

(C) If you distribute any portion of the software, you must retain all copyright, patent, trademark, and attribution notices that are present in the software.

(D) If you distribute any portion of the software in source code form, you may do so only under this license by including a complete copy of this license with your distribution. If you distribute any portion of the software in compiled or object code form, you may only do so under a license that complies with this license.

(E) The software is licensed "as-is." You bear the risk of using it. The contributors give no express warranties, guarantees or conditions. You may have additional consumer rights under your local laws which this license cannot change. To the extent permitted under your local laws, the contributors exclude the implied warranties of merchantability, fitness for a particular purpose and non-infringement.